Bug 603782 - Tracker generates "Could not add monitor for path" errors
Summary: Tracker generates "Could not add monitor for path" errors
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: tracker (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Deji Akingunola
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-14 15:08 UTC by Matthew Garrett
Modified: 2013-01-10 07:50 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-21 15:12:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 621568 None None None Never

Description Matthew Garrett 2010-06-14 15:08:10 UTC
~/.local/share/tracker/tracker-miner-fs.log contains over 60,000 errors similar to

14 Jun 2010, 09:30:24: Tracker-Warning **: Could not add monitor for path:'/home/mjg59/Source/iphonelinux-kernel/drivers/scsi/qla2xxx'

Tracker is configured to ignore ~/Source.

Comment 1 Deji Akingunola 2010-06-18 13:50:33 UTC
Upstream developers need both ~/.config/tracker/tracker-miner-fs.cfg and
~/.config/user-dirs.dirs files in order to know what's wrong. Full logs are
also appreciated, since they often contain much more info than what a single
line can provide.

Comment 2 Matthew Garrett 2010-06-18 13:59:07 UTC
The errors go away if I increase the number of possible inotify watches, so I think it's simply that I have too many directories.

Comment 3 Deji Akingunola 2010-06-21 15:12:55 UTC
Upstream say the bug has been fixed in the development tree. Not sure if it will back-ported to tracker-0.8.x series.


Note You need to log in before you can comment on or make changes to this bug.