Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 603797 - [NVa3] Display hangs (X repeatedly get ERESTARTSYS from ioctl calls) then system hangs
[NVa3] Display hangs (X repeatedly get ERESTARTSYS from ioctl calls) then sys...
Status: CLOSED DUPLICATE of bug 626973
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-14 11:34 EDT by Andrew Parker
Modified: 2018-04-11 02:51 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-17 18:24:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesh shortly after hang (121.32 KB, text/plain)
2010-06-22 12:29 EDT, Andrew Parker
no flags Details
/var/log/messages shortly after a hang (67.04 KB, text/plain)
2010-06-22 12:31 EDT, Andrew Parker
no flags Details
Xorg.0.log shortly after a hang (106.70 KB, text/plain)
2010-06-22 12:31 EDT, Andrew Parker
no flags Details

  None (edit)
Description Andrew Parker 2010-06-14 11:34:12 EDT
Description of problem:

Anywhere from an hour after logging in up to a couple of days, my display will hang.  Frequently I am still able to log in from another host for a few minutes, but that is not always the case.

Version-Release number of selected component (if applicable):
xorg-x11-drv-nv-2.1.15-5.fc13.i686

How reproducible:
always


Additional info:

When I am able to log in, if I strace X, I see the following in rapid succession:

octl(8, 0x40086482, 0xbfd94e18)        = ? ERESTARTSYS (To be restarted)
--- SIGALRM (Alarm clock) @ 0 (0) ---
sigreturn()                             = ? (mask now [])
ioctl(8, 0x40086482, 0xbfd94e18)        = ? ERESTARTSYS (To be restarted)
--- SIGALRM (Alarm clock) @ 0 (0) ---
sigreturn()                             = ? (mask now [])
ioctl(8, 0x40086482, 0xbfd94e18)        = ? ERESTARTSYS (To be restarted)
--- SIGALRM (Alarm clock) @ 0 (0) ---
sigreturn()                             = ? (mask now [])
ioctl(8, 0x40086482, 0xbfd94e18)        = ? ERESTARTSYS (To be restarted)
--- SIGALRM (Alarm clock) @ 0 (0) ---
sigreturn()                             = ? (mask now [])
ioctl(8, 0x40086482, 0xbfd94e18)        = ? ERESTARTSYS (To be restarted)
--- SIGALRM (Alarm clock) @ 0 (0) ---
sigreturn()                             = ? (mask now [])
ioctl(8, 0x40086482, 0xbfd94e18)        = ? ERESTARTSYS (To be restarted)
--- SIGALRM (Alarm clock) @ 0 (0) ---
sigreturn()                             = ? (mask now [])
ioctl(8, 0x40086482, 0xbfd94e18)        = ? ERESTARTSYS (To be restarted)
--- SIGALRM (Alarm clock) @ 0 (0) ---
sigreturn()                             = ? (mask now [])
ioctl(8, 0x40086482, 0xbfd94e18)        = ? ERESTARTSYS (To be restarted)
--- SIGALRM (Alarm clock) @ 0 (0) ---
sigreturn()                             = ? (mask now [])

[root@bb local]# ls /proc/2040/fd/8 -l
lrwx------ 1 root root 64 Jun 14 11:31 /proc/2040/fd/8 -> /dev/dri/card0

[root@bb local]# lspci | grep VGA
01:00.0 VGA compatible controller: nVidia Corporation GT215 [GeForce GT 240] (rev a2)
Comment 1 Matěj Cepl 2010-06-20 17:44:53 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please add drm.debug=0x04 to the kernel command line, restart computer, and attach

* your X server config file (/etc/X11/xorg.conf, if available),
* X server log file (/var/log/Xorg.*.log)
* output of the dmesg command, and
* system log (/var/log/messages)

to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Andrew Parker 2010-06-22 12:29:33 EDT
Created attachment 426003 [details]
dmesh shortly after hang
Comment 3 Andrew Parker 2010-06-22 12:31:11 EDT
Created attachment 426004 [details]
/var/log/messages shortly after a hang
Comment 4 Andrew Parker 2010-06-22 12:31:46 EDT
Created attachment 426005 [details]
Xorg.0.log shortly after a hang
Comment 5 Andrew Parker 2010-06-22 12:33:53 EDT
I do not have aconfig file for Xorg

If I remove this card, and use an onboard Intel card, I do not get any problems:

00:02.0 VGA compatible controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)
Comment 6 Ben Skeggs 2011-03-17 18:24:53 EDT
The only known workaround for this problem is "nouveau.noaccel=1" in your boot options.  There's evidence to suggest that *maybe* F15 is better, but it's not conclusive yet.  However, my laptop with one of these chipsets is stable and shows no signs of the problem.

*** This bug has been marked as a duplicate of bug 626973 ***

Note You need to log in before you can comment on or make changes to this bug.