Bug 60389 - pine mailbox listing omits case variants
pine mailbox listing omits case variants
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: pine (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-27 01:50 EST by Chris Ricker
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-02 22:09:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2002-02-27 01:50:28 EST
pine does not deal correctly with multiple mboxes whose names differ only by
case.  For example, I have pine on this system configured as follows:

inbox-path=Mail/Inbox
folder-collections=Mail/[]
default-fcc=Sent-mail

(all mail delivery to ~/Mail using mboxes, main mbox is ~/Mail/Inbox, sent mail
is copied to ~/Mail/Sent-mail)

Most, but not all, mboxes in ~/Mail are displayed in the folder list (start
pine, press L).  The mbox ~/Mail/Inbox is displayed as INBOX (which is correct),
while the mbox ~/Mail/inbox is not displayed at all (which is broken).  This
appears to be a special casing only for the case-insensitive string "inbox",
since both ~/Mail/Sent-mail and ~/Mail/sent-mail do display.
Comment 1 Mike A. Harris 2002-03-07 01:47:24 EST
Did you recompile PINE with mbox support?
Comment 2 Chris Ricker 2002-03-07 09:45:05 EST
Um, RH ships it compiled with mbox support.
Comment 3 Mike A. Harris 2002-03-07 11:43:31 EST
Hmm, I wonder how that managed to slip through...  damn.  We disabled
mbox support ages ago, and do not at all support it.  I'll have to double
check what happened that re-enabled it.
Comment 4 Chris Ricker 2002-03-07 11:50:48 EST
I'm confused.  How would pine even be usable as anything other than an IMAP /
POP client if it didn't support mboxes?
Comment 5 Mike A. Harris 2002-03-07 12:05:50 EST
Perhaps there is a bit of confusion..  I am refering to mbox as the file
~/mbox which if it exists when PINE starts up, PINE will promptly copy
the contents of /var/spool/mail/$USER to ~/mbox

That is what we do not support, since it causes a lot of users a lot of
problems, and creates a lot of support problems for us.  If this is not
related to your problem, then I've misunderstood.

BTW, what version(s) of PINE do you see this problem in?
Comment 6 Chris Ricker 2002-03-07 12:16:00 EST
Ah, okay.  I meant (and read your) "mbox" as meaning "standard mbox Unix mail
spool file format" (versus things like Maildir or Maildir++ format mail files).

I noticed this with pine-4.44, but it's probably broken in older releases too.
Comment 7 Chris Ricker 2002-03-23 02:20:28 EST
This is still true with the pine in the skipjack public beta (4.44-6)
Comment 8 chappa 2002-04-02 22:09:15 EST
The problem is not the format of the folder, the problem is that Pine won't let
you create a folder containing the forbidden word "INBOX" (regardless of case).
The string "INBOX" is a reserved word for the folder where you receive your
mail, regardless of the real name (as a file) that that folder may have (e.g.
/var/spool/mail/foo could be called INBOX), and you never see "foo" in your list
of folders.

As far as I understand this is not a bug in Pine, I would say, that Pine is not
being helpful in clarifying this point though.
Comment 9 Mike A. Harris 2002-04-03 09:53:57 EST
Thanks Ed, indeed I've looked at this too now and this is intentional
operation of PINE.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.