Bug 603902 - Request addition of UPEK Eikon II support
Request addition of UPEK Eikon II support
Status: CLOSED DUPLICATE of bug 504399
Product: Fedora
Classification: Fedora
Component: libfprint (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-14 15:31 EDT by P Rauser
Modified: 2010-08-17 14:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-17 14:22:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch to libfprint-0.1.0-pre2 (55.57 KB, patch)
2010-06-14 15:31 EDT, P Rauser
no flags Details | Diff

  None (edit)
Description P Rauser 2010-06-14 15:31:48 EDT
Created attachment 423966 [details]
Patch to libfprint-0.1.0-pre2

Description of problem:

UPEK Eikon II reader not supported in current version of libfprint.


Additional info:

Upek Eikon model TCRD4C4 (aka "Eikon II") fingerprint reader device not supported by upstream libfprint.  This Eikon II device is the fingerprint reader now being installed by Lenovo on recent T-series Thinkpads, among several others.

Jorge Suárez de Lis has written a patch (discussed in the libfprint mailing list).  A copy of the patch is attached.
Comment 1 Bastien Nocera 2010-08-17 14:22:13 EDT
That will not work, unless you do not compile the upeksonly device driver:
$ grep -r 0x2016 . | grep 0x147e
./drivers/upeksonly.c:	{ .vendor = 0x147e, .product = 0x2016 },
./eikonII.patch:+	{ .vendor = 0x147e, .product = 0x2016 },

As those use the same device ID.

Bug 504399 has updated patches, and some discussion on how to handle both drivers.

*** This bug has been marked as a duplicate of bug 504399 ***

Note You need to log in before you can comment on or make changes to this bug.