Bug 603903 - Intermittent plugin registration/update failure - HibernateException: Javassist Enhancement failed
Intermittent plugin registration/update failure - HibernateException: Javassi...
Status: CLOSED DUPLICATE of bug 616395
Product: RHQ Project
Classification: Other
Component: Core Server (Show other bugs)
3.0.0
All All
medium Severity high (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Corey Welton
:
Depends On:
Blocks: jon-sprint11-bugs
  Show dependency treegraph
 
Reported: 2010-06-14 15:38 EDT by Jay Shaughnessy
Modified: 2010-07-20 16:59 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Oracle 10g XE
Last Closed: 2010-07-20 16:59:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
failed server statup (134.01 KB, text/x-log)
2010-06-14 15:40 EDT, Jay Shaughnessy
no flags Details

  None (edit)
Description Jay Shaughnessy 2010-06-14 15:38:21 EDT
I think this may happen when a new version of a plugin is being registered. It may not actually have to be different from the db version of the plugin. I'm not sure.

Anyway, during plugin registration you get a failure (full trace attached) with a root cause like the following:

Caused by: org.hibernate.HibernateException: Javassist Enhancement failed: org.rhq.core.domain.plugin.Plugin
        at org.hibernate.proxy.pojo.javassist.JavassistLazyInitializer.getProxy(JavassistLazyInitializer.java:118)
        at org.hibernate.proxy.pojo.javassist.JavassistProxyFactory.getProxy(JavassistProxyFactory.java:48)
        at org.hibernate.tuple.entity.AbstractEntityTuplizer.createProxy(AbstractEntityTuplizer.java:379)
        at org.hibernate.persister.entity.AbstractEntityPersister.createProxy(AbstractEntityPersister.java:3460)
        at org.hibernate.event.def.DefaultLoadEventListener.createProxyIfNecessary(DefaultLoadEventListener.java:257)
        at org.hibernate.event.def.DefaultLoadEventListener.proxyOrLoad(DefaultLoadEventListener.java:191)
        at org.hibernate.event.def.DefaultLoadEventListener.onLoad(DefaultLoadEventListener.java:103)
        at org.hibernate.impl.SessionImpl.fireLoad(SessionImpl.java:878)
        at org.hibernate.impl.SessionImpl.load(SessionImpl.java:795)
        at org.hibernate.impl.SessionImpl.load(SessionImpl.java:788)
        at org.hibernate.ejb.AbstractEntityManagerImpl.getReference(AbstractEntityManagerImpl.java:153)
        ... 94 more
Caused by: java.lang.NullPointerException
        at javassist.util.proxy.RuntimeSupport$DefaultMethodHandler.invoke(RuntimeSupport.java:37)
        at org.rhq.core.domain.plugin.Plugin_$$_javassist_68.setDeployment(Plugin_$$_javassist_68.java)
        at org.rhq.core.domain.plugin.Plugin.<init>(Plugin.java:205)
        at org.rhq.core.domain.plugin.Plugin_$$_javassist_68.<init>(Plugin_$$_javassist_68.java)
        at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
        at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
        at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
        at java.lang.reflect.Constructor.newInstance(Constructor.java:513)
        at java.lang.Class.newInstance0(Class.java:355)
        at java.lang.Class.newInstance(Class.java:308)
        at org.hibernate.proxy.pojo.javassist.JavassistLazyInitializer.getProxy(JavassistLazyInitializer.java:115)
        ... 104 more


I don't currently have any reproduction steps, but I've seen this more than once.  The server startup continues but is most likely invalid from that point on.  A subsequent restart may normalize the situation but I'm not sure.
Comment 1 Jay Shaughnessy 2010-06-14 15:40:04 EDT
Created attachment 423967 [details]
failed server statup
Comment 2 Charles Crouch 2010-06-18 09:25:22 EDT
Dropping priority until able to reproduce
Comment 3 Jay Shaughnessy 2010-07-20 16:59:47 EDT
I believe the root cause for this is the same as 616395. Closing as duplicate.

*** This bug has been marked as a duplicate of bug 616395 ***

Note You need to log in before you can comment on or make changes to this bug.