Bug 60391 - NT reboots when launched with GRUB
NT reboots when launched with GRUB
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: grub (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-27 05:28 EST by Didier Arenzana
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-27 11:49:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Didier Arenzana 2002-02-27 05:28:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT)

Description of problem:
When I install GRUB on the MBR of my harddisk or on a floppy to dual-boot 
between linux and NT4, if I choose NT at the boot, Nt starts to load, and then 
reboots without any message.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.install grub on /dev/hda or /dev/fd0
2.reboot, choose Windows NT
3.
	

Actual Results:  Windows NT starts loading, prompts me the usual (normal or VGA 
mode, then which hardware profile I want to load); then goes into the blue 
screen initialisation, prints the usual version information string, does some 
hard disk activity, and then the machine reboots.

Expected Results:  NT should finish loading, and show me the login screen

Additional info:

If I start linux the same way, no problem at all.
If I restore the original MBR on the harddisk (I saved it with dd if=/dev/hda 
of=mbr.sav bs=512 count=1; I restore it with dd if=mbr.sav of=/dev/hda bs=512 
count=1), NT loads without trouble.
I haven't tried LILO yet. The hardware is a compaq notebook Evo N400c.
Windows NT is on hda1, NTFS formated, it's an NT4 SP6.
Comment 1 Jeremy Katz 2002-02-27 10:51:31 EST
This does actually work in the general case.  It's possible you're hitting a
strange BIOS interaction, in which case it might be fixed in the newer GRUB
packages at http://people.redhat.com/~katzj/grub/.  If you install the i386
package and then run '/sbin/grub-install /dev/hda` (substitute whereever you
installed grub for /dev/hda) and see if that works, I'd appreciate it.

Otherwise, I'll need to know a bit more information about your hardware as well
as whether it works with LILO or not
Comment 2 Didier Arenzana 2002-02-27 11:49:32 EST
Hi,
I tried with the newer grub package (0.91-1.7x); and now everything works just 
fine.
Thank you very much for your help.
Comment 3 Jeremy Katz 2002-02-27 11:51:57 EST
Great!

Note You need to log in before you can comment on or make changes to this bug.