Bug 603919 - AutoDiscovery: ClassNotFoundException: org.rhq.core.pluginapi.inventory.ManualAddFacet
Summary: AutoDiscovery: ClassNotFoundException: org.rhq.core.pluginapi.inventory.Manua...
Status: CLOSED NOTABUG
Alias: None
Product: RHQ Project
Classification: Other
Component: Agent   
(Show other bugs)
Version: 1.3.1
Hardware: All
OS: Linux
medium
medium vote
Target Milestone: ---
: ---
Assignee: John Sanda
QA Contact: Corey Welton
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: jon-sprint11-bugs
TreeView+ depends on / blocked
 
Reported: 2010-06-14 21:09 UTC by JiraBot
Modified: 2010-07-07 02:36 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-07 02:36:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description JiraBot 2010-06-14 21:09:20 UTC
STR:

1) Install JON 2.3.0 and JBoss AS/EAP plugins
2) Install EAP 4.2.0 and let an agent monitor it
3) tail -f rhq_agent/logs/rhq_agent.log
4) Wait for this exception:

...
2010-06-14 23:00:38,484 INFO  [InventoryManager.discovery-1] (rhq.core.pc.inventory.AutoDiscoveryExecutor)- Executing server discovery scan...
2010-06-14 23:00:47,699 INFO  [ResourceDiscoveryComponent.invoker.daemon-2597] (org.rhq.plugins.agent.AgentDiscoveryComponent)- Discovering RHQ Agent...
2010-06-14 23:00:47,719 ERROR [InventoryManager.discovery-1] (rhq.core.pc.inventory.AutoDiscoveryExecutor)- Error in auto discovery
java.lang.NoClassDefFoundError: org/rhq/core/pluginapi/inventory/ManualAddFacet
        at java.lang.ClassLoader.defineClass1(Native Method)
        at java.lang.ClassLoader.defineClass(ClassLoader.java:616)
        at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124)
        at java.net.URLClassLoader.defineClass(URLClassLoader.java:260)
        at java.net.URLClassLoader.access$000(URLClassLoader.java:56)
        at java.net.URLClassLoader$1.run(URLClassLoader.java:195)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:303)
        at org.rhq.core.pc.plugin.PluginClassLoader.loadClass(PluginClassLoader.java:63)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:248)
        at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:316)
        at java.lang.Class.forName0(Native Method)
        at java.lang.Class.forName(Class.java:247)
        at org.rhq.core.pc.plugin.PluginComponentFactory.instantiateClass(PluginComponentFactory.java:228)
        at org.rhq.core.pc.plugin.PluginComponentFactory.getDiscoveryComponent(PluginComponentFactory.java:110)
        at org.rhq.core.pc.inventory.AutoDiscoveryExecutor.pluginDiscovery(AutoDiscoveryExecutor.java:170)
        at org.rhq.core.pc.inventory.AutoDiscoveryExecutor.call(AutoDiscoveryExecutor.java:104)
        at org.rhq.core.pc.inventory.AutoDiscoveryExecutor.run(AutoDiscoveryExecutor.java:92)
        at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
        at java.util.concurrent.FutureTask$Sync.innerRunAndReset(FutureTask.java:317)
        at java.util.concurrent.FutureTask.runAndReset(FutureTask.java:150)
        at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$101(ScheduledThreadPoolExecutor.java:98)
        at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.runPeriodic(ScheduledThreadPoolExecutor.java:181)
        at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:205)
        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
        at java.lang.Thread.run(Thread.java:619)
Caused by: java.lang.ClassNotFoundException: org.rhq.core.pluginapi.inventory.ManualAddFacet
        at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:303)
        at org.rhq.core.pc.plugin.PluginClassLoader.loadClass(PluginClassLoader.java:63)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:248)
        at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:316)
        ... 28 more
2010-06-14 23:00:47,722 INFO  [InventoryManager.discovery-1] (rhq.core.pc.inventory.AutoDiscoveryExecutor)- Process scan auto-detected new server resource: scan=[ProcessScan: query=[process|basename|match=^java.*,arg|org.jboss.Main|match=.*], name=[JBoss4]], discovered-process=[process: pid=[20301], name=[/mnt/jqa/jdk1.6.0_17-x86_64/bin/java], ppid=[20275]]
...

Comment 1 Charles Crouch 2010-06-18 16:31:28 UTC
I thought ManualAddFacet only came in 2.4?
We just need to verify this, in which case, this issue is likely a result of using a mismatched server/plugin version.

Comment 2 JiraBot 2010-06-18 17:23:12 UTC
I will check that.

Comment 3 John Sanda 2010-06-23 04:49:55 UTC
I checked both JON 2.3.1 and 2.3.0. ManualAddFacet is not included in either of those version, so it appears that it is in fact a new addition to 2.4.0.

Charles is there additional work that needs to be done with this bug?

Comment 4 Charles Crouch 2010-07-07 02:36:05 UTC
The only way this could occur is with mismatched server/agent versions


Note You need to log in before you can comment on or make changes to this bug.