Bug 603951 - StayOnScreen
StayOnScreen
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
anaconda_trace_hash:7ceeb6c8017e558fd...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-14 19:58 EDT by Brian Lane
Modified: 2010-07-22 16:31 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-22 16:31:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (84.22 KB, text/plain)
2010-06-14 19:58 EDT, Brian Lane
no flags Details

  None (edit)
Description Brian Lane 2010-06-14 19:58:30 EDT
The following was filed automatically by anaconda:
anaconda 14.8 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.6/site-packages/pyanaconda/iw/account_gui.py", line 83, in passwordError
    raise gui.StayOnScreen
  File "/usr/lib/python2.6/site-packages/pyanaconda/iw/account_gui.py", line 107, in getNext
    self.passwordError()
  File "/tmp/updates/pyanaconda/gui.py", line 1165, in nextClicked
    rc = self.currentWindow.getNext ()
StayOnScreen
Comment 1 Brian Lane 2010-06-14 19:58:33 EDT
Created attachment 423999 [details]
Attached traceback automatically from anaconda.
Comment 2 Brian Lane 2010-06-14 20:06:38 EDT
This happens if you don't enter a root password and click ok on the dialog that appears.
Comment 3 Ales Kozumplik 2010-06-15 04:22:26 EDT
I've run into this too. When you look into gui.py, there actually is an 'except StayOnScreen' clause just below the exception is thrown. The reason it's not catched there is that one exception is of type 'pyanaconda.gui.StayOnScreen' whereas the other one is simply 'gui.StayOnScreen'. I know I sound like a broken record, but this too is a a fault of how modules are imported at the moment.

Note You need to log in before you can comment on or make changes to this bug.