Bug 60396 - ifup replaces routes incorrectly for similar subnets
ifup replaces routes incorrectly for similar subnets
Status: CLOSED DEFERRED
Product: Red Hat Raw Hide
Classification: Retired
Component: initscripts (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-27 08:35 EST by Need Real Name
Modified: 2014-03-16 22:25 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-28 15:07:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-02-27 08:35:59 EST
Description of Problem:
I use a network setup where eth0 and eth1 use the same subnet 
(10.0.0.0/24). On eth1 (10.0.0.254), the only host supposed to be reached is 10.0.0.1. All others 
should go to eth0 (10.0.0.2). In command line configuration it looks like this:
route add -host 
10.0.0.1 gw 10.0.0.254 dev eth1
route add -net 10.0.0.0 netmask 255.255.255.0 gw 10.0.0.2 dev 
eth0
At approximately line 227 of /sbin/ifup (search for comment "Replace any existing route"), 
there are some lines which intend to add a route for the device being configured. However since 
eth1 is configured after eth0, the lines replace the route through eth0 (described in second route 
command), forcing all traffic to go through eth1.

Problem fix: For me I can just comment the lines 
out and there are no side effects. However this may not be true for all systems.


Version-Release 
number of selected component (if applicable):
initscripts-6.53-1

How Reproducible:
Every 
time

Steps to Reproduce:
1. Configure ifcfg-eth0 to 10.0.0.2/24 and ifcfg-eth1 to 
10.0.0.254/24.
2. Put these lines in static-routes:
eth0 net 10.0.0.0 netmask 255.255.255.0 gw 
10.0.0.2
eth1 net 10.0.0.1 netmask 255.255.255.255
3. Reboot system.

Actual Results:
The 
route with gateway through 10.0.0.2/eth0 gets replaced with a route through eth1.

Expected 
Results:
The route through 10.0.0.2 should stay, of course.

Additional Information:
Comment 1 Bill Nottingham 2005-04-28 15:07:54 EDT
Closing bugs on older, no longer supported releases. Apologies for any lack of
response. Please open a new bug if this persists on a current release, such as
Fedora Core 3.

Note You need to log in before you can comment on or make changes to this bug.