Bug 6040 - rpm is not updating the installed database
rpm is not updating the installed database
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-18 07:42 EDT by cormacj
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-10-19 15:32:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description cormacj 1999-10-18 07:42:07 EDT
I have been trying to update apache and php to accept mysql.
I have to install the sources and recompile with the
switches for mysql.

rpm doesn't seem to update the installed database once
source has been installed. As a result I'm getting a failure
on php because rpm can't determine that a srpm package has
been installed.

eg:
[root@dns SRPMS]# rpm --version
RPM version 3.0.3
[root@dns SRPMS]# rpm -ivh  apache-1.3.9-4.src.rpm
apache
##################################################
[root@dns SRPMS]# rpm -ivh  apache-1.3.9-4.src.rpm
apache
##################################################
[root@dns SRPMS]# rpm -ivh  apache-1.3.9-4.src.rpm
apache
##################################################
[root@dns SRPMS]# rpm -q  apache-1.3.9-4.src.rpm
package apache-1.3.9-4.src.rpm is not installed
[root@dns SRPMS]#
Comment 1 Jeff Johnson 1999-10-19 15:32:59 EDT
Source rpm's are never installed in the rpm database. You probably
are failing to build because of a build dependency on a binary
rpm.

Note You need to log in before you can comment on or make changes to this bug.