Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 604004 - 'man lftp' gives wrong default for xfer:clobber
'man lftp' gives wrong default for xfer:clobber
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lftp (Show other bugs)
13
All Linux
low Severity low
: ---
: ---
Assigned To: Jiri Skala
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-15 02:39 EDT by Bruce Jerrick
Modified: 2014-11-09 17:33 EST (History)
3 users (show)

See Also:
Fixed In Version: lftp-4.0.9-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-15 03:47:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruce Jerrick 2010-06-15 02:39:52 EDT
Description of problem:
/usr/share/doc/lftp-4.0.7/NEWS states (correctly) that xfer:clobber
is off by default now, yet the man page still says "Default is on".
(And since the default has changed, "xfer:clobber" will be showing up
in error messages now, and people will look at the man page and wonder
why.)

Version-Release number of selected component (if applicable):
lftp-4.0.7-1.fc13.i686

How reproducible:
100%

Steps to Reproduce:
1. head -3 /usr/share/doc/lftp-4.0.7/NEWS	# right there on top
2. zgrep -A2 "xfer:clobber" /usr/share/man/man1/lftp.1.gz
  
Actual results:
From Step 1:
    Version 4.0.7 - 2010-04-29
    * make xfer:clobber off by default.
From Step 2:
    .BR xfer:clobber \ (boolean)
    if this setting is off, get commands will not overwrite existing
    files and generate an error instead. Default is on.

Expected results:
Man page should say "Default is off."

Additional info:
It is left as an exercise to show that xfer:clobber is indeed off now
by default.  Hint: Error message is:
    get: license.chm: file already exists and xfer:clobber is unset

Be aware that 'man lftp | grep "xfer:clobber"' will not show anything,
due to embedded overstrike characters.
Comment 1 Fedora Update System 2010-06-15 03:46:25 EDT
lftp-4.0.9-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/lftp-4.0.9-1.fc13
Comment 2 Fedora Update System 2010-06-30 11:11:45 EDT
lftp-4.0.9-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.