Bug 604005 - Review Request: ledgersmb - Financial accounting program
Summary: Review Request: ledgersmb - Financial accounting program
Keywords:
Status: CLOSED DUPLICATE of bug 732232
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Nobody's working on this, feel free to take it
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: fedora-medical
TreeView+ depends on / blocked
 
Reported: 2010-06-15 06:44 UTC by Rakesh Pandit
Modified: 2011-08-21 19:39 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-07-17 17:02:59 UTC
Type: ---


Attachments (Terms of Use)

Description Rakesh Pandit 2010-06-15 06:44:49 UTC
SPEC: http://rakesh.fedorapeople.org/misc/ledgersmb.spec
SRPM: http://rakesh.fedorapeople.org/misc/ledgersmb-1.2.21-1.fc13.src.rpm

Description:
LedgerSMB is a double-entry accounting system written in perl. LedgerSMB is a fork of sql-ledger offering better security and data integrity, and many advanced features.

Comment 1 Ankur Sinha (FranciscoD) 2010-07-09 07:19:33 UTC
Preliminary rpmlint check:


[Ankur@localhost SPECS]$ rpmlint ledgersmb.spec ../SRPMS/ledgersmb-1.2.21-1.fc13.src.rpm 
ledgersmb.spec: W: invalid-url Source0: http://downloads.sourceforge.net/ledgersmb/ledgersmb-1.2.21.tar.gz HTTP Error 404: Not Found
ledgersmb.src: W: spelling-error %description -l en_US perl -> Perl, peel, perk
ledgersmb.src: W: spelling-error %description -l en_US sql -> sq, ql, sal
ledgersmb.src: W: invalid-url Source0: http://downloads.sourceforge.net/ledgersmb/ledgersmb-1.2.21.tar.gz HTTP Error 404: Not Found
1 packages and 1 specfiles checked; 0 errors, 4 warnings.


I'll do a detailed review asap.

Comment 2 Ankur Sinha (FranciscoD) 2010-07-09 19:25:50 UTC
Review:

+ OK
- NA
? ISSUE

+ Package meets naming and packaging guidelines
+ Spec file matches base package name.
+ Spec has consistant macro usage.
+ Meets Packaging Guidelines.
+ License
+ License field in spec matches
+ License file included in package
+ Spec in American English
+ Spec is legible.
- Sources match upstream md5sum:

- Package needs ExcludeArch
+ BuildRequires correct
? Spec handles locales/find_lang
- Package is relocatable and has a reason to be.
+ Package has %defattr and permissions on files is good.
+ Package has a correct %clean section.
+ Package has correct buildroot
%{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+ Package is code or permissible content.
- Doc subpackage needed/used.
+ Packages %doc files don't affect runtime.

- Headers/static libs in -devel subpackage.
- Spec has needed ldconfig in post and postun
- .pc files in -devel subpackage/requires pkgconfig
- .so files in -devel subpackage.
- -devel package Requires: %{name} = %{version}-%{release}
- .la files are removed.

? Package is a GUI app and has a .desktop file

+ Package compiles and builds on at least one arch.
+ Package has no duplicate files in %files.
+ Package doesn't own any directories other packages own.
+ Package owns all the directories it creates.
? No rpmlint output.
- final provides and requires are sane:
(include output of for i in *rpm; do echo $i; rpm -qp --provides $i; echo =; rpm -qp --requires $i; echo; done
manually indented after checking each line.  I also remove the rpmlib junk and anything provided by glibc.)

SHOULD Items:

+ Should build in mock.
? Should build on all supported archs
? Should function as described.
- Should have sane scriptlets.
- Should have subpackages require base package with fully versioned depend.
+ Should have dist tag
+ Should package latest version
- check for outstanding bugs on package. (For core merge reviews)

Issues:

1. the source url is wrong.. apparently, the sourceforge project name is ledger-smb (note the hyphen)

2. Does not handle locale files. Please use %find_lang and the rest. 
http://fedoraproject.org/wiki/Packaging/Guidelines#Handling_Locale_Files

3. Havent tested if it builds on all archs (to be done after outage is over)

4. rpmlint shows minor issues:
[Ankur@localhost SPECS]$ rpmlint ledgersmb.spec /var/lib/mock/fedora-rawhide-i386/result/*.rpm
ledgersmb.spec: W: invalid-url Source0: http://downloads.sourceforge.net/ledgersmb/ledgersmb-1.2.21.tar.gz HTTP Error 404: Not Found
ledgersmb.noarch: W: spelling-error %description -l en_US perl -> Perl, peel, perk
ledgersmb.src: W: spelling-error %description -l en_US perl -> Perl, peel, perk
ledgersmb.src: W: spelling-error %description -l en_US sql -> sq, ql, sal
ledgersmb.src: W: invalid-url Source0: http://downloads.sourceforge.net/ledgersmb/ledgersmb-1.2.21.tar.gz HTTP Error 404: Not Found
2 packages and 1 specfiles checked; 0 errors, 5 warnings.


URL needs to be corrected. "Perl" can be corrected too. 

5. Haven't been able to check the working of the package. Got this error while trying to install the created rpm: (tail)

---> Package perl-YAML.noarch 0:0.70-3.fc13 set to be updated
--> Running transaction check
---> Package ledgersmb.noarch 0:1.2.21-1.fc13 set to be updated
--> Processing Dependency: perl(LedgerSMB::Session/) >= . for package: ledgersmb-1.2.21-1.fc13.noarch
--> Processing Dependency: perl(bin::aa.pl) for package: ledgersmb-1.2.21-1.fc13.noarch
--> Processing Dependency: perl(bin::arap.pl) for package: ledgersmb-1.2.21-1.fc13.noarch
--> Processing Dependency: perl(bin::arapprn.pl) for package: ledgersmb-1.2.21-1.fc13.noarch
--> Processing Dependency: perl(bin::ar.pl) for package: ledgersmb-1.2.21-1.fc13.noarch
--> Processing Dependency: perl(bin::io.pl) for package: ledgersmb-1.2.21-1.fc13.noarch
--> Processing Dependency: perl(bin::is.pl) for package: ledgersmb-1.2.21-1.fc13.noarch
--> Processing Dependency: perl(bin::pos.pl) for package: ledgersmb-1.2.21-1.fc13.noarch
--> Processing Dependency: perl(bin::pw.pl) for package: ledgersmb-1.2.21-1.fc13.noarch
--> Processing Dependency: perl(bin::rp.pl) for package: ledgersmb-1.2.21-1.fc13.noarch
--> Processing Dependency: perl(common.pl) for package: ledgersmb-1.2.21-1.fc13.noarch
--> Processing Dependency: perl(config.pl) for package: ledgersmb-1.2.21-1.fc13.noarch
--> Processing Dependency: perl(Config::Std) for package: ledgersmb-1.2.21-1.fc13.noarch
--> Processing Dependency: perl(drivers::pd3000.pl) for package: ledgersmb-1.2.21-1.fc13.noarch
--> Processing Dependency: perl(LedgerSMB::AA) for package: ledgersmb-1.2.21-1.fc13.noarch
--> Processing Dependency: perl(LedgerSMB::AM) for package: ledgersmb-1.2.21-1.fc13.noarch
--> Processing Dependency: perl(LedgerSMB::BP) for package: ledgersmb-1.2.21-1.fc13.noarch
--> Processing Dependency: perl(LedgerSMB::CA) for package: ledgersmb-1.2.21-1.fc13.noarch
--> Processing Dependency: perl(LedgerSMB::CP) for package: ledgersmb-1.2.21-1.fc13.noarch
--> Processing Dependency: perl(LedgerSMB::CreditCard::Config) for package: ledgersmb-1.2.21-1.fc13.noarch
--> Processing Dependency: perl(LedgerSMB::CreditCard::TrustCommerce::Config) for package: ledgersmb-1.2.21-1.fc13.noarch
--> Processing Dependency: perl(LedgerSMB::CT) for package: ledgersmb-1.2.21-1.fc13.noarch
--> Processing Dependency: perl(LedgerSMB::Form) for package: ledgersmb-1.2.21-1.fc13.noarch
--> Processing Dependency: perl(LedgerSMB::GL) for package: ledgersmb-1.2.21-1.fc13.noarch
--> Processing Dependency: perl(LedgerSMB::HR) for package: ledgersmb-1.2.21-1.fc13.noarch
--> Processing Dependency: perl(LedgerSMB::IC) for package: ledgersmb-1.2.21-1.fc13.noarch
--> Processing Dependency: perl(LedgerSMB::Inifile) for package: ledgersmb-1.2.21-1.fc13.noarch
--> Processing Dependency: perl(LedgerSMB::IR) for package: ledgersmb-1.2.21-1.fc13.noarch
--> Processing Dependency: perl(LedgerSMB::IS) for package: ledgersmb-1.2.21-1.fc13.noarch
--> Processing Dependency: perl(LedgerSMB::JC) for package: ledgersmb-1.2.21-1.fc13.noarch
--> Processing Dependency: perl(LedgerSMB::Mailer) for package: ledgersmb-1.2.21-1.fc13.noarch
--> Processing Dependency: perl(LedgerSMB::Menu) for package: ledgersmb-1.2.21-1.fc13.noarch
--> Processing Dependency: perl(LedgerSMB::Num2text) for package: ledgersmb-1.2.21-1.fc13.noarch
--> Processing Dependency: perl(LedgerSMB::OE) for package: ledgersmb-1.2.21-1.fc13.noarch
--> Processing Dependency: perl(LedgerSMB::OP) for package: ledgersmb-1.2.21-1.fc13.noarch
--> Processing Dependency: perl(LedgerSMB::PE) for package: ledgersmb-1.2.21-1.fc13.noarch
--> Processing Dependency: perl(LedgerSMB::PriceMatrix) for package: ledgersmb-1.2.21-1.fc13.noarch
--> Processing Dependency: perl(LedgerSMB::RC) for package: ledgersmb-1.2.21-1.fc13.noarch
--> Processing Dependency: perl(LedgerSMB::RP) for package: ledgersmb-1.2.21-1.fc13.noarch
--> Processing Dependency: perl(LedgerSMB::Session) for package: ledgersmb-1.2.21-1.fc13.noarch
--> Processing Dependency: perl(LedgerSMB::Tax) for package: ledgersmb-1.2.21-1.fc13.noarch
--> Processing Dependency: perl(menu.pl) for package: ledgersmb-1.2.21-1.fc13.noarch
--> Processing Dependency: perl(Net::TCLink) for package: ledgersmb-1.2.21-1.fc13.noarch
--> Processing Dependency: perl(pos.conf.pl) for package: ledgersmb-1.2.21-1.fc13.noarch
---> Package perl-Clone.x86_64 0:0.31-4.fc13 set to be updated
---> Package perl-IO-String.noarch 0:1.08-9.fc13 set to be updated
---> Package perl-Net-SMTP-SSL.noarch 0:1.01-4.fc13 set to be updated
---> Package perl-Params-Util.x86_64 0:1.01-1.fc13 set to be updated
---> Package perl-Pod-POM.noarch 0:0.25-2.fc13 set to be updated
---> Package perl-TimeDate.noarch 1:1.20-1.fc13 set to be updated
--> Finished Dependency Resolution
Error: Package: ledgersmb-1.2.21-1.fc13.noarch (/ledgersmb-1.2.21-1.fc13.noarch)
           Requires: perl(common.pl)
Error: Package: ledgersmb-1.2.21-1.fc13.noarch (/ledgersmb-1.2.21-1.fc13.noarch)
           Requires: perl(LedgerSMB::AM)
Error: Package: ledgersmb-1.2.21-1.fc13.noarch (/ledgersmb-1.2.21-1.fc13.noarch)
           Requires: perl(pos.conf.pl)
Error: Package: ledgersmb-1.2.21-1.fc13.noarch (/ledgersmb-1.2.21-1.fc13.noarch)
           Requires: perl(LedgerSMB::Menu)
Error: Package: ledgersmb-1.2.21-1.fc13.noarch (/ledgersmb-1.2.21-1.fc13.noarch)
           Requires: perl(LedgerSMB::CP)
Error: Package: ledgersmb-1.2.21-1.fc13.noarch (/ledgersmb-1.2.21-1.fc13.noarch)
           Requires: perl(LedgerSMB::Session)
Error: Package: ledgersmb-1.2.21-1.fc13.noarch (/ledgersmb-1.2.21-1.fc13.noarch)
           Requires: perl(LedgerSMB::Session/) >= .
Error: Package: ledgersmb-1.2.21-1.fc13.noarch (/ledgersmb-1.2.21-1.fc13.noarch)
           Requires: perl(LedgerSMB::CA)
Error: Package: ledgersmb-1.2.21-1.fc13.noarch (/ledgersmb-1.2.21-1.fc13.noarch)
           Requires: perl(drivers::pd3000.pl)
Error: Package: ledgersmb-1.2.21-1.fc13.noarch (/ledgersmb-1.2.21-1.fc13.noarch)
           Requires: perl(bin::ar.pl)
Error: Package: ledgersmb-1.2.21-1.fc13.noarch (/ledgersmb-1.2.21-1.fc13.noarch)
           Requires: perl(config.pl)
Error: Package: ledgersmb-1.2.21-1.fc13.noarch (/ledgersmb-1.2.21-1.fc13.noarch)
           Requires: perl(bin::arapprn.pl)
Error: Package: ledgersmb-1.2.21-1.fc13.noarch (/ledgersmb-1.2.21-1.fc13.noarch)
           Requires: perl(LedgerSMB::OP)
Error: Package: ledgersmb-1.2.21-1.fc13.noarch (/ledgersmb-1.2.21-1.fc13.noarch)
           Requires: perl(menu.pl)
Error: Package: ledgersmb-1.2.21-1.fc13.noarch (/ledgersmb-1.2.21-1.fc13.noarch)
           Requires: perl(LedgerSMB::OE)
Error: Package: ledgersmb-1.2.21-1.fc13.noarch (/ledgersmb-1.2.21-1.fc13.noarch)
           Requires: perl(bin::pos.pl)
Error: Package: ledgersmb-1.2.21-1.fc13.noarch (/ledgersmb-1.2.21-1.fc13.noarch)
           Requires: perl(bin::aa.pl)
Error: Package: ledgersmb-1.2.21-1.fc13.noarch (/ledgersmb-1.2.21-1.fc13.noarch)
           Requires: perl(LedgerSMB::AA)
Error: Package: ledgersmb-1.2.21-1.fc13.noarch (/ledgersmb-1.2.21-1.fc13.noarch)
           Requires: perl(LedgerSMB::GL)
Error: Package: ledgersmb-1.2.21-1.fc13.noarch (/ledgersmb-1.2.21-1.fc13.noarch)
           Requires: perl(Config::Std)
Error: Package: ledgersmb-1.2.21-1.fc13.noarch (/ledgersmb-1.2.21-1.fc13.noarch)
           Requires: perl(LedgerSMB::RP)
Error: Package: ledgersmb-1.2.21-1.fc13.noarch (/ledgersmb-1.2.21-1.fc13.noarch)
           Requires: perl(LedgerSMB::PriceMatrix)
Error: Package: ledgersmb-1.2.21-1.fc13.noarch (/ledgersmb-1.2.21-1.fc13.noarch)
           Requires: perl(LedgerSMB::IS)
Error: Package: ledgersmb-1.2.21-1.fc13.noarch (/ledgersmb-1.2.21-1.fc13.noarch)
           Requires: perl(LedgerSMB::CreditCard::TrustCommerce::Config)
Error: Package: ledgersmb-1.2.21-1.fc13.noarch (/ledgersmb-1.2.21-1.fc13.noarch)
           Requires: perl(LedgerSMB::Tax)
Error: Package: ledgersmb-1.2.21-1.fc13.noarch (/ledgersmb-1.2.21-1.fc13.noarch)
           Requires: perl(LedgerSMB::PE)
Error: Package: ledgersmb-1.2.21-1.fc13.noarch (/ledgersmb-1.2.21-1.fc13.noarch)
           Requires: perl(LedgerSMB::Inifile)
Error: Package: ledgersmb-1.2.21-1.fc13.noarch (/ledgersmb-1.2.21-1.fc13.noarch)
           Requires: perl(LedgerSMB::JC)
Error: Package: ledgersmb-1.2.21-1.fc13.noarch (/ledgersmb-1.2.21-1.fc13.noarch)
           Requires: perl(bin::is.pl)
Error: Package: ledgersmb-1.2.21-1.fc13.noarch (/ledgersmb-1.2.21-1.fc13.noarch)
           Requires: perl(bin::pw.pl)
Error: Package: ledgersmb-1.2.21-1.fc13.noarch (/ledgersmb-1.2.21-1.fc13.noarch)
           Requires: perl(bin::rp.pl)
Error: Package: ledgersmb-1.2.21-1.fc13.noarch (/ledgersmb-1.2.21-1.fc13.noarch)
           Requires: perl(LedgerSMB::Form)
Error: Package: ledgersmb-1.2.21-1.fc13.noarch (/ledgersmb-1.2.21-1.fc13.noarch)
           Requires: perl(LedgerSMB::IC)
Error: Package: ledgersmb-1.2.21-1.fc13.noarch (/ledgersmb-1.2.21-1.fc13.noarch)
           Requires: perl(Net::TCLink)
Error: Package: ledgersmb-1.2.21-1.fc13.noarch (/ledgersmb-1.2.21-1.fc13.noarch)
           Requires: perl(LedgerSMB::HR)
Error: Package: ledgersmb-1.2.21-1.fc13.noarch (/ledgersmb-1.2.21-1.fc13.noarch)
           Requires: perl(LedgerSMB::Num2text)
Error: Package: ledgersmb-1.2.21-1.fc13.noarch (/ledgersmb-1.2.21-1.fc13.noarch)
           Requires: perl(bin::io.pl)
Error: Package: ledgersmb-1.2.21-1.fc13.noarch (/ledgersmb-1.2.21-1.fc13.noarch)
           Requires: perl(LedgerSMB::RC)
Error: Package: ledgersmb-1.2.21-1.fc13.noarch (/ledgersmb-1.2.21-1.fc13.noarch)
           Requires: perl(LedgerSMB::Mailer)
Error: Package: ledgersmb-1.2.21-1.fc13.noarch (/ledgersmb-1.2.21-1.fc13.noarch)
           Requires: perl(LedgerSMB::CreditCard::Config)
Error: Package: ledgersmb-1.2.21-1.fc13.noarch (/ledgersmb-1.2.21-1.fc13.noarch)
           Requires: perl(LedgerSMB::IR)
Error: Package: ledgersmb-1.2.21-1.fc13.noarch (/ledgersmb-1.2.21-1.fc13.noarch)
           Requires: perl(bin::arap.pl)
Error: Package: ledgersmb-1.2.21-1.fc13.noarch (/ledgersmb-1.2.21-1.fc13.noarch)
           Requires: perl(LedgerSMB::CT)
Error: Package: ledgersmb-1.2.21-1.fc13.noarch (/ledgersmb-1.2.21-1.fc13.noarch)
           Requires: perl(LedgerSMB::BP)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Comment 3 Ankur Sinha (FranciscoD) 2010-07-09 19:26:30 UTC
[Ankur@localhost SPECS]$ md5sum ../SOURCES/ledgersmb-1.2.21.tar.gz 
a95ab0cd734140322e29c5376fda6eff  ../SOURCES/ledgersmb-1.2.21.tar.gz
[Ankur@localhost SPECS]$ md5sum ../ledgersmb-1.2.21.tar.gz 
a95ab0cd734140322e29c5376fda6eff  ../ledgersmb-1.2.21.tar.gz

Comment 4 Rakesh Pandit 2010-11-23 08:22:23 UTC
Sorry for late response. I will have a look in few days (this week or coming weekend).

Comment 5 Rakesh Pandit 2010-12-16 12:38:13 UTC
I was busy again, but update coming this week.

Comment 6 Ankur Sinha (FranciscoD) 2011-05-03 18:00:38 UTC
Hello,

Ping?

Comment 7 Ankur Sinha (FranciscoD) 2011-06-17 03:07:04 UTC
Hi. 

This review is stalled as per 

http://fedoraproject.org/wiki/Policy_for_stalled_package_reviews#Submitter_not_responding

Please respond ASAP or I'll have to close this review :/

Thanks,
Ankur

Comment 8 Susmit 2011-06-17 03:14:55 UTC
I shall take this.

Comment 9 Rakesh Pandit 2011-06-20 07:05:46 UTC
(In reply to comment #8)
> I shall take this.

feel free to. I wouldn't be able to work on it for next 10-15 days either.

Comment 10 Ankur Sinha (FranciscoD) 2011-07-17 17:02:59 UTC
I'm going to package this one up again, and submit it for review. Closing this one. I'll open a fresh review ticket. 

Thanks,
Ankur

Comment 11 Ankur Sinha (FranciscoD) 2011-08-21 07:13:01 UTC

*** This bug has been marked as a duplicate of bug 732232 ***


Note You need to log in before you can comment on or make changes to this bug.