Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 604046 - Profile for tuned missing
Profile for tuned missing
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: tuned (Show other bugs)
6.0
All Linux
high Severity high
: rc
: ---
Assigned To: John Shakshober
qe-baseos-daemons
: Reopened
: 590022 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-15 05:26 EDT by Kamil Kolakowski
Modified: 2011-01-24 20:42 EST (History)
9 users (show)

See Also:
Fixed In Version: tuned-0.2.11-6.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 16:48:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kamil Kolakowski 2010-06-15 05:26:55 EDT
Please update tuned package with profile for large-memory systems running disk and network-intensive applications.
Comment 3 RHEL Product and Program Management 2010-06-15 05:53:14 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 5 Phil Knirsch 2010-06-16 08:51:07 EDT
There are 2 performance related profiles in tuned/ktune at the moment:

       throughput-performance
              Sever profile for typical throughput performance tuning. Disables tuned and ktune power saving mechanisms and enables sysctl settings that improve the throughput performance of your disk and  network
              IO and switches to the deadline scheduler.

       latency-performance
              Sever profile for typical latency performance tuning. Disables tuned and ktune power saving mechanisms and enables sysctl settings that improve the latency performance of your network IO.

(see man tuned-adm).

If that is not sufficient please contact the performance team regarding more area specific profiles.

Thanks & regards, Phil
Comment 6 Kamil Kolakowski 2010-06-17 03:09:41 EDT
Hi Phil,

Those 2 profiles are in my testing matrix, but I missing one profile described with perf team (large-memory systems running disk and network-intensive applications)

Have a Great day!


Thanks 

Kamil
Comment 10 John Shakshober 2010-07-01 09:53:04 EDT
My understanding is that we agreed to setup ktune consistant with RHEL5;

1) set cpuspeed governors to "performance"
2) set io elevator=deadline 
3) reduce scheduler quantum to match RHEL5
echo 10000000 > /proc/sys/kernel/sched_min_granularity_ns 
echo 15000000 > /proc/sys/kernel/sched_wakeup_granularity_ns
4) enable transparent hugepages - if not set.
echo always >/sys/kernel/mm/redhat_transparent_hugepage/enabled
5) adjust dirty ratio back to 40
echo 40 > /proc/sys/vm/dirty_ratio
 
Not needed from RHEL5:

remove the network size adjustments (kernel does this automatically in 5.4+>
*** not needed ***

Others?

Increase the ridulously small values for;
(ie for 64GB system)
sysctl -w kernel.shmmax=6871947673600
sysctl -w kernel.shmall=429496729600
sysctl -w kernel.sem="25000      3200000   32000      12800"
sysctl -w kernel.pid_max=1280000
Comment 12 Kamil Kolakowski 2010-07-28 03:22:15 EDT
I retested this bug on RHEL6.0-20100722.0 with tuned-0.2.11-6.el6.

It can be closed. RESOLVED!
Comment 13 Linda Wang 2010-07-30 09:48:07 EDT
*** Bug 590022 has been marked as a duplicate of this bug. ***
Comment 14 Linda Wang 2010-08-04 10:26:23 EDT
*** Bug 590022 has been marked as a duplicate of this bug. ***
Comment 15 Issue Tracker 2010-08-05 14:26:27 EDT
Event posted on 08-05-2010 11:40am EDT by Glen Johnson

------- Comment From mgrf@de.ibm.com 2010-08-05 11:28 EDT-------
(In reply to comment #52)
> These changes made by lwang@redhat.com.
> Bugzilla comment added:
> we have discussed the tunable parameters recommended by
> IBM internally:
>
> kernel.sched_min_granularity_ns = 10000000
> kernel.sched_wakeup_granularity_ns = 15000000
> kernel.sched_latency_ns = 80000000
> kernel.sched_features = 15834234
> kernel.sched_tunable_scaling = 0
>
> and have agreed on to set the following tunning parameters
> in tunded throughput profile: [see bug 604046 comment#10]
>
> echo 10000000 > /proc/sys/kernel/sched_min_granularity_ns
> echo 15000000 > /proc/sys/kernel/sched_wakeup_granularity_ns
>
> since sched_feature parameter has been removed from upstream,
> so we didn't put that in the profile, and tunable_scaling isn't
> in RHEL6. hence this bug is CLOSED DUP to bug 604046.
>

While I don't agree I can understand your opinion about FS here.

But what about:
kernel.sched_latency_ns = 80000000
kernel.sched_tunable_scaling = 0

Those two should definitely also get set in the same profile.

As I can't open the DUP RH Bug and neither want to leave it in
FIXEDAWAITINGTEST nor being able to set it as TESTED/ACCEPTED I'll reopen
this
bug for now.


This event sent from IssueTracker by jkachuck 
 issue 860543
Comment 16 John Jarvis 2010-08-17 10:14:26 EDT
IBM, please open a new bug to track your request and have it considered for RHEL 6.1.
Comment 20 releng-rhel@redhat.com 2010-11-10 16:48:00 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.