Bug 604056 - [abrt] crash in yum-utils-1.1.26-7.fc13: reposync:246:main:AttributeError: 'function' object has no attribute 'keys'
[abrt] crash in yum-utils-1.1.26-7.fc13: reposync:246:main:AttributeError: 'f...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
abrt_hash:2aab8f0c
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-15 06:16 EDT by Rakesh Pandit
Modified: 2014-01-21 18:15 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-29 03:45:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.58 KB, text/plain)
2010-06-15 06:16 EDT, Rakesh Pandit
no flags Details

  None (edit)
Description Rakesh Pandit 2010-06-15 06:16:38 EDT
abrt 1.1.1 detected a crash.

architecture: x86_64
cmdline: /usr/bin/python -tt /usr/bin/reposync --download-metadata
component: yum-utils
executable: /usr/bin/reposync
kernel: 2.6.33.5-112.fc13.x86_64
package: yum-utils-1.1.26-7.fc13
reason: reposync:246:main:AttributeError: 'function' object has no attribute 'keys'
release: Fedora release 13 (Goddard)

backtrace
-----
reposync:246:main:AttributeError: 'function' object has no attribute 'keys'

Traceback (most recent call last):
  File "/usr/bin/reposync", line 349, in <module>
    main()
  File "/usr/bin/reposync", line 246, in main
    wanted_types = repo.repoXML.fileTypes.keys()
AttributeError: 'function' object has no attribute 'keys'

Local variables in innermost frame:
junk: []
local_repo_path: '/media/_data/project/repo/brew'
repo: <yum.yumRepo.YumRepository object at 0x1bdbfd0>
arches: ['ia32e', 'x86_64', 'athlon', 'i686', 'i586', 'i486', 'i386', 'noarch']
cachedir: '/var/tmp/yum-rakesh-4D9o0r'
opts: <Values at 0x1bd3518: {'newest': False, 'downloadcomps': False, 'quiet': False, 'destdir': '/media/_data/project/repo', 'source': False, 'cachedir': None, 'tempcache': True, 'urls': False, 'plugins': False, 'gpgcheck': False, 'downloadmd': True, 'norepopath': False, 'config': '/etc/yum.conf', 'arch': None, 'repoid': [], 'delete': False}>
reposack: <yum.packageSack.ListPackageSack object at 0x1c9b9d0>
my: <__main__.RepoSync object at 0x1491d50>
download_list: [<YumAvailablePackageSqlite : brewkoji-1.7-1.fc12.noarch (0x1c9ba50)>, <YumAvailablePackageSqlite : koji-1.3.2-2.mead.2.fc12.noarch (0x1c9ba90)>, <YumAvailablePackageSqlite : koji-builder-1.3.2-2.mead.2.fc12.noarch (0x1c9bad0)>, <YumAvailablePackageSqlite : koji-hub-1.3.2-2.mead.2.fc12.noarch (0x1c9bb10)>, <YumAvailablePackageSqlite : koji-hub-plugins-1.3.2-2.mead.2.fc12.noarch (0x1c9bb50)>, <YumAvailablePackageSqlite : koji-utils-1.3.2-2.mead.2.fc12.noarch (0x1c9bb90)>, <YumAvailablePackageSqlite : koji-web-1.3.2-2.mead.2.fc12.noarch (0x1c9bbd0)>]
Comment 1 Rakesh Pandit 2010-06-15 06:16:41 EDT
Created attachment 424095 [details]
File: backtrace
Comment 2 Shreyank Gupta 2010-06-15 06:24:33 EDT
Package: yum-utils-1.1.26-7.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. ran reposync --download-metadata
2.
3.
Comment 3 Tim Lauridsen 2010-06-15 07:59:21 EDT
Could you please retest with yum-utils-1.1.27-2 just push to stable
Comment 4 seth vidal 2010-06-15 09:22:52 EDT
Pretty sure it is broken there, too.

I just checked upstream head and it looks like a simple think-o. I think it was on my part.

fixed now.
Comment 5 Shreyank Gupta 2010-06-24 12:57:18 EDT
Package: yum-utils-1.1.27-2.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. reposync --download-metadata
2.
3.
Comment 6 Rakesh Pandit 2010-12-29 03:45:44 EST
New release fixed it up. I will close it as CURRENTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.