Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 604061 - Microsoft Live Meeting doesn't work
Microsoft Live Meeting doesn't work
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Deepak Bhole
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-15 06:39 EDT by Felipe Contreras
Modified: 2011-06-27 14:16 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-27 14:16:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log of two LiveMeeting test runs using upstream icedtea-web and Firefox 4; the second run crashed. (14.43 KB, application/x-bzip)
2011-04-27 17:00 EDT, Robert Swain
no flags Details

  None (edit)
Description Felipe Contreras 2010-06-15 06:39:55 EDT
Description of problem:
When I try to join live meetings from different companies, I see an error that I don't have Java enabled:
  
Actual results:
Error: Install Java Runtime Environment to use Live Meeting Web Access
To use Live Meeting Web Access, Java must be installed on your computer.

Expected results:
Live Meeting works just fine.

Additional info:
http://office.microsoft.com/en-us/live-meeting-help/live-meeting-support-homepage-FX101878057.aspx
Comment 1 Felipe Contreras 2010-08-09 15:10:08 EDT
Is anybody going to take a look into this?
Comment 2 Deepak Bhole 2010-08-09 15:36:33 EDT
How do I reproduce this issue on my machine?
Comment 3 Felipe Contreras 2010-08-09 21:22:45 EDT
Well, you need access to Microsoft's live meeting service.
Comment 4 Deepak Bhole 2010-08-09 21:48:48 EDT
Hmm. Looked around.. turns out there is a test for it: http://go.microsoft.com/fwlink/?LinkId=90703

With the above, the issue is reproducible. I will look into it.
Comment 5 Felipe Contreras 2010-09-09 06:18:47 EDT
Any progress? If I recall correctly it worked correctly on Sun's official Java.

But of course this should work with whatever comes by default in Fedora.
Comment 6 Javier Jardón 2010-12-20 12:34:12 EST
Same problem here with F14
Comment 7 Robert Swain 2011-03-26 10:22:21 EDT
I have it working with the 64-bit plugin from Oracle/Sun JRE 1.6.0_24 in Fedora 14. I had to set advanced -> settings -> security -> mixed code security verification -> enabled - hide warning and run with protections in the Java Control Panel ( /usr/java/latest/bin/ControlPanel ). Also I had to disable pop-up and ad-blocking for the relevant domain.

No such configuration utility exists for openjdk. There is a policytool GUI ( /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/policytool ) but I don't know whether one can achieve the same thing with that.

If one, for example, runs Firefox in a terminal with openjdk as the active Java plugin and tries to connect to LiveMeeting, it gets so far and even appears to redraw parts of the window that would be widgets but then it sits and appears to hang and lock up the browser. I see messages such as:

Cannot access local disk. Exception: access denied (java.util.PropertyPermission java.io.tmpdir read)

[2011-03-26 14:42:04, 341 CET]: Waiting for Console to show up.
[2011-03-26 14:42:04, 843 CET]: Waiting for Console to show up.
[2011-03-26 14:42:05, 343 CET]: Waiting for Console to show up.
java.lang.IllegalArgumentException: DonorPanel is not accepting donors for [some hash that I removed]
	at placeware.awt.DonorPanel.init(pw.java)
	at placeware.awt.DonorPanel.init(pw.java)
	at sun.applet.AppletPanel.run(AppletPanel.java:436)

Thereafter it just spits the "Waiting for Console to show up." message. I don't know if any of those are relevant or if any others are.
	at java.lang.Thread.run(Thread.java:636)
Comment 8 Robert Swain 2011-03-26 10:29:57 EDT
Looks like Deepak has been fixing the issue:
http://mail.openjdk.java.net/pipermail/distro-pkg-dev/2011-March/012605.html

Deepak - how is this coming along? Is there any chance of a fix in packages in Fedora 14?
Comment 9 Deepak Bhole 2011-03-26 11:53:29 EDT
Hi Robert. It is actually very close to fully fixed upstream. If you (and/or anyone else!) are comfortable with building icedtea-web and are willing to give it a try, I'd love to know if it works. It can be built on F14 as follows:

# Install the rpm deps (so that plugin dependencies are installed)
sudo yum-builddep java-1.6.0-openjdk

# Check out an additional patch that is not in HEAD yet (but will be,
# and influences how LiveMeeting will function)
wget http://people.redhat.com/dbhole/scratch/itw-clsharing.patch -P /tmp

# Check out HEAD
hg clone http://icedtea.classpath.org/hg/icedtea-web

# Apply the patch
cd icedtea-web && patch -p1 < /tmp/itw-clsharing.patch

Before building, uninstall java-1.6.0-openjdk-plugin temporarily, and move /usr/lib/jvm/java-openjdk/jre/lib/netx.jar and /usr/lib/jvm/java-openjdk/jre/lib/plugin.jar out of the way

# Build
./autogen.sh
./configure --with-jdk-home=/usr/lib/jvm/java-openjdk/ --prefix=/some/temp/location
make && make install

The above commands will build it and install it in the "/some/temp/location/" provided to ./configure

Now you can make it visible to firefox by running:
ln -s /some/temp/location/lib/IcedTeaPlugin.so ~/.mozilla/plugins/

Restart firefox, and go to about:plugins (enter it in URL bar) to verify that the plugin is seen. It should show something like:

"IcedTea-Web Plugin (using IcedTea-Web 1.1pre+rd94fc0fb8a53+)"

And that should be the only "IcedTea*" entry on that page

That means it is installed and working correctly. Now give LiveMeeting a try!

Whenever you want to revert back, just rm -f ~/.mozilla/plugins/IcedTeaPlugin.so , move netx.jar and plugin.jar back and reinstall java-1.6.0-openjdk-plugin. It is also then safe to delete the install dir if no longer needed.
Comment 10 Robert Swain 2011-03-26 18:44:48 EDT
I had a couple of issues with your instructions:

- My jdk home is /usr/lib/jvm/jre-1.6.0-openjdk.x86_64
- yum-builddep (I didn't know about this function and missed it from apt, thanks!) pulled in some java-1.5.0-gcj package instead of java-1.6.0-openjdk-devel, the latter being required for successful compilation of the icedtea plugin.

But, it works! \o/ There are a few widget bugs in the UI of Live Meeting with this plugin, but it looks good enough. I'll let you know in a few days if I find more issues. It would be very nice to have Fedora working with Live Meeting with a simple installation of the openjdk plugin. Good work!
Comment 11 Robert Swain 2011-03-26 18:46:17 EDT
I got the wrong paste - actually my jdk home was: /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64
Comment 12 Robert Swain 2011-04-18 08:35:13 EDT
Is there any update on this?

I have upgraded to branched Fedora 15 and just built with a current clone of icedtea-web as I saw that the commit had been merged. When trying to run LiveMeeting now, I see the following error in my terminal:

###!!! ABORT: X_SetScreenSaver: BadLength (poly request too large or internal Xlib length error); 179 requests ago: file nsX11ErrorHandler.cpp, line 203
###!!! ABORT: X_SetScreenSaver: BadLength (poly request too large or internal Xlib length error); 179 requests ago: file nsX11ErrorHandler.cpp, line 203
[2011-04-18 14:31:55, 051 CEST]: CheckApplet started

And it takes out Firefox. I would love to not have to try to set up Oracle Java again because it's very very very picky.
Comment 13 Robert Swain 2011-04-18 08:40:02 EDT
Very strange. After posting that message, I tried connecting to the test LiveMeeting linked above and that worked. Then I tried another LiveMeeting that was crashing before and that also worked. Perhaps it's a racey issue. Cool though.
Comment 14 Robert Swain 2011-04-26 09:00:59 EDT
I tested with a real LiveMeeting session today that used screen-sharing. The first time I tried to connect, Firefox crashed but I did not submit the bug report to Mozilla as I don't think it is particularly relevant to them. It would be nice if I could get an abrt report for this crash.

When I connected the second time, it worked and the stream of the shared screen worked too for some hours.

Can anyone else reproduce the crash bug? Or is there some way I can get a decent backtrace from it without having to submit anything to Mozilla. I like Mozilla, but I want to vet the information and paste it here.
Comment 15 Robert Swain 2011-04-27 08:47:31 EDT
Using it again for some time today I have noticed that it maxes out one of my CPUs with a session with screen-sharing. Also, if I size the window such that the shared screen fits inside the window, periodically it will make the shared screen area and display the internal scroll bars as if the window were too small. Adjusting the window size causes a recalculation and the shared screen space jumps back out again. The crash on first run seems to be quite reproducible.
Comment 16 Deepak Bhole 2011-04-27 14:42:57 EDT
Hi Robert. Can you please start Firefox with:

ICEDTEAPLUGIN_DEBUG=true  firefox 2>&1 | tee console.log

And attach the resulting console.log file? (Please make sure it contains no meeting username/passwords, as it might, depending on the applet).
Comment 17 Robert Swain 2011-04-27 16:59:09 EDT
I used the above-mentioned LiveMeeting test to avoid exposing any sensitive data. Also, the first time I connected to the test session, it worked, the second time it crashed. I will attach the bzip2-ed log - I hope that is not too inconvenient for you but I thought I should save space on bugzilla. :)
Comment 18 Robert Swain 2011-04-27 17:00:47 EDT
Created attachment 495347 [details]
Log of two LiveMeeting test runs using upstream icedtea-web and Firefox 4; the second run crashed.
Comment 19 Deepak Bhole 2011-04-27 17:16:48 EDT
No problem -- thanks for the log! What version of FF (rpm nvr) from F15 are you using? I'd like to set up a vm and try to see if I can make it happen.
Comment 20 Robert Swain 2011-04-27 17:21:54 EDT
Name        : firefox
Arch        : x86_64
Version     : 4.0
Release     : 4.fc15
Size        : 20 M
Repo        : installed
From repo   : updates-testing
Summary     : Mozilla Firefox Web browser
URL         : http://www.mozilla.org/projects/firefox/
License     : MPLv1.1 or GPLv2+ or LGPLv2+
Description : Mozilla Firefox is an open-source web browser, designed for standards
            : compliance, performance and portability.
Comment 21 Bug Zapper 2011-06-02 06:47:48 EDT
This message is a reminder that Fedora 13 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 13.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '13'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 13's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 13 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 22 Bug Zapper 2011-06-27 14:16:21 EDT
Fedora 13 changed to end-of-life (EOL) status on 2011-06-25. Fedora 13 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.