Bug 60409 - Please provide nsgmls in a separate small RPM without jade
Please provide nsgmls in a separate small RPM without jade
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openjade (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Tim Waugh
Brock Organ
http://www.jclark.com/sp/
: EasyFix
: 78473 (view as bug list)
Depends On:
Blocks: FC5Target
  Show dependency treegraph
 
Reported: 2002-02-27 10:24 EST by Markus Kuhn
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version: 1.3.2-20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-14 08:19:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Spec file for new opensp package. (2.65 KB, text/plain)
2005-12-08 17:50 EST, Terje Bless
no flags Details
Modified openjade spec file for split opensp and openjade. (9.07 KB, text/plain)
2005-12-08 17:52 EST, Terje Bless
no flags Details

  None (edit)
Description Markus Kuhn 2002-02-27 10:24:00 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20011019
Netscape6/6.2

Description of problem:
nsgmls is a very important and frequently used web authoring tool, as it is the
best available HTML/XML syntax checker/parser. Unfortunately, Red Hat 7.1
packaged the tiny nsgmls tool together with the 15 MB huge monster DSSSL package
"jade", so any user of nsgmls is forced to install the huge and rarely used jade
package. This makes system administrators reluctant to install nsgmls by default
for disk space reasons. Please please split the nsgmls binary (and the updated
HTML DTDs, XML declaration, documentation, etc.) out of the openjade package and
into a small separate RPM. Thanks!

Version-Release number of selected component (if applicable): openjade-1.3-13


How reproducible:
Always

Steps to Reproduce:
	

Additional info:

nsgmls is the program used for instance on http://validator.w3.org/. "jade" and
DSSSL is only used by very few gurus.
Comment 1 Tim Waugh 2002-02-28 08:56:07 EST
Good idea.
Comment 2 Warren Togami 2004-04-11 19:12:47 EDT
probably target FC3
Comment 3 Terje Bless 2004-08-30 23:05:12 EDT
Bug #78473 appears to be a duplicate of this bug, and introduces a few
additional considerations (i.e. the upstream split, security, and
packaging issues from Bug #78473).
Comment 4 Tim Waugh 2004-12-07 09:58:38 EST
*** Bug 78473 has been marked as a duplicate of this bug. ***
Comment 6 Tim Waugh 2005-12-08 12:22:51 EST
So I've gone ahead and made this change, but actually I'm not really sure what
it bought us.  nsgmls still needs libosp.so.*, and that is quite large itself. 
See what you think: 1.3.2-17.
Comment 7 Ville Skyttä 2005-12-08 13:58:59 EST
Actually, a week or two ago I and Terje have been preparing this split; I gather
Terje has the packages almost ready to roll, pending applying some of the
patches I fed him.

The main difference was that in our approach, opensp was completely split away
from the openjade package, which allows for somewhat "cleaner" updates of
opensp, and allowed purging quite a bit of specfile cruft that is the result of
the bundling of opensp into the current openjade package.

Also, opensp was updated to 1.5.2pre1, and 1.5.2 final is due out soon(tm), I hear.

Terje, could you post the status of our approach and packages here?
Comment 8 Terje Bless 2005-12-08 17:48:57 EST
( Not commenting on openjade-1.3.2-17 as it hasn't hit my Rawhide yet. )

The key issue from Bug #78473 that isn't quite prominent in this bug's
Description is that OpenJade and OpenSP are now two separate packages upstream.
OpenJade used to embed OpenSP, like many projects embed expat, but that's no
longer the case.

So the modified spec files split OpenJade and OpenSP into separate packages and
makes openjade Require opensp-devel.

This lets OpenSP and OpenJade be updated independently of eachother, and has the
nice side-effect of eliminating a lot of cruft from openjade's spec file.

As Ville mentioned, OpenSP 1.5.2 is due for final release RSN -- some wrangling
over build system, documentation, and final checks once GCC 4.1 hits Rawhide, is
about all that remains -- which makes this a good time to try the split.
Comment 9 Terje Bless 2005-12-08 17:50:40 EST
Created attachment 122045 [details]
Spec file for new opensp package.
Comment 10 Terje Bless 2005-12-08 17:52:35 EST
Created attachment 122046 [details]
Modified openjade spec file for split opensp and openjade.
Comment 11 Tim Waugh 2005-12-08 17:55:33 EST
Excellent -- this is a more useful split, and I had lost sight of that.

I've pulled 1.3.2-17 from tomorrow's tree, although you can of course view
current CVS right now.
Comment 12 Ville Skyttä 2005-12-09 18:14:07 EST
Thanks for looking into this, Tim.

There's one bug in the new openjade specfile from comment 10: install-catalog
--remove should be run in %preun, not %postun.
Comment 13 Tim Waugh 2005-12-14 08:19:14 EST
Okay, opensp-1.5.1-2 (built minutes ago) and openjade-1.3.2-20 (in today's
rawhide) are the ones I hope can close this bug report.

The only difference between opensp-1.5.1-1 and opensp-1.5.1-2 is just to add in
the ArcEngine.cxx change from 1.5.2pre1, which fixes a crash during 'make check'.

Thanks very much for the work on the spec files!

Note You need to log in before you can comment on or make changes to this bug.