Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 604094 - Stored Profile doesn't get associated with the Kickstart Profile.
Stored Profile doesn't get associated with the Kickstart Profile.
Status: CLOSED ERRATA
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
530
All Linux
high Severity medium
: ---
: ---
Assigned To: Justin Sherrill
Petr Sklenar
:
Depends On:
Blocks: sat531-triage
  Show dependency treegraph
 
Reported: 2010-06-15 08:25 EDT by Vishal Gaikwad
Modified: 2010-11-04 07:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-05 09:17:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch (896 bytes, patch)
2010-06-15 08:33 EDT, Vishal Gaikwad
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2010:0740 normal SHIPPED_LIVE Red Hat Network Satellite bug fix update 2010-10-05 09:16:28 EDT

  None (edit)
Description Vishal Gaikwad 2010-06-15 08:25:24 EDT
Description of problem:
In a kickstart profile, if you select an existing package profile for sync and then kickstart the system, then after kickstart the package profile of the newly kickstarted system doesn't match to the profile which was selected in the kickstart.


Version-Release number of selected component (if applicable):
Red Hat Network Satellite 530

How reproducible:
Always

Steps to Reproduce:
1. Register an exisitng rhel5 system and created a stored package profile
2. create a simple activation key which has provisioning entitlement
3. Create a kickstart profile.
4. Under Packages -> select the newly created package profile
5. Under activaiton key select the newly created activation key
6. You can either kickstart the system or just refer the kickstart profile and copy the whole rhnreg_ks command with kickstart's default activation key and newly added activation key.
  
Actual results:
System is kickstarted and registered on satellite, but package profile is not synced


Expected results:
Package profile should also be synced.
Comment 3 Vishal Gaikwad 2010-06-15 08:33:14 EDT
Created attachment 424133 [details]
proposed patch
Comment 4 Justin Sherrill 2010-07-14 15:15:43 EDT
fixed in spacewalk master:

b729d5880b0b99f57befc1f71f588b4934db3205

The patch provided didnt quite do it, because that would have broken package profile sync when the package profile was set at the session level (instead of the ks profile level).  My fix checks the session first, and if it is null, checks the kickstart profile 2nd.
Comment 11 errata-xmlrpc 2010-10-05 09:17:07 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0740.html

Note You need to log in before you can comment on or make changes to this bug.