This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 604110 - [abrt] crash in ModemManager-0.3-13.git20100507.fc13: Process /usr/sbin/modem-manager was killed by signal 11 (SIGSEGV)
[abrt] crash in ModemManager-0.3-13.git20100507.fc13: Process /usr/sbin/modem...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ModemManager (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
abrt_hash:5d6da46489da8ca23cf51a8e3f0...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-15 08:58 EDT by David Hollis
Modified: 2010-07-02 13:18 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-02 13:18:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (5.16 KB, text/plain)
2010-06-15 08:59 EDT, David Hollis
no flags Details

  None (edit)
Description David Hollis 2010-06-15 08:58:57 EDT
abrt 1.1.1 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: /usr/sbin/modem-manager
comment: Typically, the first two or three connections drop with a crash in modemmanager after a few seconds/minutes.  After the 2nd or 3rd quick-drop, the connection establishes and seems to stay pretty stable.
component: ModemManager
executable: /usr/sbin/modem-manager
global_uuid: 5d6da46489da8ca23cf51a8e3f006e6c867e1e2a
kernel: 2.6.33.5-112.fc13.x86_64
package: ModemManager-0.3-13.git20100507.fc13
rating: 3
reason: Process /usr/sbin/modem-manager was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

How to reproduce
-----
1. Connect to Verizon via Novatel U760 usb device
2. modemmanager quickly segfaults
Comment 1 David Hollis 2010-06-15 08:59:16 EDT
Created attachment 424143 [details]
File: backtrace
Comment 2 Dan Williams 2010-06-24 12:24:25 EDT
Could you do the following for me (all as root)?

1) make sure the U760 is unplugged
2) service NetworkManager stop
3) killall -TERM modem-manager
4) gdb /usr/sbin/modem-manager
5) type "run --debug" at the (gdb) prompt
6) plug your modem in
7) wait for it to show up in the NM menu
8) connect it
9) when MM crashes, gdb will drop you back to the "(gdb)" prompt, type "t a a bt" here to get a backtrace (stands for "thread apply all backtrace")
10) you may have to hit return a few times when gdb asks to get it to print all the backtrace
11) attach everything (the MM debug output before the crash, and the backtrace) to this bug

At the (gdb) prompt you can type 'quit' to exit.

Thanks!
Comment 3 David Hollis 2010-06-25 15:50:08 EDT
FWIW, I pulled down the ModemManager SRPM from Koji and updated it w/ the 6/22/2010 code from git (ModemManager-0.4-1.git20100622.fc13.x86_64 now) and mm is no longer bombing out.  Now, the connection does drop periodically but that seems to be from PPP (and it may just be the 3G connection dropping sporadically) but with that connection definition set to auto-connect, NM winds up restarting after MM cycles through and re-discovers the ttyUSBx devices, etc.

If needbe, I can downgrade back to the stock F13 ModemManager and capture the backtraces that you need.
Comment 4 Dan Williams 2010-07-02 13:18:38 EDT
Ok, thanks for the update.  I'll close this, it could have been the one of a few fixes to MM upstream that fixed your issue.

Note You need to log in before you can comment on or make changes to this bug.