Bug 604124 - [abrt] crash in scribus-1.3.6-2.fc13: Process /usr/bin/scribus was killed by signal 11 (SIGSEGV)
[abrt] crash in scribus-1.3.6-2.fc13: Process /usr/bin/scribus was killed by ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: scribus (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Dan Horák
Fedora Extras Quality Assurance
http://bugs.scribus.net/view.php?id=9180
abrt_hash:fd70619c3b59e58889695557b51...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-15 09:22 EDT by Fabien Archambault
Modified: 2010-06-28 13:16 EDT (History)
2 users (show)

See Also:
Fixed In Version: scribus-1.3.7-3.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 13:15:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (132.25 KB, text/plain)
2010-06-15 09:22 EDT, Fabien Archambault
no flags Details

  None (edit)
Description Fabien Archambault 2010-06-15 09:22:28 EDT
abrt 1.1.1 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: scribus
comment: This cannot be reproduced every time... This was after about 30 minutes without saving and modifying options... Perhpas I will find a more reproducible way later.
component: scribus
crash_function: ScribusMainWindow::emergencySave
executable: /usr/bin/scribus
global_uuid: fd70619c3b59e58889695557b51437639b9a2286
kernel: 2.6.33.5-112.fc13.x86_64
package: scribus-1.3.6-2.fc13
rating: 4
reason: Process /usr/bin/scribus was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

How to reproduce
-----
1. Select all text with ctrl+a
2. Push Edit Style button
Comment 1 Fabien Archambault 2010-06-15 09:22:31 EDT
Created attachment 424153 [details]
File: backtrace
Comment 2 Fabien Archambault 2010-06-15 09:44:00 EDT
A few moment ago I figured out how to reproduce this behavior. Not exactly the same way as explained before but every time it was possible on the file I am using (I will save it somewhere if it is not reproducible with another file).

So something to have is:
* two text frames with some text inside.
* Pick one frame then [ctrl]+[t].
* Select the first line (a random number of characters) then cut the line (I use [ctrl]+[v]).
* Click on the other text frame.
* Then comes the signal 11 (SIGSEGV)

I am not able to reproduce it on an empty file but perhaps it is possible to reproduce it with another way ?
Comment 3 Dan Horák 2010-06-15 09:59:45 EDT
Fabien, thanks for your report. This or similar crashes are rather common in Scribus, so having a reproducer would be very good. But better place to report this kind of problems is the Scribus bugtracker (http://bugs.scribus.net). Then you will be in direct contact with the developers.

You can also try the latest package from https://admin.fedoraproject.org/updates/scribus-1.3.7-2.fc13
Comment 4 Fabien Archambault 2010-06-16 05:24:19 EDT
Hello,

I updated to 1.3.7-2 and same problem.
I also noticed that in order to reproduce this crash I have to use 2 screens.
I reported it to http://bugs.scribus.net/view.php?id=9180

Hope to see a way to solve this.
Comment 5 Fabien Archambault 2010-06-17 01:51:37 EDT
This is solved using the 1.3.8svn. See the bugzilla of scribus.
If there is an update please notify me. Thanks.
Comment 6 Fedora Update System 2010-06-19 07:54:41 EDT
scribus-1.3.7-3.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/scribus-1.3.7-3.fc12
Comment 7 Fedora Update System 2010-06-19 07:56:49 EDT
scribus-1.3.7-3.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/scribus-1.3.7-3.fc13
Comment 8 Fedora Update System 2010-06-19 07:56:57 EDT
scribus-1.3.7-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/scribus-1.3.7-2.fc11
Comment 9 Fedora Update System 2010-06-21 17:31:50 EDT
scribus-1.3.7-2.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update scribus'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/scribus-1.3.7-2.fc11
Comment 10 Fedora Update System 2010-06-21 17:43:29 EDT
scribus-1.3.7-3.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update scribus'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/scribus-1.3.7-3.fc13
Comment 11 Fedora Update System 2010-06-21 17:46:57 EDT
scribus-1.3.7-3.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update scribus'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/scribus-1.3.7-3.fc12
Comment 12 Fabien Archambault 2010-06-22 09:58:27 EDT
This solved in one of the computer I have where I was able to reproduce the bug.I do not have access for the moment to the main computer where I was able to find the bug but i hope this is solved.
Comment 13 Fedora Update System 2010-06-28 13:15:38 EDT
scribus-1.3.7-3.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2010-06-28 13:16:37 EDT
scribus-1.3.7-3.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.