Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 604137 - Proxy settings not carried over to stage2 repos
Proxy settings not carried over to stage2 repos
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Brian Lane
Release Test Team
: Reopened
Depends On:
Blocks: 582286
  Show dependency treegraph
 
Reported: 2010-06-15 09:47 EDT by Alexander Todorov
Modified: 2014-01-21 01:18 EST (History)
2 users (show)

See Also:
Fixed In Version: anaconda-13.21.55-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 14:48:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tarball of all logs from stage2 (44.64 KB, application/x-gzip)
2010-06-15 09:47 EDT, Alexander Todorov
no flags Details

  None (edit)
Description Alexander Todorov 2010-06-15 09:47:23 EDT
Created attachment 424159 [details]
tarball of all logs from stage2

Description of problem:
If you boot with proxy=host:port anaconda will correctly download the stage2 image files using the proxy (monitor proxy logs). However the repositories that appear in package configuration screen in stage2 don't have proxy URL configured.  If install proceeds no proxy will be used (monitor your proxy logs).

Version-Release number of selected component (if applicable):
anaconda 13.21.50

How reproducible:
always

Steps to Reproduce:
1. Configure a proxy host (for example with apache mod_proxy)
2. Start an install with 'linux proxy=host:port'
3. Monitoring the proxy log observe that stage2 images are downloaded via the proxy.
4. Proceed to package selection
5. Edit/Modify the repositories listed there.
  
Actual results:
No Proxy URL specified for repositories. If you leave it as is the packages will be downloaded directly not via the proxy (see your logs).

Expected results:
Proxy configuration is present for the repositories and packages are downloaded via proxy.

Additional info:
All logs will be attached. anaconda-yum.conf seems to have correct proxy definition.
Comment 1 Brian Lane 2010-06-21 18:13:10 EDT
Reassigning to yum. I've tracked this into the depths of anaconda and as far as I can tell everything is setup properly and yum appears to be ignoring the proxy setting in /tmp/anaconda-yum.conf

A possible complication with my setup is that my virt cannot resolve the host set for the repo, only the host for the proxy. I don't know if Alexander's setup is similar to mine or not. So if yum is expecting to resolve the repo host before using the proxy that could explain the problem.
Comment 2 James Antill 2010-06-22 00:49:15 EDT
Unless you can reproduce a problem post anaconda, I'm going to assume it's a dup of the anaconda proxy BZ.

*** This bug has been marked as a duplicate of bug 484788 ***
Comment 3 Alexander Todorov 2010-06-24 11:19:43 EDT
When adding proxy=http://host:port into yum.conf on already installed system yum used the proxy to download the packages.
Comment 4 Brian Lane 2010-06-28 19:59:29 EDT
It ends up the problem was anaconda's use of YumRepo objects. They don't inherit the proxy settings from the main yum.conf file so they need to be set.
Comment 7 Alexander Todorov 2010-07-02 09:33:55 EDT
Fixed in anaconda-13.21.56-1.
Comment 8 releng-rhel@redhat.com 2010-11-10 14:48:14 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.