Bug 60415 - printconf error due to missing /var/spool/lpd directory
printconf error due to missing /var/spool/lpd directory
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: filesystem (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-27 11:37 EST by John Kacur
Modified: 2014-03-16 22:25 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-27 13:05:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Kacur 2002-02-27 11:37:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.9-13 i686)

Description of problem:
printconf error due to missing /var/spool/lpd directory.
No errors are reported during setup (my test case was for a UNIX printer lpd
Queue)
driver = PostScript Printer, but when trying to print a test page an error
message occurs.
Cause of the problem is a missing /var/spool/lpd directory.
Solution: The program should create the directory if necessary. (Perhaps it is
missing if the user doesn't choose to install a printer during initial RedHat
Installation but runs
the printconf tool afterwards?)
Workaround: Manually create directory, as root do "mkdir /var/spool/lpd"

This tool should also print more informative error messages.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install RedHat 7.2 but don't install a printer during initial setup
2. Run printconf tool afterward and setup Remote UNIX lpd Queue printer
3. Try to print a test page.
	

Actual Results:  An uninformative message is printed saying "a print error
occurred"
(or something similar)

Expected Results:  The test page should print

Additional info:

I'm not sure why this directory was missing, I believe it is because I didn't
set-up a
printer during RedHat installation, however, it is easy to write code that would
detect this situation and create the directory if it needs to.
Comment 1 Tim Waugh 2002-02-27 12:17:18 EST
This directory is provided by the 'filesystem' package (try rpm -V filesystem,
for example), and should always be present unless manually removed.
Comment 2 John Kacur 2002-02-27 13:03:15 EST
1. Ok, the problem is that filesystem is not installed. However, I cannot install filesystem, because when I partitioned my hard drive, I named one of
the partitions /usr/tmp
if you do
rpm -ivh filesystem-2.1.6-2.noarch.rpm --force (or without the --force)
you get
error: unpacking of archive failed, on file /usr/tmp:
cpio: rename failed - Is a directory.

Naming a partion /usr/tmp is not an unreasonable thing to do. Perhaps this bug should be reopened as a filesystem.rpm install problem and
the install script could be made more robust to handle such cases. Otherwise tools like printconf which make assumptions about the filesystem
will fail and your customers won't understand why.
Comment 3 Tim Waugh 2002-02-27 13:05:30 EST
Changing component.
Comment 4 Bill Nottingham 2002-02-27 14:14:43 EST
This cannot be fixed in the filesystem package. Sorry.

Note You need to log in before you can comment on or make changes to this bug.