Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 604156 - [abrt] crash in python-2.6.2-4.fc12: raise: Process /usr/bin/python2.6 was killed by signal 6 (SIGABRT)
[abrt] crash in python-2.6.2-4.fc12: raise: Process /usr/bin/python2.6 was ki...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: python (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Dave Malcolm
Fedora Extras Quality Assurance
abrt_hash:5fe8dcc317873d734d6f0f7afe6...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-15 10:17 EDT by Julien Gardès
Modified: 2010-06-30 16:26 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-30 16:26:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (12.99 KB, text/plain)
2010-06-15 10:17 EDT, Julien Gardès
no flags Details

  None (edit)
Description Julien Gardès 2010-06-15 10:17:20 EDT
abrt 1.0.9 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: /usr/bin/python2.6 -u /home/jgardes/Travail/Softwares/Sequences_finder/src/test.py
component: python
crash_function: raise
executable: /usr/bin/python2.6
global_uuid: 5fe8dcc317873d734d6f0f7afe6acc2b290981f5
kernel: 2.6.32.12-115.fc12.x86_64
package: python-2.6.2-4.fc12
rating: 4
reason: Process /usr/bin/python2.6 was killed by signal 6 (SIGABRT)
release: Fedora release 12 (Constantine)
Comment 1 Julien Gardès 2010-06-15 10:17:22 EDT
Created attachment 424167 [details]
File: backtrace
Comment 2 Dave Malcolm 2010-06-30 16:26:54 EDT
Thank you for filing this bug report.

Looking at the backtrace I see that the problem is an invalid call to "free" in frame #4, as called by "proc_requete" which is a function wrapped in Python by ~/Logiciels_bioinfo/remoteacnuc/acnucmodule.so, which seems to be a module that you've built yourself:

#3  0x0000003ac3274ac6 in malloc_printerr (action=3, 
    str=0x3ac333c4a8 "free(): invalid pointer", ptr=<value optimized out>)
    at malloc.c:6267
        buf = "00000000020d6220"
        cp = <value optimized out>
#4  0x00007fb7e46d6191 in proc_requete ()
   from /home/jgardes/Logiciels_bioinfo/remoteacnuc/acnucmodule.so
#5  0x0000003acea43b33 in PyObject_Call (func=0x7fb7ead5eab8, 
    arg=<value optimized out>, kw=<value optimized out>)
    at Objects/abstract.c:2492
        result = 0x7fb7ead65081
        call = 0x3acea805f0 <PyCFunction_Call>

So as it stands, this looks like a bug in your version of "acnucmodule.so", rather than in python itself.  Is a version of this module in Fedora?  Is it open source?  (See http://fedoraproject.org/wiki/SIGs/SciTech and the list at http://fedoraproject.org/wiki/SIGs/SciTech/BioinformaticsWishList for some notes on Fedora bioinformatics code)

I'm going to close this bug, with the resolution "NOTABUG", as it's not a bug in our python rpms themselves (though obviously it _is_ a bug).

Hope this is helpful; I'm sorry that I can't be of more help.

Note You need to log in before you can comment on or make changes to this bug.