Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 604158 - pulp-tools create repo need to catch error, and display human readable message
pulp-tools create repo need to catch error, and display human readable message
Status: CLOSED CURRENTRELEASE
Product: Pulp
Classification: Retired
Component: z_other (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Pradeep Kilambi
: QA-Closed
: 605381 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-15 10:20 EDT by wes hayutin
Modified: 2011-07-15 15:32 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-20 12:11:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2010-06-15 10:20:22 EDT
\"Invalid type.  valid types are ['yum', 'local', 'rhn']\"\n"


[root@localhost ~]# pulp repo create --label f12_i386 --name=f12 --arch=i386 --feed=yum:http://download.devel.redhat.com/released/F-12/GOLD/Fedora/i386/os/
 Successfully created Repo [ f12_i386 ] with feed [ yum:http://download.devel.redhat.com/released/F-12/GOLD/Fedora/i386/os/ ]

[root@localhost ~]# pulp repo create --label f12_i386 --name=f12 --arch=i386 --feed=http://download.devel.redhat.com/released/F-12/GOLD/Fedora/i386/os/
"Traceback (most recent call last):\n  File \"build/bdist.linux-i686/egg/juicer/controllers/base.py\", line 45, in report_error\n    return method(self, *args, **kwargs)\n  File \"build/bdist.linux-i686/egg/juicer/controllers/repositories.py\", line 61, in POST\n    repo_data['feed'])\n  File \"build/bdist.linux-i686/egg/pulp/api/repo.py\", line 297, in create\n    r = model.Repo(id, name, arch, feed)\n  File \"build/bdist.linux-i686/egg/pulp/model.py\", line 34, in __init__\n    self.repo_source = RepoSource(source)\n  File \"build/bdist.linux-i686/egg/pulp/model.py\", line 55, in __init__\n    self.parse_feed(url)\n  File \"build/bdist.linux-i686/egg/pulp/model.py\", line 64, in parse_feed\n    % self.supported_types)\nPulpException: \"Invalid type.  valid types are ['yum', 'local', 'rhn']\"\n"
Comment 1 Pradeep Kilambi 2010-06-17 16:14:48 EDT
*** Bug 605381 has been marked as a duplicate of this bug. ***
Comment 3 Shveta 2010-08-10 06:03:29 EDT
[root@shveta ~]# pulp -u admin -p admin repo create --id=f12_x64 --name=f12 --arch=i386 --feed=yum:http://download.devel.redhat.com/released/F-12/GOLD/Fedora/i386/os/
 Successfully created Repo [ f12_x64 ]
[root@shveta ~]# pulp -u admin -p admin repo create --id=f12_x64 --name=f12 --arch=i386 --feed=yum:http://download.devel.redhat.com/released/F-12/GOLD/Fedora/i386/os/
"A repository with the id, f12_x64, already exists"
Comment 4 Preethi Thomas 2010-10-20 12:11:38 EDT
Closed after review.

Note You need to log in before you can comment on or make changes to this bug.