Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 604159 - virtio-blk: Avoid zeroing every request structure
virtio-blk: Avoid zeroing every request structure
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.6
All Linux
high Severity medium
: rc
: ---
Assigned To: Virtualization Maintenance
Virtualization Bugs
: ZStream
Depends On: 598042
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-15 10:22 EDT by RHEL Product and Program Management
Modified: 2013-01-09 17:44 EST (History)
11 users (show)

See Also:
Fixed In Version: kvm-83-164.el5_5.13
Doc Type: Bug Fix
Doc Text:
The virtio-blk back end for qemu-kvm performed unnecessary zeroing of memory on every I/O request, which reduced virtual guest performance. With this update, the virtio-blk back end avoids spurious zeroing of request structures on each I/O request, with the result that guest performance is increased.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-29 01:49:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
test result (16.78 KB, application/octet-stream)
2010-06-24 05:43 EDT, Golita Yue
no flags Details
test result with raw (16.67 KB, application/octet-stream)
2010-06-25 07:04 EDT, Golita Yue
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2010:0536 normal SHIPPED_LIVE kvm bug fix update 2010-07-29 01:49:39 EDT

  None (edit)
Description RHEL Product and Program Management 2010-06-15 10:22:17 EDT
This bug has been copied from bug #598042 and has been proposed
to be backported to 5.5 z-stream (EUS).
Comment 6 Golita Yue 2010-06-24 05:43:30 EDT
Created attachment 426506 [details]
test result
Comment 8 Golita Yue 2010-06-25 07:04:16 EDT
Created attachment 426846 [details]
test result with raw
Comment 9 Golita Yue 2010-07-05 04:48:19 EDT
Tested in kvm-83-164.el5_5.11 & kvm-83-164.el5_5.13.(#comment5,6,7,8)

The performance boost of 7-29% in kvm-83-164.el5_5.13. So this bug fixed.
Comment 13 Eduardo Habkost 2010-07-23 14:14:44 EDT
Technical note added. If any revisions are required, please edit the "Technical Notes" field
accordingly. All revisions will be proofread by the Engineering Content Services team.

New Contents:
Cause: the virtio-blk backend on qemu-kvm was doing unnecessary zeroing of memory on every I/O request.

Consequence: performance impact due to unnecessary memory writes.

Fix: avoid zeroing whole requests structures on every I/O requests.

Consequence: performance boosts on virtio-blk.
Comment 14 Douglas Silas 2010-07-28 11:40:56 EDT
Technical note updated. If any revisions are required, please edit the "Technical Notes" field
accordingly. All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -1,7 +1 @@
-Cause: the virtio-blk backend on qemu-kvm was doing unnecessary zeroing of memory on every I/O request.
+The virtio-blk back end for qemu-kvm performed unnecessary zeroing of memory on every I/O request, which reduced virtual guest performance. With this update, the virtio-blk back end avoids spurious zeroing of request structures on each I/O request, with the result that guest performance is increased.-
-Consequence: performance impact due to unnecessary memory writes.
-
-Fix: avoid zeroing whole requests structures on every I/O requests.
-
-Consequence: performance boosts on virtio-blk.
Comment 16 errata-xmlrpc 2010-07-29 01:49:59 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0536.html

Note You need to log in before you can comment on or make changes to this bug.