Bug 604196 - RV370: X server crashes when system booted with "nomodeset"
Summary: RV370: X server crashes when system booted with "nomodeset"
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati   
(Show other bugs)
Version: 14
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jérôme Glisse
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-15 15:17 UTC by Nalin Dahyabhai
Modified: 2018-04-11 09:52 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-13 15:18:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log from failed run (56.02 KB, text/plain)
2010-06-15 15:18 UTC, Nalin Dahyabhai
no flags Details
Xorg log with the crash (64.67 KB, text/plain)
2010-10-13 03:12 UTC, igor.redhat@gmail.com
no flags Details
Screenshot of garbled X session with modesetting enabled (118.45 KB, image/png)
2010-11-23 22:12 UTC, Jason
no flags Details

Description Nalin Dahyabhai 2010-06-15 15:17:56 UTC
Description of problem:
I've been using "nomodeset" for a while, but today's combination of packages seems to crash with it.  I'm not sure which component it is, so I'm guessing.

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.13.1-0.20100519git428125c09.fc14.x86_64
xorg-x11-server-Xorg-1.8.0-12.fc13.x86_64
libdrm-2.4.21-1.fc14.x86_64
kernel-2.6.34-20.fc14.x86_64
linux-firmware-20100106-4.fc14.noarch

How reproducible:
Always

Steps to Reproduce:
1. Boot to runlevel 3 with "nomodeset" (I was also using "enforcing=0", but I don't think that would make a difference here)
2. Log in at the console
3. Run startx
  
Actual results:
X server crashes

Expected results:
Normal startup

Comment 1 Nalin Dahyabhai 2010-06-15 15:18:33 UTC
Created attachment 424190 [details]
Xorg.0.log from failed run

Comment 2 Jérôme Glisse 2010-06-15 16:02:01 UTC
Did you have issue with kms ie without nomodeset ? You should consider booting with nomodeset kind of unsupported as it goes right to the bottom of long list of bugs.

Comment 3 Nalin Dahyabhai 2010-06-15 18:08:27 UTC
Without "nomodeset", the server starts up correctly, yes.

Comment 5 Bug Zapper 2010-07-30 12:08:20 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 6 igor.redhat@gmail.com 2010-10-13 03:12:15 UTC
Created attachment 453068 [details]
Xorg log with the crash

Same issue for me with ATI Radeon X1200 (ChipID = 0x791f). X starts without nomodeset but 3D is funky (as in bugs 579615 and 638779).

Comment 7 Jason 2010-11-23 22:12:22 UTC
Created attachment 462464 [details]
Screenshot of garbled X session with modesetting enabled

Same issue here with:

01:05.0 VGA compatible controller: ATI Technologies Inc RS690M [Radeon X1200 Series]

I've been using nomodeset (Since modesetting was initially enabled by default) with the radeon driver to avoid the issue visible in my attachment. Since X will no longer start with nomodeset enabled, I have to start with modesetting which causes my screen to constantly get garbled requiring me to restart X. 

Highly annoying.

Comment 8 desertblizzard 2010-12-22 16:33:27 UTC
Same exact problem here with a fresh insatll of F14 on a Gateway LT3114u with x1270 ATI Radeon hardware.  Skipped F13, used nomodeset on f12 to get desired results.  Can anything be done or am I stuck with F12?

Comment 9 Jérôme Glisse 2011-01-13 15:18:00 UTC
we don't support nomodeset, we will only fix kms bugs


Note You need to log in before you can comment on or make changes to this bug.