Bug 60424 - ext3 is a module - / is always checked as ext2
ext3 is a module - / is always checked as ext2
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Copeland
Beth Uptagrafft
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-27 12:00 EST by Jeff Wiedemeier
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-06 12:43:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Wiedemeier 2002-02-27 12:00:22 EST
Description of Problem:

Since ext3 is a module that is loaded after the root filesystem is checked, the
fsck of / is always done as ext2 - without the journal - even when / is ext3.
The ext3 module is loaded in time to check /boot.

Version-Release number of selected component (if applicable):

2.4.9-24 (7.2 rc - 0222.1 iso)

How Reproducible:

very

Steps to Reproduce:
1. turn off machine while running (with / and /boot ext3)
2. reboot - watch disk check, it uses EXT2 tools (if it requires intervention,
lsmod in that shell shows no modules loaded)
3. what disk check of /boot - it uses EXT tools

Actual Results:

/ is checked as an EXT2, /boot is checked as ext3

Expected Results:

/ and /boot checked as ext3

Additional Information:
Comment 1 Jeff Wiedemeier 2002-03-06 06:57:03 EST
I've also now seen a case where / could not be mounted because it contained
"unsupported optional features"
Comment 2 Phil Copeland 2002-03-06 12:43:03 EST
Humm
well I think the best way to solve this is to NOT make ext3 a loadable module as
it's always needed so making it a loadable module is sort of ummm redundant.
the extra options error you got is to do with the Filesystem features 

(tune2fs -l /dev/<partition>)

has_journal, needs_recovery will cause the behaviour you mention

So, I propose to move ext3 from being modular to being part of the monolithic
kernel
Comment 3 Phil Copeland 2002-03-11 16:22:34 EST
Bah. My bad.

Looks likethe ramdisk.img file doesn't include the fat/msdos/vfat modules so
when anaconda goes to write out the information, it can't
I've updated anaconda to include these extra modules
(anaconda-7.2/scripts/mk-images.alpha)

===============================
(from anaconda-7.2/exception.py)
-------------------------------
        if iutil.getArch() != "ia64":
            args = [ 'mkdosfs', '/tmp/floppy' ]

        
            cmd = "/usr/sbin/mkdosfs"
        
            if os.access("/sbin/mkdosfs", os.X_OK):
                cmd = "/sbin/mkdosfs"

            iutil.execWithRedirect (cmd, args, 
                                stdout = '/dev/tty5', stderr = '/dev/tty5')
                                
        try:
            isys.mount(device, "/tmp/crash", fstype = "vfat")
        except SystemError:
            continue

        out = open("/tmp/crash/anacdump.txt", "w")
        dumpException (out, text, tb, dispatch)
        out.close()

        # write out any syslog information as well
        try:
            iutil.copyFile("/tmp/syslog", "/tmp/crash")
        except:
            pass
        
        isys.umount("/tmp/crash")

        intf.messageWindow(_("Dump Written"),
            _("Your system's state has been successfully written to the "
              "floppy. Your system will now be reset."))

-------------------------------


Note You need to log in before you can comment on or make changes to this bug.