Bug 604243 - The system randomly freezes
The system randomly freezes
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-15 13:05 EDT by Ivan Razuvaev
Modified: 2011-06-27 14:18 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-27 14:18:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivan Razuvaev 2010-06-15 13:05:34 EDT
Description of problem:
The system randomly freezes. If nouveau is loaded then freeze comes faster. If nvidia proprietary kernel module is used then i get more time working properly.  Sometimes keyboard lights shows kernel panic.

Version-Release number of selected component (if applicable):
kernel-2.6.33.4-112.fc13.x86_64
kernel-2.6.33.5-112.fc13.x86_64

Steps to Reproduce:
1. boot
2. just wait and it comes
Comment 1 Benny 2010-06-15 14:41:11 EDT
Same as bug 601638?
Comment 2 Ivan Razuvaev 2010-06-15 15:26:57 EDT
(In reply to comment #1)
> Same as bug 601638?    

Looks similar. But i can't test ssh conection while problem appers. Additionally, i have nothing unusual in logs.
Comment 3 Benny 2010-06-20 18:53:19 EDT
For me this bug is solved when using: 

- kernel 2.6.34-43.fc13.x86_64
- kmod-nvidia-2.6.34-43.fc13.x86_64.x86_64 (akmod)
  (nouveau blacklisted, nomodeset)

And with the virtualization (Vanderpool technology) turned off in the BIOS. 

At least I havn't had any freezes so far... Also I managed to watch my first complete Youtube video without freezing up, which I tried many times before, ending up in a freeze. 

Therefore I assume the problem has something to do with virtualization support in the current kernel(s). With any Fedora (<12) I never encountered this problem (with virtualization turned on in the BIOS), and as soon as I upgraded it started, so I think it is not BIOS related.
Comment 4 Benny 2010-06-21 04:22:50 EDT
Argh, never mind this last comment... next boot it froze up again...
Comment 5 Ivan Razuvaev 2010-06-21 04:57:12 EDT
Looks like developers doesn't care about this problem. Or no one haves any idea about this issue. Benny, is there anything useful in your system logs?
Comment 6 Benny 2010-06-21 08:51:57 EDT
Sorry all my 'useful' logs are given in bug 601638... unless you want something specific. 

Furthermore maybe this helps: http://koji.fedoraproject.org/koji/buildinfo?buildID=178558   

Notice:
* Mon Jun 07 2010 Ben Skeggs <bskeggs@redhat.com>
- nouveau: fix iommu errors on GeForce 8 and newer chipsets (bug 561267)

I'll try it tonight.
Comment 7 Benny 2010-06-21 16:03:00 EDT
Also kernel 2.6.33.5-133.fc13.x86_64 freezes...
Comment 8 Ivan Razuvaev 2010-06-22 01:01:58 EDT
Bad news to hear that. I'm really disappointed with F12 and F13 kernels. F11 were much more stable at my opinion and experience. 
I tried to run F13 on my laptop with 945PM chipset and G72M GPU (GeForce Go 7300) and got similar results. System or freezes or displays "kernel panic". System prosuces some output when panic. I'll try to take the picture of these messages and share it here.
Comment 9 Ivan Razuvaev 2010-06-22 01:52:17 EDT
Guys, try kernel option pcie_aspm=off. This fixes freezes for some people with GF8600 cards. Too bad it's not working for me.
Comment 10 Bug Zapper 2011-06-02 06:43:43 EDT
This message is a reminder that Fedora 13 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 13.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '13'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 13's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 13 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Ivan Razuvaev 2011-06-02 06:49:54 EDT
F15. the bug still appears. pcie_aspm=off option is the only solution by now.
Comment 12 Bug Zapper 2011-06-27 14:18:44 EDT
Fedora 13 changed to end-of-life (EOL) status on 2011-06-25. Fedora 13 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.