Bug 604303 - KDE pulseaudio integration: volume level sync is very strange
KDE pulseaudio integration: volume level sync is very strange
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-15 15:54 EDT by Viktor Erdelyi
Modified: 2010-06-30 17:34 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-29 17:32:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Viktor Erdelyi 2010-06-15 15:54:32 EDT
Pulseaudio volumes are not even close to be in sync with the alsamixer levels. After experimenting for a while I managed to max out the pulseaudio master channel (internal audio analog stereo) in kmix while alsamixer's master (on HDA Intel, not the pulseaudio device) was only at 10/100.

Another strange thing is that when I move an application-specific slider, the master level changes as well. There is some connection between the levels (when I move a slider in kmix/"pulse", some alsa levels change) however I have no idea about the nature of that connection.

Version-Release number of selected component (if applicable):
pulseaudio-0.9.21-6.fc13.i686
KDE 4.4.3

HW is Realtek ALC882 HD audio.

PS: volume levels were strange on Gnome as well (especialy when trying to adjust 5.1 levels separately), but not to this extent.
Comment 1 Lennart Poettering 2010-06-29 17:32:43 EDT
Yes, PA unifies the dB scale across all sound cards. This is a feature, not a bug:

http://pulseaudio.org/wiki/PulseAudioStoleMyVolumes
http://pulseaudio.org/wiki/WritingVolumeControlUIs
Comment 2 Viktor Erdelyi 2010-06-30 17:34:26 EDT
I was talking about KMix's controls and KDE integration, not PA itself. Having KMix's "PA Master" (and all other controls of KMix) maxed out while there is almost no sound, is _imho_ not a feature but a bug. Feel free to disagree, however.

Note You need to log in before you can comment on or make changes to this bug.