Bug 604352 - garcon-devel depends on gtk-doc unnecessarily
garcon-devel depends on gtk-doc unnecessarily
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: garcon (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: 604169
  Show dependency treegraph
 
Reported: 2010-06-15 16:52 EDT by Felipe Contreras
Modified: 2010-10-07 17:11 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.1.1-2.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-07 17:11:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Felipe Contreras 2010-06-15 16:52:18 EDT
There's no need to depend on gtk-doc to install .html files. See the tracking bug for details.
Comment 1 Christoph Wickert 2010-07-04 14:07:50 EDT
As long as there is no other package to own /usr/share/gtk-doc/(html) this is not a bug but follows the guidelines. If you think this is not the case, please figure this out on the packaging list before repoening this bug. So far I don't see a post from you there.
Comment 2 Felipe Contreras 2010-07-04 21:26:23 EDT
It's covered in the guidelines. See what is supposed to happen for /etc/bash_completion.d: all the packages must own the directory.

I did send a mail to the list, but I got "Your message to packaging awaits moderator approval" and it never appeared.
Comment 3 Christoph Wickert 2010-07-05 03:50:20 EDT
(In reply to comment #2)
> It's covered in the guidelines. See what is supposed to happen for
> /etc/bash_completion.d: all the packages must own the directory.

Obviously the guidelines were changed recently and the change was not announced. I'm trying to figure out if this change was ratified be the packaging committee and backed up by the rpm developers. rpm has a problem with left over directories when the packages were uninstalled in a single transaction but in the wrong order.

> I did send a mail to the list, but I got "Your message to packaging awaits
> moderator approval" and it never appeared.

If you are really interested in a discussion, you will need to subscribe to that mailing list because otherwise you wont get the replies. CC wont work because mailman sets a reply-to. By subscribing to the mailing list you can also reply to the mail I just sent there.

If the package committee confirms the guideline change, I will reopen this bug and fix it.
Comment 4 Felipe Contreras 2010-07-05 07:33:46 EDT
(In reply to comment #3)
> > I did send a mail to the list, but I got "Your message to packaging awaits
> > moderator approval" and it never appeared.
> 
> If you are really interested in a discussion, you will need to subscribe to
> that mailing list because otherwise you wont get the replies. CC wont work
> because mailman sets a reply-to. By subscribing to the mailing list you can
> also reply to the mail I just sent there.

Public mailing lists should receive mail from anybody; if the poster is not subscribed, then the message should go through moderation.

Orthogonal to this is that the mailing lists should not mingle with "Reply-To"; they should leave the To and Cc fields intact, so that the MUA can reply to the right addresses.

See:
http://www.unicom.com/pw/reply-to-harmful.html

Good mailing lists like LKML do this.

I am already subscribed to too many mailing lists. I would rather go through the process of fixing Fedora's mailing lists rather than subscribe to this one.

> If the package committee confirms the guideline change, I will reopen this bug
> and fix it.

Considering the guideline says *right now* that the package itself should own the directory, I think you should have closed the bug *after*, the guideline is changed to require 'gtk-doc' (hopefully not).

But whatever.
Comment 5 Felipe Contreras 2010-08-23 12:42:08 EDT
It is a bug, see:
https://fedoraproject.org/wiki/PackagingDrafts/Revised_File_and_Directory_Ownership

From the original bug #604169 comment #31
---
Which by my reading means that all packages which place files in
/usr/share/gtk-doc/ should go ahead and own that dir. (root/root, mode 755).
---
Comment 6 Christoph Wickert 2010-10-07 17:11:36 EDT
Fixed in http://koji.fedoraproject.org/koji/taskinfo?taskID=2521478

Note You need to log in before you can comment on or make changes to this bug.