Bug 604399 - libxfce4ui-devel depends on gtk-doc unnecessarily
Summary: libxfce4ui-devel depends on gtk-doc unnecessarily
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libxfce4ui   
(Show other bugs)
Version: 13
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Christoph Wickert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks: 604169
TreeView+ depends on / blocked
 
Reported: 2010-06-15 20:57 UTC by Felipe Contreras
Modified: 2010-10-07 21:12 UTC (History)
2 users (show)

Fixed In Version: 4.7.3-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-07 21:12:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Felipe Contreras 2010-06-15 20:57:00 UTC
There's no need to depend on gtk-doc to install .html files. See the tracking bug for details.

Comment 1 Christoph Wickert 2010-07-04 18:07:41 UTC
As long as there is no other package to own /usr/share/gtk-doc/(html) this is not a bug but follows the guidelines. If you think this is not the case, please figure this out on the packaging list before repoening this bug. So far I don't see a post from you there.

Comment 2 Felipe Contreras 2010-08-23 16:43:51 UTC
It is a bug, see:
https://fedoraproject.org/wiki/PackagingDrafts/Revised_File_and_Directory_Ownership

From the original bug #604169 comment #31
---
Which by my reading means that all packages which place files in
/usr/share/gtk-doc/ should go ahead and own that dir. (root/root, mode 755).
---

Comment 3 Christoph Wickert 2010-10-07 21:12:56 UTC
Fixed in http://koji.fedoraproject.org/koji/taskinfo?taskID=2521488


Note You need to log in before you can comment on or make changes to this bug.