Bug 604409 - parole-devel depends on gtk-doc unnecessarily
parole-devel depends on gtk-doc unnecessarily
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: parole (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: 604169
  Show dependency treegraph
 
Reported: 2010-06-15 16:58 EDT by Felipe Contreras
Modified: 2010-09-28 01:51 EDT (History)
2 users (show)

See Also:
Fixed In Version: parole-0.2.0.2-3.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-18 11:50:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Felipe Contreras 2010-06-15 16:58:00 EDT
There's no need to depend on gtk-doc to install .html files. See the tracking bug for details.
Comment 1 Christoph Wickert 2010-07-04 14:07:30 EDT
As long as there is no other package to own /usr/share/gtk-doc/(html) this is not a bug but follows the guidelines. If you think this is not the case, please figure this out on the packaging list before repoening this bug. So far I don't see a post from you there.
Comment 2 Felipe Contreras 2010-08-23 12:44:06 EDT
It is a bug, see:
https://fedoraproject.org/wiki/PackagingDrafts/Revised_File_and_Directory_Ownership

From the original bug #604169 comment #31
---
Which by my reading means that all packages which place files in
/usr/share/gtk-doc/ should go ahead and own that dir. (root/root, mode 755).
---
Comment 3 Fedora Update System 2010-09-18 11:33:11 EDT
parole-0.2.0.2-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/parole-0.2.0.2-3.fc14
Comment 4 Fedora Update System 2010-09-28 01:51:42 EDT
parole-0.2.0.2-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.