Bug 60444 - binutils: "readelf -r" fails
Summary: binutils: "readelf -r" fails
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: binutils   
(Show other bugs)
Version: 7.3
Hardware: alpha Linux
medium
medium
Target Milestone: ---
Assignee: Beth Uptagrafft
QA Contact: Beth Uptagrafft
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-02-27 20:45 UTC by Christopher Holmes
Modified: 2007-04-18 16:40 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-28 18:22:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Christopher Holmes 2002-02-27 20:45:03 UTC
Description of Problem:

binutils: readelf -r fails "make -k check"

Version-Release number of selected component (if applicable):

binutils-2.11.90.0.8-12.src.rpm

How Reproducible:

always

Steps to Reproduce:

1. rpm -i binutils-2.11.90.0.8-12.src.rpm
1a. cd /usr/src/redhat/SPECS
2. rpm -ba binutils.spec
3. cd /usr/src/redhat/BUILD/binutils-2.11.90.0.8
4. make -k check
5. review ./binutils/binutils.log searching for "readelf -r"


Actual Results:

exec /usr/src/redhat/BUILD/binutils-2.11.90.0.8/binutils/readelf  -r
tmpdir/bintest.o > readelf.out
regexp_diff match failure
regexp "^  00000004  00.* R_.*00000000  external_symbol.*$"
line   "  00000004  700000001 R_ALPHA_REFLONG       0000000000000000 
external_symbol           + 0"
FAIL: readelf -r


Expected Results:

exec /usr/src/redhat/BUILD/binutils-2.11.90.0.8/binutils/readelf  -r
PASS: readelf -r

Additional Information:

expected results achieved on intel RedHat7.2

Comment 1 Jakub Jelinek 2002-02-27 21:17:11 UTC
readelf -r is correct, the bug is in the regexp pattern.
In current CVS binutils it looks like:
^0+04  [0-9A-Fa-f]+ *R_.*0+00 external_symbol.*$


Note You need to log in before you can comment on or make changes to this bug.