Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 604452 - segmentation fault with nvidia graphics card and no monitor
segmentation fault with nvidia graphics card and no monitor
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
12
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-15 18:43 EDT by Ian Mortimer
Modified: 2018-04-11 08:45 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-23 22:56:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/Xorg.0.log (12.05 KB, text/plain)
2010-06-21 21:08 EDT, Ian Mortimer
no flags Details
dmesg output (121.32 KB, text/plain)
2010-06-21 21:08 EDT, Ian Mortimer
no flags Details
/var/log/messages (70.59 KB, text/plain)
2010-06-21 21:09 EDT, Ian Mortimer
no flags Details

  None (edit)
Description Ian Mortimer 2010-06-15 18:43:59 EDT
Description of problem:
X11 on F12 with latest updates segfaults on a system with an nVidia G73GL [Quadro FX 560] graphics card and no monitor attached.


Version-Release number of selected component (if applicable):
xorg-x11-drv-nouveau-0.0.15-21.20091105gite1c2efd.fc12.x86_64

How reproducible:
Always


Steps to Reproduce:
1.install F12 on a system with nVidia G73GL graphics card
2.update to latest
3.reboot headless
  
Actual results:
X segfaults.

Expected results:
X should start normally even on headless system.

Additional info:
Xorg.0.log reports:

Backtrace:
0: /usr/bin/Xorg (xorg_backtrace+0x28) [0x49ef28]
1: /usr/bin/Xorg (0x400000+0x61ec9) [0x461ec9]
2: /lib64/libpthread.so.0 (0x3227e00000+0xf0f0) [0x3227e0f0f0]
3: /usr/bin/Xorg (xf86InitViewport+0x4b) [0x51ebab]
4: /usr/bin/Xorg (InitOutput+0xb23) [0x470673]
5: /usr/bin/Xorg (0x400000+0x21d7f) [0x421d7f]
6: /lib64/libc.so.6 (__libc_start_main+0xfd) [0x322721eb1d]
7: /usr/bin/Xorg (0x400000+0x21ad9) [0x421ad9]
Segmentation fault at address 0x24    

This host is a terminal server and normally runs headless - however it needs X and gdm running for the terminal service.  Simple workaround is to attach any old monitor so X and gdm start normally but that shouldn't be necessary.
Comment 1 Matěj Cepl 2010-06-21 05:13:42 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please add drm.debug=0x04 to the kernel command line, restart computer, and attach

* your X server config file (/etc/X11/xorg.conf, if available),
* X server log file (/var/log/Xorg.*.log)
* output of the dmesg command, and
* system log (/var/log/messages)

to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Ian Mortimer 2010-06-21 21:08:26 EDT
Created attachment 425789 [details]
/var/log/Xorg.0.log
Comment 3 Ian Mortimer 2010-06-21 21:08:57 EDT
Created attachment 425790 [details]
dmesg output
Comment 4 Ian Mortimer 2010-06-21 21:09:37 EDT
Created attachment 425791 [details]
/var/log/messages
Comment 5 Ian Mortimer 2010-06-21 21:10:35 EDT
No /etc/X11/xorg.conf.  /var/log/Xorg.0.log, dmesg output and /var/log/messages attached.

Thanks.
Comment 6 Ben Skeggs 2010-06-23 12:09:40 EDT
I can easily fix the F12 nouveau package to not cause a segfault.  However, X will still fail to start all the same.  Additional work to the X server is needed to start with no displays, this has been done in F13 already, it's not likely to be backported to F12.

How do you wish to proceed?
Comment 7 Ian Mortimer 2010-06-23 17:45:13 EDT
We can work around it, however since EL6 is based on F12 will the X server also fail without a display in EL6?

(We're waiting for EL6 to come out of beta and running F12 only because EL5 is too old.)


Thanks
Comment 8 Ben Skeggs 2010-06-23 19:28:50 EDT
It's likely the X server in EL6 will have the code necessary to make this work at the time of release.  Happy for this to be closed as WONTFIX for F12?
Comment 9 Ian Mortimer 2010-06-23 19:58:38 EDT
(In reply to comment #8)

> Happy for this to be closed as WONTFIX for F12?    

Fine with me.

Note You need to log in before you can comment on or make changes to this bug.