Bug 604481 - Upstart does not recognize jobs
Summary: Upstart does not recognize jobs
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: upstart (Show other bugs)
(Show other bugs)
Version: 6.0
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: Petr Lautrbach
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-16 02:49 UTC by twelvefortyfive
Modified: 2010-06-17 08:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-17 08:38:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description twelvefortyfive 2010-06-16 02:49:00 UTC
Description of problem:
I am trying to use a small, custom upstart script to run apache tomcat. This works very well in Fedora 11 (upstart-0.3.9-24) but does not seem to work in RHEL 6 (upstart-0.6.3-5). Here is the script:

=====================================
start on tomcat-start
respawn
exec /opt/tomcat/bin/catalina.sh run
=====================================

When I run the following command, nothing happens:
# initctl emit tomcat-start

I also tried the simple "bounce" example from the upstart website and it doesn't work on RHEL 6 either (but works on FC11, like the above script):
http://upstart.ubuntu.com/getting-started.html

Version-Release number of selected component (if applicable):
upstart-0.6.3-5

How reproducible:
Always

Steps to Reproduce:
1. Install a new upstart script
2. Try to run script using start or emit command
3.
  
Actual results:
Nothing happens if script is event based and emit command is used. When invoked using the "initctl start" command, an "Unknown job" error is received.

Expected results:
Script should run.

Additional info:

Comment 2 RHEL Product and Program Management 2010-06-16 03:13:14 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Petr Lautrbach 2010-06-16 07:58:50 UTC
Where is your job located and what is job file name? Since upstart-0.6.5 upstart jobs moved to /etc/init and job description files must have .conf suffix.

# cat > /etc/init/tomcat.conf << EOF
> start on tomcat-start
> respawn
> exec /opt/tomcat/bin/catalina.sh run
> EOF

# initctl status tomcat
tomcat stop/waiting

# start tomcat
start: Job failed to start

Job failed just because I don't have any  /opt/tomcat/bin/catalina.sh.

Comment 4 twelvefortyfive 2010-06-16 23:28:27 UTC
Thanks very much Petr. That was indeed the problem.

What's the best place to find documentation on upstart 0.6.5? I have a problem with another job too that was working in FC11, but I want to make sure it's not a config issue like this one before reporting anything.

Comment 5 Petr Lautrbach 2010-06-17 08:38:05 UTC
The most actual documentation can be found in man pages - init(8), init(5), initctl(8)   telinit(8), runlevel(7), startup(7), starting(7), started(7), stopping(7), stopped(7)


Note You need to log in before you can comment on or make changes to this bug.