Bug 604532 - ivtv-firmware has missing %{?dist} tag in NVR
Summary: ivtv-firmware has missing %{?dist} tag in NVR
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ivtv-firmware   
(Show other bugs)
Version: 6.0
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: Mauro Carvalho Chehab
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-16 07:56 UTC by Daniel Mach
Modified: 2013-07-04 22:55 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-05 19:36:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Daniel Mach 2010-06-16 07:56:38 UTC
%{?dist} is missing in package release.

actual NVR:
ivtv-firmware-20080701-20.2

correct NVR:
ivtv-firmware-20080701-20.2%{?dist}

Comment 1 RHEL Product and Program Management 2010-06-16 08:13:21 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 2 RHEL Product and Program Management 2010-07-15 14:29:54 UTC
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **

Comment 3 Jarod Wilson 2010-08-05 19:30:31 UTC
Firmware is firmware is firmware. The same firmware package could be used across multiple distributions without having to rebuild it, since there's nothing to rebuild. Firmware is quite commonly packaged without a dist tag. This is not a bug.

Comment 4 Jarod Wilson 2010-08-05 19:33:05 UTC
Slightly more background info: This firmware hasn't changed since 2008, as evident from the version string. We package it once in Fedora, without a dist tag, and the same package then gets propagated to all current trees at the time, and then gets carried forward to each new release. The contents aren't going to change, since its a binary-only firmware.

Comment 5 Mauro Carvalho Chehab 2010-08-05 19:36:12 UTC
I agree with Jarod's aguments. So, I'm closing it as NOTABUG.

Comment 6 Dennis Gregorovic 2010-08-05 19:48:48 UTC
What happens if we want to deliver ivtv-firmware-20080701-20.2 on RHEL 5?  We would need to rebuild the package for several reasons (different GPG key, RHEL 6 RPMs aren't backward-compatible, different buildroots).  So, in order to rebuild the package you would have to modify the release field.  It's much simpler to use %{?dist}.  It makes rebuilds much more pleasant.


Note You need to log in before you can comment on or make changes to this bug.