Bug 604575 - [RFE] All crashes of condor daemons should create corefile
Summary: [RFE] All crashes of condor daemons should create corefile
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: condor (Show other bugs)
(Show other bugs)
Version: Development
Hardware: All Linux
medium
medium
Target Milestone: 3.0
: ---
Assignee: Matthew Farrellee
QA Contact: MRG Quality Engineering
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-16 09:37 UTC by Martin Kudlej
Modified: 2013-01-08 18:57 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-08 18:57:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Martin Kudlej 2010-06-16 09:37:41 UTC
Description of problem:
If I set up Condor and OS for creating corefiles, Condor just log crash of daemons to logs and doesn't create corefile in $(LOG) directory.

Version-Release number of selected component (if applicable):
condor-7.4.3-0.17.el5

Actual results:
There is just log entry for crash and there isn't any corefile for that crash.

Expected results:
There will be always corefile for all crashes of daemons.

Additional info:
Settings for generating corefiles:
# common part rhel4/5/...
ulimit -c unlimited
export DAEMON_COREFILE_LIMIT='unlimited'
grep DAEMON_COREFILE_LIMIT /etc/sysconfig/init ||
  echo "DAEMON_COREFILE_LIMIT='unlimited'" >>/etc/sysconfig/init

  
# rhel5/... only
echo 2 > /proc/sys/fs/suid_dumpable

# rhel4 only
echo 2 > /proc/sys/kernel/suid_dumpable

grep ^CREATE_CORE_FILES ${condor_config} || \
  echo "CREATE_CORE_FILES = True" >> ${condor_config}
  
# condor optional (useful in some cases)
grep ^ABORT_ON_EXCEPTION ${condor_config} || \
 echo "ABORT_ON_EXCEPTION = True" >> ${condor_config}

Comment 1 Matthew Farrellee 2010-08-30 10:53:03 UTC
Is this a request for ABORT_ON_EXCEPTION and CREATE_CORE_FILES to default to true?

The OS specific pieces should not be controlled by Condor or its RPM.

Comment 2 Martin Kudlej 2010-09-16 09:55:31 UTC
For example this https://bugzilla.redhat.com/show_bug.cgi?id=628034#c7 doesn't generate any core file. There are set all configuration variables from Description(except of Abort_on_exception) and it is not exception.

Comment 3 Matthew Farrellee 2013-01-08 18:57:48 UTC
I'm unaware of any reports of this since the original filing.

If this issue resurfaces please reopen.


Note You need to log in before you can comment on or make changes to this bug.