Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 604607 - SELinux is preventing /usr/sbin/sendmail.sendmail "module_request" access on <Unknown>.
SELinux is preventing /usr/sbin/sendmail.sendmail "module_request" access on ...
Status: CLOSED DUPLICATE of bug 604606
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-16 06:32 EDT by Jóhann B. Guðmundsson
Modified: 2010-06-16 13:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-16 13:41:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jóhann B. Guðmundsson 2010-06-16 06:32:04 EDT
Description of problem:


Summary:

SELinux is preventing /usr/sbin/sendmail.sendmail "module_request" access on <Unknown>.

Detailed Description:

SELinux denied access requested by sendmail. The current boolean settings do not
allow this access. If you have not setup sendmail to require this access this
may signal an intrusion attempt. If you do intend this access you need to change
the booleans on this system to allow the access.

Allowing Access:

Confined processes can be configured to run requiring different access, SELinux
provides booleans to allow you to turn on/off access as needed. The boolean
domain_kernel_load_modules is set incorrectly.
Boolean Description:
Allow all domains to have the kernel load modules


Fix Command:

# setsebool -P domain_kernel_load_modules 1

Additional Information:

Source Context                system_u:system_r:sendmail_t:s0
Target Context                system_u:system_r:kernel_t:s0
Target Objects                None [ system ]
Source                        sendmail
Source Path                   /usr/sbin/sendmail.sendmail
Port                          <Unknown>
Host                          localhost.localdomain
Source RPM Packages           sendmail-8.14.4-7.fc14
Target RPM Packages           
Policy RPM                    selinux-policy-3.8.3-1.fc14
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall_boolean
Host Name                     localhost.localdomain
Platform                      Linux localhost.localdomain 2.6.34-20.fc14.i686 #1
                              SMP Wed Jun 2 13:12:51 UTC 2010 i686 i686
Alert Count                   12
First Seen                    Wed 26 May 2010 02:06:13 PM GMT
Last Seen                     Wed 16 Jun 2010 10:21:39 AM GMT
Local ID                      412e65c3-3870-4a0b-9414-7cfbbc7a072f
Line Numbers                  

Raw Audit Messages            

node=localhost.localdomain type=AVC msg=audit(1276683699.62:25): avc:  denied  { module_request } for  pid=1192 comm="sendmail" kmod="net-pf-10" scontext=system_u:system_r:sendmail_t:s0 tcontext=system_u:system_r:kernel_t:s0 tclass=system

node=localhost.localdomain type=SYSCALL msg=audit(1276683699.62:25): arch=40000003 syscall=102 success=no exit=-97 a0=1 a1=bfc4a6d0 a2=97a738 a3=9ee3a0 items=0 ppid=1 pid=1192 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=485 sgid=485 fsgid=485 tty=(none) ses=4294967295 comm="sendmail" exe="/usr/sbin/sendmail.sendmail" subj=system_u:system_r:sendmail_t:s0 key=(null)

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Daniel Walsh 2010-06-16 13:41:26 EDT

*** This bug has been marked as a duplicate of bug 604606 ***

Note You need to log in before you can comment on or make changes to this bug.