Bug 604625 - Authentication is needed to run gnome-power-backlight-helper as the superuser
Summary: Authentication is needed to run gnome-power-backlight-helper as the superuser
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-power-manager   
(Show other bugs)
Version: 14
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-16 11:12 UTC by Jóhann B. Guðmundsson
Modified: 2010-08-31 12:53 UTC (History)
3 users (show)

Fixed In Version: gnome-power-manager-2.31.90-3.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-24 01:55:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jóhann B. Guðmundsson 2010-06-16 11:12:45 UTC
Description of problem:

As soon as GDM starts the first thing to pop up is an authentication dialog that asks for the root password to be able to run gnome-power-backlight-helper as the superuser. 

Then it asks for it again as soon as you have logged in as a regular user on the system.

Version-Release number of selected component (if applicable):

2.31.1-1.fc14

How reproducible:

Always

Steps to Reproduce:
1. Boot wait until GDM
2. Log in as regular user
3.
  
Actual results:

Being ask for the superuser password to allow gnome-backlight-helper to be run

Expected results:

No authentication dialogues asking me for anything other than my password for the user I want to log in as.

Additional info:

Comment 1 Bug Zapper 2010-07-30 12:08:42 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 2 Will Woods 2010-08-18 20:50:46 UTC
This turns out to be a build error - gnome-power-manager-2.31.6.tar.gz ships with a prebuilt policy/org.gnome.power.policy file, which incorrectly lists the path of gnome-power-backlight-helper:
    
    <annotate key="org.freedesktop.policykit.exec.path">/home/hughsie/.root/sbin/gnome-power-backlight-helper</annotate>

As a workaround, edit /usr/share/polkit-1/actions/org.gnome.power.policy and change that path to '/usr/sbin/gnome-power-backlight-helper'. 

The minimal build fix is probably to add:
  rm -f policy/org.gnome.power.policy
to the specfile's %prep section.

(except I can't confirm that 'cuz g-p-m doesn't build right now, boo)

Comment 3 Will Woods 2010-08-18 21:10:29 UTC
Build failure is bug 625206 - there's a patch that fixes it there.

I can now confirm that the minimal build fix in comment #2 works as expected.

Comment 4 Fedora Update System 2010-08-23 19:20:46 UTC
gnome-power-manager-2.31.90-3.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/gnome-power-manager-2.31.90-3.fc14

Comment 5 Fedora Update System 2010-08-24 01:55:08 UTC
gnome-power-manager-2.31.90-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Richard Hughes 2010-08-31 12:53:38 UTC
Committed upstream:

commit 51ff5159c7dd1c4e8ac0b7423b8f468f3adb1d47
Author: Richard Hughes <richard@hughsie.com>
Date:   Tue Aug 31 13:53:11 2010 +0100

    Do not dist org.gnome.power.policy in the tarball


Note You need to log in before you can comment on or make changes to this bug.