Bug 604630 - Loading bonding module causes a WARNING oops
Loading bonding module causes a WARNING oops
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Neil Horman
Fedora Extras Quality Assurance
:
: 668165 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-16 07:24 EDT by Reuben Farrelly
Modified: 2011-08-26 15:00 EDT (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-26 15:00:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
More complete dmesg from the system (44.69 KB, application/octet-stream)
2010-06-16 07:25 EDT, Reuben Farrelly
no flags Details
patch to check for existance of a device name before trying to register it (1.91 KB, patch)
2010-10-04 10:44 EDT, Neil Horman
no flags Details | Diff
New dmesg with patched kernel (46.48 KB, application/octet-stream)
2010-10-05 03:43 EDT, Reuben Farrelly
no flags Details
patch to prevent WARN_ON during bonding_masters write (2.55 KB, patch)
2010-10-06 10:39 EDT, Neil Horman
no flags Details | Diff

  None (edit)
Description Reuben Farrelly 2010-06-16 07:24:42 EDT
Description of problem:

An unexpected oops is created when the bonding module is loaded.

Version-Release number of selected component (if applicable):

2.6.33.5-112, 2.6.33.5-124 possibly earlier

How reproducible:

Warning oops is generated on every boot

Steps to Reproduce:
1. Boot kernel with bonding config
2. Watch oops go past..
3.
  
Bonding module appears to load and operate OK by the time the boot process completes, but the oops should not be generated.

A more complete dmesg from the box is attached to this bug report.

bonding: bond0 is being created...
------------[ cut here ]------------
WARNING: at fs/proc/generic.c:590 proc_register+0x14d/0x185()
Hardware name: ProLiant BL465c G1  
proc_dir_entry 'bonding/bond0' already registered
Modules linked in: bonding ipv6 tg3 bnx2 shpchp amd64_edac_mod edac_core ipmi_si
 ipmi_msghandler serio_raw i2c_piix4 k8temp edac_mce_amd hpwdt microcode hpsa cc
iss radeon ttm drm_kms_helper drm i2c_algo_bit i2c_core [last unloaded: scsi_wai
t_scan]
Pid: 935, comm: ifup-eth Not tainted 2.6.33.5-124.fc13.x86_64 #1
Call Trace:
 [<ffffffff8104b54c>] warn_slowpath_common+0x77/0x8f
 [<ffffffff8104b5b1>] warn_slowpath_fmt+0x3c/0x3e
 [<ffffffff8114bf0b>] proc_register+0x14d/0x185
 [<ffffffff8114c20c>] proc_create_data+0x87/0xa1
 [<ffffffffa0211e9b>] bond_create_proc_entry+0x55/0x95 [bonding]
 [<ffffffffa0215e5d>] bond_init+0x95/0xd0 [bonding]
 [<ffffffff8138cd97>] register_netdevice+0xdd/0x29e
 [<ffffffffa021240b>] bond_create+0x8e/0xb8 [bonding]
 [<ffffffffa021c4be>] bonding_store_bonds+0xb3/0x1c1 [bonding]
 [<ffffffff812aec85>] class_attr_store+0x27/0x29
 [<ffffffff8115423d>] sysfs_write_file+0x10f/0x14b
 [<ffffffff81101acf>] vfs_write+0xa9/0x106
 [<ffffffff81101be2>] sys_write+0x45/0x69
 [<ffffffff81009b02>] system_call_fastpath+0x16/0x1b
---[ end trace a677c3f7f8b16b1e ]---
bonding: Bond creation failed.
Comment 1 Reuben Farrelly 2010-06-16 07:25:20 EDT
Created attachment 424407 [details]
More complete dmesg from the system
Comment 2 David Cartwright 2010-07-29 22:02:25 EDT
I am also seeing kernel crashes with bonded interface.

Backtrace follows:
------------------------------------------------------------
WARNING: at fs/proc/generic.c:590 proc_register+0x14d/0x185()
Hardware name: X58A-UD5
proc_dir_entry 'bonding/bond0' already registered
Modules linked in: bonding ipv6 xt_physdev kvm_intel kvm uinput snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device wmi xhci r8169 mii snd_pcm snd_timer snd i2c_i801 iTCO_wdt iTCO_vendor_support soundcore snd_page_alloc microcode raid1 firewire_ohci firewire_core ata_generic pata_acpi crc_itu_t pata_jmicron nouveau ttm drm_kms_helper drm i2c_algo_bit video output i2c_core [last unloaded: scsi_wait_scan]
Pid: 1339, comm: ifup-eth Not tainted 2.6.33.6-147.fc13.x86_64 #1
Call Trace:
[<ffffffff8104aecc>] warn_slowpath_common+0x77/0x8f
[<ffffffff8104af31>] warn_slowpath_fmt+0x3c/0x3e
[<ffffffff8114b9e3>] proc_register+0x14d/0x185
[<ffffffff8114bce4>] proc_create_data+0x87/0xa1
[<ffffffffa029ae9b>] bond_create_proc_entry+0x55/0x95 [bonding]
[<ffffffffa029ee5d>] bond_init+0x95/0xd0 [bonding]
[<ffffffff8138bfc2>] register_netdevice+0xdd/0x29e
[<ffffffffa029b40b>] bond_create+0x8e/0xb8 [bonding]
[<ffffffffa02a54be>] bonding_store_bonds+0xb3/0x1c1 [bonding]
[<ffffffff812adce1>] class_attr_store+0x27/0x29
[<ffffffff81153cf5>] sysfs_write_file+0x10f/0x14b
[<ffffffff8110155f>] vfs_write+0xa9/0x106
[<ffffffff81101672>] sys_write+0x45/0x69
[<ffffffff81009b02>] system_call_fastpath+0x16/0x1b
Comment 3 Curtis Doty 2010-08-30 23:00:28 EDT
Same here with 2.6.33.8-149.fc13.x86_64. It seems to collide on itself in /proc?

bonding: Ethernet Channel Bonding Driver: v3.6.0 (September 26, 2009)
bonding: Warning: either miimon or arp_interval and arp_ip_target module parameters must be specified, otherwise bonding will not detect link failures! see bonding.txt for details.
bonding: bond0 is being created...
------------[ cut here ]------------
WARNING: at fs/proc/generic.c:590 proc_register+0x14d/0x185()
Hardware name: X8ST3
proc_dir_entry 'bonding/bond0' already registered
Modules linked in: bonding 8021q garp stp llc ipv6 ioatdma iTCO_wdt iTCO_vendor_support i2c_i801 i2c_core e1000e dca microcode serio_raw raid1 [last unloaded: scsi_wait_scan]
Pid: 1478, comm: ifup-eth Not tainted 2.6.33.8-149.fc13.x86_64 #1
Call Trace:
 [<ffffffff81049ecc>] warn_slowpath_common+0x77/0x8f
 [<ffffffff81049f31>] warn_slowpath_fmt+0x3c/0x3e
 [<ffffffff8114aae3>] proc_register+0x14d/0x185
 [<ffffffff8114ade4>] proc_create_data+0x87/0xa1
 [<ffffffffa00dee9b>] bond_create_proc_entry+0x55/0x95 [bonding]
 [<ffffffffa00e2e5d>] bond_init+0x95/0xd0 [bonding]
 [<ffffffff8138b1b7>] register_netdevice+0xdd/0x29e
 [<ffffffffa00df40b>] bond_create+0x8e/0xb8 [bonding]
 [<ffffffffa00e94be>] bonding_store_bonds+0xb3/0x1c1 [bonding]
 [<ffffffff812ace01>] class_attr_store+0x27/0x29
 [<ffffffff81152df5>] sysfs_write_file+0x10f/0x14b
 [<ffffffff8110062b>] vfs_write+0xa9/0x106
 [<ffffffff8110073e>] sys_write+0x45/0x69
 [<ffffffff81008b02>] system_call_fastpath+0x16/0x1b
---[ end trace df134944079a1455 ]---
bonding: Bond creation failed.
bonding: bond0: setting mode to 802.3ad (4).
bonding: bond0: setting xmit hash policy to layer3+4 (1).
bonding: bond0: Setting MII monitoring interval to 100.
bonding: bond0: Setting down delay to 300.
bonding: bond0: Setting up delay to 500.
bonding: bond0: Adding slave eth2.
bonding: bond0: enslaving eth2 as a backup interface with a down link.
bonding: bond0: Adding slave eth3.
bonding: bond0: enslaving eth3 as a backup interface with a down link.
Comment 4 Curtis Doty 2010-09-03 03:10:58 EDT
Still occurring in 2.6.34.6-47.fc13.x86_64...

bonding: Ethernet Channel Bonding Driver: v3.6.0 (September 26, 2009)
bonding: Warning: either miimon or arp_interval and arp_ip_target module parameters must be specified, otherwise bonding will not detect link failures! see bonding.txt for details.
bonding: bond0 is being created...
------------[ cut here ]------------
WARNING: at fs/proc/generic.c:598 proc_register+0x152/0x18a()
Hardware name: X8ST3
proc_dir_entry 'bonding/bond0' already registered
Modules linked in: bonding 8021q garp stp llc ipv6 xt_hl ipt_ULOG xt_limit xt_multiport xt_dscp xt_owner i2c_i801 iTCO_wdt ioatdma iTCO_vendor_support e1000e dca i2c_core microcode raid1 [last unloaded: scsi_wait_scan]
Pid: 1507, comm: ifup-eth Not tainted 2.6.34.6-47.fc13.x86_64 #1
Call Trace:
 [<ffffffff8104d12f>] warn_slowpath_common+0x7c/0x94
 [<ffffffff8104d19e>] warn_slowpath_fmt+0x41/0x43
 [<ffffffff8115a776>] proc_register+0x152/0x18a
 [<ffffffff8115aaa6>] proc_create_data+0x8c/0xa6
 [<ffffffffa0109f20>] bond_create_proc_entry+0x5a/0x91 [bonding]
 [<ffffffffa010dfed>] bond_init+0x9a/0xd5 [bonding]
 [<ffffffff813a8dcb>] register_netdevice+0xe3/0x2be
 [<ffffffffa010a4ca>] bond_create+0x98/0xbd [bonding]
 [<ffffffffa011480d>] bonding_store_bonds+0xb8/0x1bb [bonding]
 [<ffffffff812c4367>] class_attr_store+0x23/0x25
 [<ffffffff81162de6>] sysfs_write_file+0x114/0x150
 [<ffffffff8110e08a>] vfs_write+0xae/0x10b
 [<ffffffff8110e1a7>] sys_write+0x4a/0x6e
 [<ffffffff81009c72>] system_call_fastpath+0x16/0x1b
---[ end trace 29a1e3f7a3db1318 ]---
bonding: Bond creation failed.
bonding: bond0: setting mode to 802.3ad (4).
bonding: bond0: setting xmit hash policy to layer3+4 (1).
bonding: bond0: Setting MII monitoring interval to 100.
bonding: bond0: Setting down delay to 300.
bonding: bond0: Setting up delay to 500.
bonding: bond0: Adding slave eth2.
bonding: bond0: enslaving eth2 as a backup interface with a down link.
bonding: bond0: Adding slave eth3.
bonding: bond0: enslaving eth3 as a backup interface with a down link.
bonding: bond0: link status up for interface eth2, enabling it in 0 ms.
bonding: bond0: link status definitely up for interface eth2.
bonding: bond0: link status up for interface eth3, enabling it in 500 ms.
bonding: bond0: link status definitely up for interface eth3.
Comment 5 Kyle McMartin 2010-09-03 16:01:55 EDT
Please try the scratch build here, and let me know if it silences the WARN_ON:
http://koji.fedoraproject.org/koji/taskinfo?taskID=2445845

Thanks, Kyle.
Comment 6 Curtis Doty 2010-09-03 18:42:34 EDT
Unfortunately no. :-(

@@ -963,24 +965,24 @@
 WARNING: at fs/proc/generic.c:598 proc_register+0x152/0x18a()
 Hardware name: X8ST3
 proc_dir_entry 'bonding/bond0' already registered
-Modules linked in: bonding 8021q garp stp llc ipv6 xt_hl ipt_ULOG xt_limit xt_multiport xt_dscp xt_owner i2c_i801 iTCO_wdt ioatdma iTCO_vendor_support e1000e dca i2c_core microcode raid1 [last unloaded: scsi_wait_scan]
-Pid: 1507, comm: ifup-eth Not tainted 2.6.34.6-47.fc13.x86_64 #1
+Modules linked in: bonding 8021q garp stp llc ipv6 xt_hl ipt_ULOG xt_limit xt_multiport xt_dscp xt_owner iTCO_wdt iTCO_vendor_support i2c_i801 i2c_core ioatdma e1000e dca microcode raid1 [last unloaded: scsi_wait_scan]
+Pid: 1504, comm: ifup-eth Not tainted 2.6.34.6-51.fc13.x86_64 #1
 Call Trace:
  [<ffffffff8104d12f>] warn_slowpath_common+0x7c/0x94
  [<ffffffff8104d19e>] warn_slowpath_fmt+0x41/0x43
  [<ffffffff8115a776>] proc_register+0x152/0x18a
  [<ffffffff8115aaa6>] proc_create_data+0x8c/0xa6
- [<ffffffffa0109f20>] bond_create_proc_entry+0x5a/0x91 [bonding]
- [<ffffffffa010dfed>] bond_init+0x9a/0xd5 [bonding]
+ [<ffffffffa010af27>] bond_create_proc_entry+0x61/0x98 [bonding]
+ [<ffffffffa010eff4>] bond_init+0x9a/0xd6 [bonding]
  [<ffffffff813a8dcb>] register_netdevice+0xe3/0x2be
- [<ffffffffa010a4ca>] bond_create+0x98/0xbd [bonding]
- [<ffffffffa011480d>] bonding_store_bonds+0xb8/0x1bb [bonding]
+ [<ffffffffa010b4d1>] bond_create+0x98/0xbd [bonding]
+ [<ffffffffa0115815>] bonding_store_bonds+0xb8/0x1bb [bonding]
  [<ffffffff812c4367>] class_attr_store+0x23/0x25
  [<ffffffff81162de6>] sysfs_write_file+0x114/0x150
  [<ffffffff8110e08a>] vfs_write+0xae/0x10b
  [<ffffffff8110e1a7>] sys_write+0x4a/0x6e
  [<ffffffff81009c72>] system_call_fastpath+0x16/0x1b
----[ end trace 29a1e3f7a3db1318 ]---
+---[ end trace 78cf2c9c19656333 ]---
 bonding: Bond creation failed.
 bonding: bond0: setting mode to 802.3ad (4).
 bonding: bond0: setting xmit hash policy to layer3+4 (1).
Comment 7 Kyle McMartin 2010-09-03 21:34:23 EDT
I'm kind of at a loss as to what that could be, as there's been very little changes in any of these code paths in a very long time... Could you please pull down the rawhide 2.6.36-rc3 kernel and let me know if that fixes the warning, and if not, I'll file a report upstream.

It's not really clear to me from a quick glance here, does the bond actually work despite the warning, or does it completely fall apart?

THanks, Kyle.
Comment 8 Curtis Doty 2010-09-03 23:56:14 EDT
The module is loading and functioning fine. It seems to be harmless WARN.

If the cause isn't the kernel module itself, then maybe it's some sort of initscripts/udev race related to ifup-eth?

FYI, I also have IPv6 loaded but disabled. And last week, I did some fiddling with bonding alias/options via both an /etc/modprobe.d/bonding.conf as well as the standard /etc/sysconfig/network-scripts/ifcfg-bond0:BONDING_OPTS= stuff. And I think I got it to come up without the WARN by setting ONBOOT=no and then manually brining it up later.

But the WARN is always reproducing with /etc/sysconfig/network-scripts/ifcfg-bond0:ONBOOT=yes and /etc/modprobe.d/bonding.conf:alias bond0 bonding.

Curious, how do I get my hands on rawhide source these days? Both cvs://cvs.fedoraproject.org:/cvs/pkgs/rpms/kernel and git://pkgs.stg.fedoraproject.org/kernel seem to have old 2.6.34 from July still...
Comment 9 Reuben Farrelly 2010-09-09 07:19:39 EDT
I've just rebooted with 2.6.34.6-54 - after reading the changelog:

* Fri Sep 03 2010 Kyle McMartin <kmcmartin@redhat.com>
- sanity-check-bond-proc_entry.patch (rhbz#604630)

... I was hoping that the problem would be fixed.  But it's not, here's the snip out of dmesg again:

lo: Disabled Privacy Extensions
bonding: Ethernet Channel Bonding Driver: v3.6.0 (September 26, 2009)
bonding: Warning: either miimon or arp_interval and arp_ip_target module parameters must be specified, otherwise bonding will not detect link failures! see bonding.txt for details.
bonding: bond0 is being created...
------------[ cut here ]------------
WARNING: at fs/proc/generic.c:598 proc_register+0x152/0x18a()
Hardware name: ProLiant BL465c G1  
proc_dir_entry 'bonding/bond0' already registered
Modules linked in: bonding ipv6 amd64_edac_mod ipmi_si edac_core ipmi_msghandler bnx2 tg3 serio_raw hpwdt k8temp edac_mce_amd i2c_piix4 shpchp microcode hpsa cciss radeon ttm drm_kms_helper drm i2c_algo_bit i2c_core [last unloaded: scsi_wait_scan]
Pid: 987, comm: ifup-eth Not tainted 2.6.34.6-54.fc13.x86_64 #1
Call Trace:
 [<ffffffff8104d12f>] warn_slowpath_common+0x7c/0x94
 [<ffffffff8104d19e>] warn_slowpath_fmt+0x41/0x43
 [<ffffffff8115a776>] proc_register+0x152/0x18a
 [<ffffffff8115aaa6>] proc_create_data+0x8c/0xa6
 [<ffffffffa0230f27>] bond_create_proc_entry+0x61/0x98 [bonding]
 [<ffffffffa0234ff4>] bond_init+0x9a/0xd6 [bonding]
 [<ffffffff813a8e8b>] register_netdevice+0xe3/0x2be
 [<ffffffffa02314d1>] bond_create+0x98/0xbd [bonding]
 [<ffffffffa023b815>] bonding_store_bonds+0xb8/0x1bb [bonding]
 [<ffffffff812c442b>] class_attr_store+0x23/0x25
 [<ffffffff81162de6>] sysfs_write_file+0x114/0x150
 [<ffffffff8110e08a>] vfs_write+0xae/0x10b
 [<ffffffff8110e1a7>] sys_write+0x4a/0x6e
 [<ffffffff81009c72>] system_call_fastpath+0x16/0x1b
---[ end trace 586e0e2a9b066a30 ]---
bonding: Bond creation failed.
bonding: bond0: setting mode to active-backup (1).
bonding: bond0: Setting MII monitoring interval to 100.
bonding: bond0: Setting up delay to 300000.
ADDRCONF(NETDEV_UP): bond0: link is not ready
bonding: bond0: Adding slave eth0.
  alloc irq_desc for 38 on node 0
  alloc kstat_irqs on node 0
bnx2 0000:02:03.0: irq 38 for MSI/MSI-X
bnx2 0000:02:03.0: eth0: using MSI

FWIW I have two bond interfaces, the warn appears when the first bond0 is created but not when bond1 is.

As with the Curtis' log entries the bonding module does seem to work OK,  although I haven't been able to test out a link failure to see how it copes with that or any other problem.  But normal everyday operation seems to be OK.

In terms of ethernet controllers I have:

02:03.0 Ethernet controller: Broadcom Corporation NetXtreme II BCM5706S Gigabit Ethernet (rev 02)
02:04.0 Ethernet controller: Broadcom Corporation NetXtreme II BCM5706S Gigabit Ethernet (rev 02)
49:04.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5715S Gigabit Ethernet (rev a3)
49:04.1 Ethernet controller: Broadcom Corporation NetXtreme BCM5715S Gigabit Ethernet (rev a3)
Comment 10 lejeczek 2010-09-16 18:44:45 EDT
2.6.34.6-54.fc13.x86_64

can confirm, seems like one way to silence this warning, having ONBOOT=yes, is to move bonding options to /etc/modprobe.d/bonding.conf

otherwise had been experiencing these very same symptoms:

bonding: Ethernet Channel Bonding Driver: v3.6.0 (September 26, 2009)
bonding: Warning: either miimon or arp_interval and arp_ip_target module parameters must be specified, otherwise bonding will not detect link failures! see bonding.txt for details.
bonding: bond0 is being created...
------------[ cut here ]------------
WARNING: at fs/proc/generic.c:598 proc_register+0x152/0x18a()
Hardware name: GA-790FXTA-UD5
proc_dir_entry 'bonding/bond0' already registered
Modules linked in: bonding ip6t_REJECT nf_conntrack_ipv6 ip6table_filter ip6_tables ipv6 snd_hda_codec_atihdmi xhci_hcd snd_hda_intel ixgbe edac_core snd_hda_codec dca r8169 edac_mce_amd mdio 8139too 8139cp mii k10temp snd_hwdep snd_seq snd_seq_device snd_pcm snd_timer snd soundcore snd_page_alloc i2c_piix4 ppdev parport_pc parport wmi serio_raw joydev ata_generic pata_acpi firewire_ohci firewire_core crc_itu_t pata_atiixp pata_jmicron radeon ttm drm_kms_helper drm i2c_algo_bit i2c_core [last unloaded: scsi_wait_scan]
Pid: 1273, comm: ifup-eth Not tainted 2.6.34.6-54.fc13.x86_64 #1
Call Trace:
 [<ffffffff8104d12f>] warn_slowpath_common+0x7c/0x94
 [<ffffffff8104d19e>] warn_slowpath_fmt+0x41/0x43
 [<ffffffff8115a776>] proc_register+0x152/0x18a
 [<ffffffff8115aaa6>] proc_create_data+0x8c/0xa6
 [<ffffffffa03adf27>] bond_create_proc_entry+0x61/0x98 [bonding]
 [<ffffffffa03b1ff4>] bond_init+0x9a/0xd6 [bonding]
 [<ffffffff813a8e8b>] register_netdevice+0xe3/0x2be
 [<ffffffffa03ae4d1>] bond_create+0x98/0xbd [bonding]
 [<ffffffffa03b8815>] bonding_store_bonds+0xb8/0x1bb [bonding]
 [<ffffffff812c442b>] class_attr_store+0x23/0x25
 [<ffffffff81162de6>] sysfs_write_file+0x114/0x150
 [<ffffffff8110e08a>] vfs_write+0xae/0x10b
 [<ffffffff8110e1a7>] sys_write+0x4a/0x6e
 [<ffffffff81009c72>] system_call_fastpath+0x16/0x1b
---[ end trace f61dd22b09e90ef0 ]---
bonding: Bond creation failed.
bonding: bond0: Setting MII monitoring interval to 1000.
bonding: bond0: setting mode to 802.3ad (4).
ADDRCONF(NETDEV_UP): bond0: link is not ready
bonding: bond0: Adding slave eth0.
r8169 0000:04:00.0: eth0: link up
r8169 0000:04:00.0: eth0: link up
bonding: bond0: enslaving eth0 as a backup interface with an up link.
bonding: bond0: Adding slave eth1.
r8169 0000:05:00.0: eth1: link up
r8169 0000:05:00.0: eth1: link up
bonding: bond0: enslaving eth1 as a backup interface with an up link.
ADDRCONF(NETDEV_CHANGE): bond0: link becomes ready
eth3: link up, 100Mbps, full-duplex, lpa 0xC5E1
Bridge firewalling registered
bond0: no IPv6 routers present
SELinux: initialized (dev autofs, type autofs), uses genfs_contexts
SELinux: initialized (dev autofs, type autofs), uses genfs_contexts
SELinux: initialized (dev autofs, type autofs), uses genfs_contexts
eth3: no IPv6 routers present
br0: no IPv6 routers present

and yet bond is still working
Comment 11 Richard A Lochner 2010-09-24 14:16:16 EDT
Kyle,

FWIW, I am also experiencing the problem in 2.6.34.6-54.fc13.x86_64.  The bond does appear to come up properly after the message.  

Rick Lochner


Sep 15 12:31:54 vmh002 kernel: bonding: Ethernet Channel Bonding Driver: v3.6.0 (September 26, 2009)
Sep 15 12:31:54 vmh002 kernel: bonding: Warning: either miimon or arp_interval and arp_ip_target module parameters must be specified, otherwise bonding will not detect link failures! see bonding.txt for details.
Sep 15 12:31:54 vmh002 kernel: bonding: bond0 is being created...
Sep 15 12:31:54 vmh002 kernel: ------------[ cut here ]------------
Sep 15 12:31:54 vmh002 kernel: WARNING: at fs/proc/generic.c:598 proc_register+0x152/0x18a()
Sep 15 12:31:54 vmh002 kernel: Hardware name: System Product Name
Sep 15 12:31:54 vmh002 kernel: proc_dir_entry 'bonding/bond0' already registered
Sep 15 12:31:54 vmh002 kernel: Modules linked in: bonding xt_physdev ip6t_REJECT nf_conntrack_ipv6 ip6table_filter ip6_tables be2iscsi bnx2i cnic uio cxgb3i cxgb3 mdio ib_iser rdma_cm ib_cm iw_cm ib_sa ib_mad ib_core ib_addr ipv6 iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi ext2 kvm_intel kvm uinput snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep iTCO_wdt snd_seq snd_seq_device snd_pcm snd_timer snd soundcore snd_page_alloc iTCO_vendor_support i2c_i801 e1000 r8169 mii wmi joydev asus_atk0110 serio_raw microcode pata_acpi ata_generic firewire_ohci pata_jmicron firewire_core crc_itu_t nouveau ttm drm_kms_helper drm i2c_algo_bit video output i2c_core [last unloaded: scsi_wait_scan]
Sep 15 12:31:54 vmh002 kernel: Pid: 1484, comm: ifup-eth Not tainted 2.6.34.6-54.fc13.x86_64 #1
Sep 15 12:31:54 vmh002 kernel: Call Trace:
Sep 15 12:31:54 vmh002 kernel: [<ffffffff8104d12f>] warn_slowpath_common+0x7c/0x94
Sep 15 12:31:54 vmh002 kernel: [<ffffffff8104d19e>] warn_slowpath_fmt+0x41/0x43
Sep 15 12:31:54 vmh002 kernel: [<ffffffff8115a776>] proc_register+0x152/0x18a
Sep 15 12:31:54 vmh002 kernel: [<ffffffff8115aaa6>] proc_create_data+0x8c/0xa6
Sep 15 12:31:54 vmh002 kernel: [<ffffffffa0423f27>] bond_create_proc_entry+0x61/0x98 [bonding]
Sep 15 12:31:54 vmh002 kernel: [<ffffffffa0427ff4>] bond_init+0x9a/0xd6 [bonding]
Sep 15 12:31:54 vmh002 kernel: [<ffffffff813a8e8b>] register_netdevice+0xe3/0x2be
Sep 15 12:31:54 vmh002 kernel: [<ffffffffa04244d1>] bond_create+0x98/0xbd [bonding]
Sep 15 12:31:54 vmh002 kernel: [<ffffffffa042e815>] bonding_store_bonds+0xb8/0x1bb [bonding]
Sep 15 12:31:54 vmh002 kernel: [<ffffffff812c442b>] class_attr_store+0x23/0x25
Sep 15 12:31:54 vmh002 kernel: [<ffffffff81162de6>] sysfs_write_file+0x114/0x150
Sep 15 12:31:54 vmh002 kernel: [<ffffffff8110e08a>] vfs_write+0xae/0x10b
Sep 15 12:31:54 vmh002 kernel: [<ffffffff8110e1a7>] sys_write+0x4a/0x6e
Sep 15 12:31:54 vmh002 kernel: [<ffffffff81009c72>] system_call_fastpath+0x16/0x1b
Sep 15 12:31:54 vmh002 kernel: ---[ end trace 46bc8f0d1a63d6da ]---
Sep 15 12:31:54 vmh002 kernel: bonding: Bond creation failed.
Sep 15 12:31:54 vmh002 kernel: bonding: bond0: setting mode to 802.3ad (4).
Sep 15 12:31:54 vmh002 kernel: bonding: bond0: Setting MII monitoring interval to 100.
Sep 15 12:31:54 vmh002 kernel: bonding: bond0: Warning: up delay (10) is not a multiple of miimon (100), updelay rounded to 0 ms
Sep 15 12:31:54 vmh002 kernel: bonding: bond0: Setting up delay to 0.
Sep 15 12:31:54 vmh002 kernel: bonding: bond0: Setting use_carrier to 1.
Sep 15 12:31:54 vmh002 kernel: ADDRCONF(NETDEV_UP): bond0: link is not ready
Sep 15 12:31:54 vmh002 kernel: bonding: bond0: Adding slave eth0.
Sep 15 12:31:54 vmh002 kernel: r8169 0000:06:00.0: eth0: link up
Sep 15 12:31:54 vmh002 kernel: r8169 0000:06:00.0: eth0: link up
Sep 15 12:31:54 vmh002 kernel: bonding: bond0: enslaving eth0 as a backup interface with an up link.
Sep 15 12:31:54 vmh002 kernel: bonding: bond0: Adding slave eth1.
Sep 15 12:31:54 vmh002 kernel: bonding: bond0: enslaving eth1 as a backup interface with a down link.
Sep 15 12:31:54 vmh002 kernel: ADDRCONF(NETDEV_CHANGE): bond0: link becomes ready
Sep 15 12:31:54 vmh002 kernel: e1000: eth1 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX
Sep 15 12:31:54 vmh002 kernel: Bridge firewalling registered
Sep 15 12:31:54 vmh002 kernel: device bond0 entered promiscuous mode
Sep 15 12:31:54 vmh002 kernel: device eth0 entered promiscuous mode
Sep 15 12:31:54 vmh002 kernel: device eth1 entered promiscuous mode
Sep 15 12:31:54 vmh002 kernel: br0: port 1(bond0) entering learning state
Sep 15 12:31:54 vmh002 kernel: bonding: bond0: link status definitely up for interface eth1.
Comment 12 Richard A Lochner 2010-09-24 14:33:41 EDT
Kyle,

And also 2.6.34.7-56.fc13.x86_64.

Rick
Comment 13 Brian Rademacher 2010-10-02 18:44:16 EDT
Add me to the list with 2.6.34.7-56.fc13.x86_64 ...

IPv6: Loaded, but administratively disabled, reboot required to enable
bonding: Ethernet Channel Bonding Driver: v3.6.0 (September 26, 2009)
bonding: Warning: either miimon or arp_interval and arp_ip_target module parameters must be specified, otherwise bonding will not detect link failures! see bonding.txt for details.
bonding: bond0 is being created...
------------[ cut here ]------------
WARNING: at fs/proc/generic.c:598 proc_register+0x152/0x18a()
Hardware name:
proc_dir_entry 'bonding/bond0' already registered
Modules linked in: bonding ipv6 tg3 amd64_edac_mod edac_core edac_mce_amd shpchp k8temp raid1 raid456 async_raid6_recov async_pq raid6_pq async_xor xor async_memcpy async_tx ata_generic pata_acpi pata_ali sata_mv [last unloaded: scsi_wait_scan]
Pid: 1245, comm: ifup-eth Not tainted 2.6.34.7-56.fc13.x86_64 #1
Call Trace:
 [<ffffffff8104d14f>] warn_slowpath_common+0x7c/0x94
 [<ffffffff8104d1be>] warn_slowpath_fmt+0x41/0x43
 [<ffffffff8115a79a>] proc_register+0x152/0x18a
 [<ffffffff8115aaca>] proc_create_data+0x8c/0xa6
 [<ffffffffa0145f20>] bond_create_proc_entry+0x5a/0x91 [bonding]
 [<ffffffffa0149fed>] bond_init+0x9a/0xd5 [bonding]
 [<ffffffff813a8d8b>] register_netdevice+0xe3/0x2be
 [<ffffffffa01464ca>] bond_create+0x98/0xbd [bonding]
 [<ffffffffa015080d>] bonding_store_bonds+0xb8/0x1bb [bonding]
 [<ffffffff812c43c3>] class_attr_store+0x23/0x25
 [<ffffffff81162e0a>] sysfs_write_file+0x114/0x150
 [<ffffffff8110e0b2>] vfs_write+0xae/0x10b
 [<ffffffff8110e1cf>] sys_write+0x4a/0x6e
 [<ffffffff81009c72>] system_call_fastpath+0x16/0x1b
---[ end trace 4c561eea606938e9 ]---
bonding: Bond creation failed.
bonding: bond0: setting mode to 802.3ad (4).
bonding: bond0: Setting MII monitoring interval to 1000.
bonding: bond0: Adding slave eth0.
tg3 0000:03:03.0: firmware: requesting tigon/tg3_tso.bin
bonding: bond0: enslaving eth0 as a backup interface with a down link.
bonding: bond0: Adding slave eth1.
tg3 0000:03:03.1: firmware: requesting tigon/tg3_tso.bin
bonding: bond0: enslaving eth1 as a backup interface with a down link.
tg3 0000:03:03.0: eth0: Link is up at 1000 Mbps, full duplex
tg3 0000:03:03.0: eth0: Flow control is off for TX and off for RX
tg3 0000:03:03.1: eth1: Link is up at 1000 Mbps, full duplex
tg3 0000:03:03.1: eth1: Flow control is off for TX and off for RX
bonding: bond0: link status definitely up for interface eth0.
bonding: bond0: link status definitely up for interface eth1.
tg3 0000:03:04.1: firmware: requesting tigon/tg3_tso.bin
tg3 0000:03:04.1: eth3: Link is up at 1000 Mbps, full duplex
tg3 0000:03:04.1: eth3: Flow control is off for TX and off for RX
tg3 0000:03:03.0: eth0: Link is down
bonding: bond0: link status definitely down for interface eth0, disabling it
tg3 0000:03:03.1: eth1: Link is down
tg3 0000:03:04.1: eth3: Link is down
bonding: bond0: link status definitely down for interface eth1, disabling it
tg3 0000:03:03.0: eth0: Link is up at 1000 Mbps, full duplex
tg3 0000:03:03.0: eth0: Flow control is off for TX and off for RX
tg3 0000:03:03.1: eth1: Link is up at 1000 Mbps, full duplex
tg3 0000:03:03.1: eth1: Flow control is off for TX and off for RX
bonding: bond0: link status definitely up for interface eth0.
bonding: bond0: link status definitely up for interface eth1.
tg3 0000:03:04.1: eth3: Link is up at 1000 Mbps, full duplex
tg3 0000:03:04.1: eth3: Flow control is off for TX and off for RX
Comment 14 Neil Horman 2010-10-04 07:10:19 EDT
appears to be a race with the sysfs bonding_masters file.  I'll write a patch shortly
Comment 15 Neil Horman 2010-10-04 10:44:37 EDT
Created attachment 451417 [details]
patch to check for existance of a device name before trying to register it

Its untested, but this patch should prevent the warn-on, and instead return -EEXIST to userspace if we try to add an interface that already exists.  It also cleans up the checking of the name, converting bond_get_dev_by_name, to a simple get_dev_by_name, since they're really the same thing.  Heres a build for you to test with.  If this fixes the issue, it appears this will need to go upstream as well.
 http://koji.fedoraproject.org/koji/taskinfo?taskID=2510892
Comment 16 Richard A Lochner 2010-10-04 11:06:51 EDT
Neil,

I will gladly test the patch for you, but I am not a "kernel developer." I would need instructions on how to load the patched kernel.

Rick Lochner
Comment 17 Neil Horman 2010-10-04 11:50:33 EDT
The koji link above provides rpms that you can download and install with rpm.  I thin you're system is 64 bit, right?  This command:
rpm -ivh http://koji.fedoraproject.org/koji/getfile?taskID=2510893&name=kernel-2.6.34.7-59.bz604630.v1.fc13.x86_64.rpm

Should install the new kernel for you.  Just boot it and see if your problem is fixed.
Comment 18 Richard A Lochner 2010-10-04 13:49:58 EDT
Neil,

The patch you provided does appear to fix the problem.  I have attached log entries for a boot after the patch was applied.

Thank you,

Rick Lochner

Oct  4 12:39:44 vmh002 kernel: bonding: Ethernet Channel Bonding Driver: v3.6.0 (September 26, 2009)
Oct  4 12:39:44 vmh002 kernel: bonding: Warning: either miimon or arp_interval and arp_ip_target module parameters must be specified, otherwise bonding will not detect link failures! see bonding.txt for details.
Oct  4 12:39:44 vmh002 kernel: bonding: bond0: setting mode to 802.3ad (4).
Oct  4 12:39:44 vmh002 kernel: bonding: bond0: Setting MII monitoring interval to 100.
Oct  4 12:39:44 vmh002 kernel: bonding: bond0: Warning: up delay (10) is not a multiple of miimon (100), updelay rounded to 0 ms
Oct  4 12:39:44 vmh002 kernel: bonding: bond0: Setting up delay to 0.
Oct  4 12:39:44 vmh002 kernel: bonding: bond0: Setting use_carrier to 1.
Oct  4 12:39:44 vmh002 kernel: ADDRCONF(NETDEV_UP): bond0: link is not ready
Oct  4 12:39:44 vmh002 kernel: bonding: bond0: Adding slave eth0.
Oct  4 12:39:44 vmh002 kernel: r8169 0000:06:00.0: eth0: link up
Oct  4 12:39:44 vmh002 kernel: r8169 0000:06:00.0: eth0: link up
Oct  4 12:39:44 vmh002 kernel: bonding: bond0: enslaving eth0 as a backup interface with an up link.
Oct  4 12:39:44 vmh002 kernel: bonding: bond0: Adding slave eth1.
Oct  4 12:39:44 vmh002 kernel: bonding: bond0: enslaving eth1 as a backup interface with a down link.
Oct  4 12:39:44 vmh002 kernel: ADDRCONF(NETDEV_CHANGE): bond0: link becomes ready
Oct  4 12:39:44 vmh002 kernel: e1000: eth1 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX
Oct  4 12:39:44 vmh002 kernel: Bridge firewalling registered
Oct  4 12:39:44 vmh002 kernel: device bond0 entered promiscuous mode
Oct  4 12:39:44 vmh002 kernel: device eth0 entered promiscuous mode
Oct  4 12:39:44 vmh002 kernel: device eth1 entered promiscuous mode
Oct  4 12:39:44 vmh002 kernel: br0: port 1(bond0) entering learning state
Oct  4 12:39:44 vmh002 kernel: bonding: bond0: link status definitely up for interface eth1.
Comment 19 Neil Horman 2010-10-04 14:38:58 EDT
great, I'll post this upstream and put it in fedora as soon as its comitted.  Thanks!
Comment 20 Reuben Farrelly 2010-10-05 03:41:39 EDT
With this new kernel things are "different" but not fixed.

The initial oops has gone, but is replaced by an different one:

bonding: bond1 is being created...
BUG: unable to handle kernel NULL pointer dereference at 00000000000003c0
IP: [<ffffffffa02417ae>] bonding_store_bonds+0x13f/0x17f [bonding]

Also now the VLANs that I was running over the bonded interface don't work on account of "8021q: VLANs not supported on bond1".  These work fine with 2.6.34.7-56.fc13.x86_64 so it's a regression of sorts.

New dmesg will be uploaded in a minute.
Comment 21 Reuben Farrelly 2010-10-05 03:43:03 EDT
Created attachment 451599 [details]
New dmesg with patched kernel

dmesg output from kernel-2.6.34.7-59.bz604630.v1.fc13.x86_64
Comment 22 Neil Horman 2010-10-05 07:09:39 EDT
Thanks for the update, I see the problem and will have a clean version that can go upstream and info fedora shortly.
Comment 23 Neil Horman 2010-10-06 10:39:50 EDT
Created attachment 451907 [details]
patch to prevent WARN_ON during bonding_masters write

New patch that went in upstream as commit:
http://git.kernel.org/?p=linux/kernel/git/davem/net-2.6.git;a=commit;h=27e6f065df132b5270014d3285889b15185e9da9

I'll apply this to f13 shortly, rawhide will pick it up from upstream soon I imagine, as its in the net-2.6 tree
Comment 24 Fedora Update System 2010-10-19 02:31:51 EDT
kernel-2.6.34.7-61.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/kernel-2.6.34.7-61.fc13
Comment 25 Fedora Update System 2010-10-22 14:05:08 EDT
kernel-2.6.34.7-61.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 26 Reuben Farrelly 2011-02-21 06:01:58 EST
Hi,

Any chance this can be pushed to the FC14 repository also?  The oops was fixed in FC13 kernels but doesn't seem to have made it's way to FC14...
Comment 27 Chuck Ebbert 2011-02-24 13:12:25 EST
(In reply to comment #26)

> Any chance this can be pushed to the FC14 repository also?  The oops was fixed
> in FC13 kernels but doesn't seem to have made it's way to FC14...

Applied to F14 and will be in the next build.
Comment 28 Neil Horman 2011-03-29 11:16:57 EDT
*** Bug 668165 has been marked as a duplicate of this bug. ***
Comment 29 Josh Boyer 2011-08-26 15:00:17 EDT
This has been fixed since 2.6.35.11-85

Note You need to log in before you can comment on or make changes to this bug.