Bug 604636 - Missing headers net-snmp/agent/util_funcs/*
Summary: Missing headers net-snmp/agent/util_funcs/*
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: net-snmp   
(Show other bugs)
Version: 6.0
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: Jan Safranek
QA Contact: Karel Srot
URL:
Whiteboard:
Keywords:
Depends On: 603243
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-16 11:45 UTC by Jan Safranek
Modified: 2010-11-10 21:12 UTC (History)
4 users (show)

Fixed In Version: net-snmp-5.5-22.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 603243
Environment:
Last Closed: 2010-11-10 21:12:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jan Safranek 2010-06-16 11:45:27 UTC
+++ This bug was initially created as a clone of Bug #603243 +++

Description of problem:

/usr/include/net-snmp/agent/util_funcs.h requires util_funcs/header_{generic,simple_table}.h which are not available. Compiling applications (like SNMP subagents) requiring the functions defined in those headers is not possible. This bug is not present in F12.

Version-Release number of selected component (if applicable):

net-snmp-devel-5.5-12.fc13.i686

How reproducible:

Always

Steps to Reproduce:
1. yum install net-snmp-devel
2. curl http://www.luffy.cx/lldpd-0.5.1.tar.gz | tar zxvf -
3. cd lldpd-0.5.1
4. ./configure --with-snmp
5. make
  
Actual results:

A build error because of the missing headers.

Expected results:

Build should be successful.

Additional info:

find /usr/include/net-snmp/agent | grep util_funcs only outputs "/usr/include/net-snmp/agent/util_funcs.h

--- Additional comment from jsafrane@redhat.com on 2010-06-14 08:36:56 EDT ---

net-snmp-5.5 restructured its header files and it misses some of them during 'make install'... I'll look at it.

Comment 1 RHEL Product and Program Management 2010-06-16 11:53:15 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 4 releng-rhel@redhat.com 2010-11-10 21:12:27 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.