Bug 60477 - KDE gives blank screen
Summary: KDE gives blank screen
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdebase   
(Show other bugs)
Version: 7.2
Hardware: athlon
OS: Linux
medium
high
Target Milestone: ---
Assignee: wdovlrrw
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-02-28 08:11 UTC by Stephen Rasku
Modified: 2007-04-18 16:40 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-12 10:15:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Stephen Rasku 2002-02-28 08:11:36 UTC
Description of Problem:

When I execute startx, KDE will display the KDE log and hang for several seconds
on "Initializing system services".  After a while, the logo disappears and I am
left with a blank blue screen (i.e. no front panel).  I have to exit using
ctrl-alt-backspace.  When I exit, I see the following message:


---------------------------------
It looks like dcopserver is already running. If you are sure
that it is not already running, remove /home/stephen/.DCOPserver_h24-83-219-128_:0
and start dcopserver again.
---------------------------------

kdeinit: Communication error with launcher. Exiting!
KDE Daemon (kded) already running.

I am running gnome to submit this bug and when I do "ps -ef | grep kde", I get:

stephen   1053     1  0 Feb27 ?        00:00:00 kdeinit: dcopserver --nosid
stephen   1965     1  0 Feb27 ?        00:00:00 kdeinit: klauncher       
stephen   2588     1  0 Feb27 ?        00:00:00 kdeinit: Running...      
stephen   2805  2668  0 00:06 pts/1    00:00:00 grep kde

Version-Release number of selected component (if applicable):

I installed the following RPMS from updates.redhat.com:

    arts-2.2.2-2.i386.rpm
    kdebase-2.2.2-1.i386.rpm
    kdelibs-2.2.2-2.i386.rpm
    kdelibs-sound-2.2.2-2.i386.rpm
    libxml2-2.4.10-0.7x.2.i386.rpm
    libxslt-1.0.7-2.i386.rpm


How Reproducible:

100% but I haven't re-booted yet.

Expected Results:

KDE starts up properly.

Additional Information:

I just recently installed (not upgraded) 7.2 on this machine.  Previously I had
7.1 installed and working fine with KDE on this machine.  I have done minimal
configuration changes to this machine so far and nothing to do with X or KDE,
yet.  It is basically vanilla.

Comment 1 Stephen Rasku 2002-02-28 08:22:58 UTC
Rebooting didn't fix the problem.

Comment 2 Bernhard Rosenkraenzer 2002-03-04 11:39:24 UTC
Does "rm -rf /tmp/.X11-unix /tmp/.ICE-unix ~/.DCOP* ~/.kde/tmp-* ~/.kde/socket*" help?

Comment 3 Stephen Rasku 2002-03-05 06:28:24 UTC
That worked.  What did I just do?  Can you point me to some documentation
explaining this black magic?

Comment 4 Stephen Rasku 2002-03-06 03:56:47 UTC
Hmmm..., it seemed to only work that one time.  Removing these files again has
no effect.

Comment 5 Stephen Rasku 2002-03-06 04:03:07 UTC
There is a problem with the sound system.  Before it stopped starting up, I
would get an error saying that it was using a null sound device or something
like that.

Comment 6 Bernhard Rosenkraenzer 2002-03-12 10:15:29 UTC
Which kernel and soundcard are you using?

Comment 7 Stephen Rasku 2002-04-06 18:18:43 UTC
If you are interested, my sound card is an old Soundblaster 16.  My kernel is
kernel-2.4.9-31 (i386).  I am going to close this since I haven't noticed the
startup problem since upgrading to KDE 3.0


Note You need to log in before you can comment on or make changes to this bug.