Bug 604798 - KNetworkManager does not display labels in the popup menu
KNetworkManager does not display labels in the popup menu
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kde-plasma-networkmanagement (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
: Reopened, Triaged
Depends On:
Blocks: kde-4.5
  Show dependency treegraph
 
Reported: 2010-06-16 14:29 EDT by Andrei Nistor
Modified: 2010-10-01 08:22 EDT (History)
10 users (show)

See Also:
Fixed In Version: kde-plasma-networkmanagement-0.9-0.25.20100920.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-01 08:22:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
knm screenshot (6.73 KB, image/png)
2010-06-16 14:29 EDT, Andrei Nistor
no flags Details

  None (edit)
Description Andrei Nistor 2010-06-16 14:29:04 EDT
Created attachment 424548 [details]
knm screenshot

Description of problem:
KNetworkManager does not display labels or icons in the popup menu. I have tested with Qt 4.7 and 4.6

Someone on IRC suggested that it might be a problem with dbusmenu-qt.


Version-Release number of selected component (if applicable):
4.4.85 (KDE 4.5 beta2)

How reproducible:
always
Comment 1 Kevin Kofler 2010-06-16 16:51:27 EDT
knetworkmanager comes from the kde-plasma-networkmanagement SRPM (they're shipped in the same directory tree upstream). The knetworkmanager package is obsolete. Reassigning.
Comment 2 Aelia 2010-07-09 06:29:15 EDT
I have some problem in fedora 13 after upgrade to kde 4.5 from rawhide repo.

qt-4.7.0-0.24.beta1.fc14.x86_64
knetworkmanager-0.9-0.20.20100603.fc14.x86_64
Comment 3 Rex Dieter 2010-07-09 07:55:33 EDT
I believe this is some sort of known problem between knm and the new dbusmenu-qt used in kde-4.5.
Comment 4 Rex Dieter 2010-08-14 17:54:55 EDT
Is this still reproducible with kde-4.5.0 + dbusmenu-qt-0.5.2 ?

(I can't on my f13 + kde-4.5.0 box anyway).
Comment 5 Andrei Nistor 2010-08-14 18:32:31 EDT
Looks like it's fixed on my computer.
Comment 6 Rex Dieter 2010-08-14 18:34:50 EDT
Excellent, thanks for the confirmation.
Comment 7 Rex Dieter 2010-08-30 17:03:13 EDT
User reported seeing this today, and I can reproduce it. :(
Comment 8 Rex Dieter 2010-08-30 19:24:03 EDT
rats, a knm snapshot from today has the same problem.  options:
1.  fix this in monolithic knm 
2.  migrate folks knm -> kde-plasma-nm

time to ping upstream whether 1 is fixable or not.
Comment 9 Fedora Admin XMLRPC Client 2010-09-11 19:52:10 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 10 Laurent Le Grandois 2010-09-17 01:51:52 EDT
Hi,
same problem on Fedora 13 2.6.34.6-54.fc13.x86_64 with :
- knetworkmanager-0.9-0.22.20100830.fc13.kde45.x86_64
- dbusmenu-qt-0.5.2-1.fc13.x86_64

Regards
llg
Comment 11 Fedora Update System 2010-09-20 12:22:54 EDT
kde-plasma-networkmanagement-0.9-0.24.20100920.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/kde-plasma-networkmanagement-0.9-0.24.20100920.fc14
Comment 12 Fedora Update System 2010-09-23 13:14:53 EDT
kde-plasma-networkmanagement-0.9-0.25.20100920.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/kde-plasma-networkmanagement-0.9-0.25.20100920.fc14
Comment 13 Fedora Update System 2010-09-23 15:34:02 EDT
kde-plasma-networkmanagement-0.9-0.25.20100920.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kde-plasma-networkmanagement'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/kde-plasma-networkmanagement-0.9-0.25.20100920.fc14
Comment 14 Fedora Update System 2010-10-01 08:22:17 EDT
kde-plasma-networkmanagement-0.9-0.25.20100920.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.