Bug 60481 - Cannot rebuild WindowMaker-0.80.0-6.src.rpm on Red Hat 7.2
Cannot rebuild WindowMaker-0.80.0-6.src.rpm on Red Hat 7.2
Status: CLOSED DEFERRED
Product: Red Hat Raw Hide
Classification: Retired
Component: WindowMaker (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Copeland
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-28 07:12 EST by Need Real Name
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-28 09:46:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-02-28 07:12:38 EST
I cannot rebuild WindowMaker-0.80-6.src.rpm on Red Hat 7.2


Version-Release number of selected component (if applicable):
Red Hat 7.2 for i386
WindowMaker-0.80-6.src.rpm from rawhide

How Reproducible:
rpm --rebuild  WindowMaker-0.80-6.src.rpm


Actual Results:
....
+ sed -e 's/\/usr\/local\/GNUstep/\/usr\/lib\/GNUstep/g;
			s/\/usr\/local\/share\/WindowMaker/\/usr\/share\/WindowMaker/g;
			s/\/usr\/local\/Acrobat3\/bin\/acroread/acroread/g;'
+ mv WindowMaker/plmenu.zh_TW.Big5.tmp WindowMaker/plmenu.zh_TW.Big5
+ libtoolize --copy --force
You should add the contents of `/usr/share/aclocal/libtool.m4' to `aclocal.m4'.
+ aclocal -I .
+ autoheader
/usr/bin/m4: configure.in: No such file or directory
+ automake --add-missing
configure.ac: 36: required file `src/config.h.in' not found
+ autoconf
autoconf: configure.in: No such file or directory
error: Bad exit status from /var/tmp/rpm-tmp.25140 (%prep)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.25140 (%prep)


Expected Results:
WindowMaker-0.80.0-6.i386.rpm

Additional Information:
I can give you the list of the RPMs installed on my machine. However, this is a
very standard RedHat 7.2 station with some added packages (including the last
GnuStep packages)
Comment 1 Need Real Name 2002-02-28 07:28:26 EST
A remark concerning the integration of WindowMaker with GNUstep.
The SRPMS placed on ftp.gnustep.org can be rebuilt without problems on Red Hat
7.2.
However, everything is installed under /usr/GNUstep.
If you consider Gorm, you can find:
 /usr/GNUstep/System/Apps/Gorm

I looked at the .spec file for WindowMaker and I found:
%configure \
...
	--with-appspath=/usr/lib/GNUstep/Apps \
...

Can't this be the source of problem?
/usr/lib/GNUstep/Apps vs  /usr/GNUstep/System/Apps/Gorm

I suppose there are others subtilities in this spirit hidden here and there...


Now my question:
Can't WindowMaker be installed according to the GNUstep standard or...
Can't RedHat modify the SRPMS provided by gnustep.org to make them comply the
Red Hat standard?
Comment 2 Phil Copeland 2002-02-28 07:51:41 EST
no can do
This is to make windowmaker compliant with the LSB/FSB standard

    http://www.linuxbase.org/
    http://www.pathname.com/fhs/

0.80.-6 is intended foruse with rawhide (aka the shape of the next release) and
does build happily through the build systems here. I'm not entirely sure why
your attempt fails.

Comment 3 Need Real Name 2002-02-28 09:46:05 EST
I don't know either what is wrong with 0.80.0-6 on RH72 but it does not built...
If I was using RH 4.0 I would understand but 7.2 with all the upgrades
installed... It sounds to me a little bit ridiculous not to be able to have this
simple package rebuilt....

WindowMaker is a good looking Desktop Manager It is intended to work with
GNUstep. So... Wouldn't it be sound and clever to have them working together
withour requiring from a fresh, innocent user to hack like hell and be pissed
for 2 days... So, if WindowMaker does comply to the FHS (Which I understand,
BTW, as "put thousands of binaries in /usr/bin...."), maybe the GNUstep RPMs can
be adapted to the same philosophy...
As I said, the SRPMS from gnustep.org build perfectly on RH72. Maybe you can
modify the .specs files a little bit (the built paths, not so hard...) and
insert them into the RawHide tree. To offer a more complete solution and a
COHERENT, STANDARDISED one... Red Hat would win with that (GNUstep API = Mac OS
X API, can be good to follow the trend too... )

What do you think about it?

Daniel
Comment 4 Phil Copeland 2002-03-04 16:19:25 EST
I think I'm doomed whatever I do.

Ok well thats rawhide for you 8)
To be honest I've been waiting for the WindowMaker folks to get me an updated
-extra package before revisiting the WindowMaker issues.

Largo may be able to get me something soon and I'll update accordingly

Phil
=--=

Note You need to log in before you can comment on or make changes to this bug.