Bug 60482 - nautilus crashes when folder is removed
Summary: nautilus crashes when folder is removed
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: nautilus   
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 67218 79579
TreeView+ depends on / blocked
 
Reported: 2002-02-28 12:41 UTC by Edmund Lam
Modified: 2007-04-18 16:40 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-16 14:44:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Edmund Lam 2002-02-28 12:41:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8+) Gecko/20020214

Description of problem:
nautilus crashes or terminates when a folder or directory or file is removed
behind its back

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Direct nautilus to the directory /tmp/a/b
2. In a terminal window, recursively delete the directory /tmp/a

And next, either 3a or 3b will occur. I haven't been able to determine what
causes one to happen in preference to the other.

3a. When the nautilus window is refreshed, an error message is displayed stating
that the directory c is missing and nautilus dies
3b. When the nautilus window is refreshed, nautilus dies without warning.
	

Actual Results:  nautilus either crashes or terminates -- not sure whether there
is a difference in this case.

Expected Results:  Nautilus may optionally display an error message and change
its current directory to "/tmp". It should not terminate

Additional info:

A similar bug also occurs when nautilus is used to view a file (eg plain text)
and the text file is deleted. If a refresh is forced upon nautilus, the program
crashes.

Comment 1 Havoc Pennington 2002-07-02 23:11:17 UTC
I'd expect this to be fixed in Rawhide.

Comment 2 Elliot Lee 2002-08-28 19:30:54 UTC
Reproduced 3b with nautilus-2.0.5-4

Comment 3 Alexander Larsson 2003-01-16 14:44:16 UTC
I can't reproduce this with the latest nautilus in rawhide. If i delete a
textfile that is displayed the window is removed. If i rm -rf /tmp/a while
showing /tmp/a/b nothing happens, but when i refresh the directory i get a
warning that it couldn't be opened, "maybe it was removed", then the window
disappears. If i'm in /tmp/a when it is removed the window just disappears.



Note You need to log in before you can comment on or make changes to this bug.