Bug 604888 - [abrt] crash in Django-1.1.1-2.fc12: importlib.py:28:import_module:TypeError: relative imports require the 'package' argument
[abrt] crash in Django-1.1.1-2.fc12: importlib.py:28:import_module:TypeError:...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: Django (Show other bugs)
12
ppc Linux
low Severity medium
: ---
: ---
Assigned To: Steve Milner
Fedora Extras Quality Assurance
abrt_hash:ed84a7eb
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-16 19:07 EDT by ringwald
Modified: 2010-06-18 15:00 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-18 15:00:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.46 KB, text/plain)
2010-06-16 19:07 EDT, ringwald
no flags Details

  None (edit)
Description ringwald 2010-06-16 19:07:02 EDT
abrt 1.0.9 detected a crash.

architecture: ppc
cmdline: /usr/bin/python /usr/bin/django-admin --settings=./settings.py
component: Django
executable: /usr/bin/django-admin
kernel: 2.6.32.12-115.fc12.ppc
package: Django-1.1.1-2.fc12
reason: importlib.py:28:import_module:TypeError: relative imports require the 'package' argument
release: Fedora release 12 (Constantine)

backtrace
-----
importlib.py:28:import_module:TypeError: relative imports require the 'package' argument

Traceback (most recent call last):
  File "/usr/bin/django-admin", line 5, in <module>
    management.execute_from_command_line()
  File "/usr/lib/python2.6/site-packages/django/core/management/__init__.py", line 353, in execute_from_command_line
    utility.execute()
  File "/usr/lib/python2.6/site-packages/django/core/management/__init__.py", line 303, in execute
    self.fetch_command(subcommand).run_from_argv(self.argv)
  File "/usr/lib/python2.6/site-packages/django/core/management/__init__.py", line 252, in fetch_command
    app_name = get_commands()[subcommand]
  File "/usr/lib/python2.6/site-packages/django/core/management/__init__.py", line 101, in get_commands
    apps = settings.INSTALLED_APPS
  File "/usr/lib/python2.6/site-packages/django/utils/functional.py", line 269, in __getattr__
    self._setup()
  File "/usr/lib/python2.6/site-packages/django/conf/__init__.py", line 40, in _setup
    self._wrapped = Settings(settings_module)
  File "/usr/lib/python2.6/site-packages/django/conf/__init__.py", line 73, in __init__
    mod = importlib.import_module(self.SETTINGS_MODULE)
  File "/usr/lib/python2.6/site-packages/django/utils/importlib.py", line 28, in import_module
    raise TypeError("relative imports require the 'package' argument")
TypeError: relative imports require the 'package' argument

Local variables in innermost frame:
name: './settings.py'
package: None
Comment 1 ringwald 2010-06-16 19:07:04 EDT
Created attachment 424608 [details]
File: backtrace
Comment 2 Steve Milner 2010-06-17 09:56:48 EDT
ringwald,

Was this related to your own application or was it related to the Django package itself?
Comment 3 ringwald 2010-06-18 14:55:20 EDT
The application was just the first step in the tutorial on django's website. I solved my problem by uninstalling the Django-1.1.1-2.fc12 rpm, removing the django subdirectory in site-packages, and then installing the official 1.1.2 tarball from their website.
Comment 4 Steve Milner 2010-06-18 15:00:36 EDT
After looking at the stack trace and your response it looks like it isn't an actual issue. I'm I'm wrong please let me know and I'll look into it. I'll go ahead and close it as not a bug then. Thanks!

Note You need to log in before you can comment on or make changes to this bug.