Bug 604963 - OpenOffice.org crashes in framework::TransactionManager::impl_throwExceptions (reading MS document template file)
Summary: OpenOffice.org crashes in framework::TransactionManager::impl_throwExceptions...
Status: CLOSED DUPLICATE of bug 566679
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: openoffice.org   
(Show other bugs)
Version: 5.5
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Caolan McNamara
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-17 06:59 UTC by Göran Uddeborg
Modified: 2010-06-17 11:59 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-17 10:05:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Debug information generated by Openoffice when it crashed (10.30 KB, application/octet-stream)
2010-06-17 06:59 UTC, Göran Uddeborg
no flags Details
The document causing the crash (118.50 KB, application/msword)
2010-06-17 07:04 UTC, Göran Uddeborg
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 110101 None None None Never
OpenOffice.org 112011 None None None Never

Description Göran Uddeborg 2010-06-17 06:59:53 UTC
Created attachment 424695 [details]
Debug information generated by Openoffice when it crashed

Description of problem:
When trying to open a file COE_JUP_BuildProcedure.dot with a document template, Openoffice crashes.

Version-Release number of selected component (if applicable):
openoffice.org-3.1.1-19.5.el5_5.1

How reproducible:
Every time

Steps to Reproduce:
1. ooffice COE_JUP_BuildProcedure.dot
  
Actual results:
Crash message from Openoffice.

Expected results:
The document in an editor window.

Additional info:
The initial error message is

terminate called after throwing an instance of 'com::sun::star::lang::DisposedException'

Comment 1 Göran Uddeborg 2010-06-17 07:04:17 UTC
Created attachment 424701 [details]
The document causing the crash

This is what I try to open when I get the crash.  (The document is copyrighted by Jeppesen, but can be used freely for the purpose of investigating this bug.)

Comment 2 Caolan McNamara 2010-06-17 08:18:04 UTC
I fancy this as a duplicate of bug 566679. Very similar stack anyway.

i.e. my suspicion is that it's not directly connected to the .dot file, but to a corruption or different db4 format cache file in your ~/.openoffice.org* dir.

So....

try this, 

a) make sure OOo is shutdown
b) mv .openoffice.org backupconfig
and see if the .dot then opens up
if it does then you can 

c) tar cjf backupconfig.tar.gz backupconfig
and attach it here for a look-see at the config

Comment 3 Göran Uddeborg 2010-06-17 09:55:38 UTC
Created attachment 424736 [details]
Old configuration as requested

That seems like a correct assumption.  After moving away my configuration I could open the document.

Comment 4 Caolan McNamara 2010-06-17 10:05:41 UTC
file ./3/user/uno_packages/cache/uno_packages.db ./3/user/uno_packages/cache/registry/com.sun.star.comp.deployment.configuration.PackageRegistryBackend/registered_packages.db 
./3/user/uno_packages/cache/uno_packages.db:                                                                                   Berkeley DB (Hash, version 9, native byte-order)
./3/user/uno_packages/cache/registry/com.sun.star.comp.deployment.configuration.PackageRegistryBackend/registered_packages.db: Berkeley DB (Hash, version 9, native byte-order)


Indeed, exactly the same as bug 566679 those should be version 8 on RHEL-5, so they were possibly created by a different db4 somehow, the other time i saw that was a dual boot box with a shared home dir, same might happen over nfs maybe

*** This bug has been marked as a duplicate of bug 566679 ***

Comment 5 Göran Uddeborg 2010-06-17 11:59:34 UTC
It could be a pollution from RHEL 6 in my case too.  I have a test installation of RHEL 6 in a virtual machine.  I'm not sure, but I may have tried Openoffice in it, using my ordinary home directory at the time.


Note You need to log in before you can comment on or make changes to this bug.