Bug 604979 - OpenOffice.org Writer does not print on remote samba printer, but Impress, etc. does
Summary: OpenOffice.org Writer does not print on remote samba printer, but Impress, et...
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org   
(Show other bugs)
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-17 07:54 UTC by Frank
Modified: 2010-06-18 07:48 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-18 07:48:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Cupsd error_log with loglevel debug2 (30.75 KB, application/x-gzip)
2010-06-17 09:42 UTC, Frank
no flags Details

Description Frank 2010-06-17 07:54:07 UTC
Description of problem:
Openoffice Writer does not print on remote samba printer after upgrade from F12 to F13. Other applications, including other openoffice Applications (calc, impress) print without problems. Printing in F12 worked without issues.


Version-Release number of selected component (if applicable):
3.2.0-12.24-F13

How reproducible:
always

Steps to Reproduce:
1. Try to print on printer smb:// (see below)
2.
3.
  
Actual results:
something gets sent to printer (printer queue reports no errors), but then there's no job in the queue. Nothing is printed.

Expected results:
printout

Additional info:
Here'S the entry in printer.conf

<Printer ps>
AuthInfoRequired username,password
Info Ricoh
Location RHRK
MakeModel Ricoh Aficio MP 6001 PS
DeviceURI smb://my_username:secret_passsword@UNI-KL.DE/drucker.uni-kl.de/ps
State Idle
StateTime 1276682834
Type 8433908
Filter application/vnd.cups-raw 0 -
Filter application/vnd.cups-postscript 0 foomatic-rip
Accepting Yes
Shared No
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0
OpPolicy default
ErrorPolicy abort-job
Option fitplot True
</Printer>

Comment 1 Caolan McNamara 2010-06-17 08:23:06 UTC
impress and calc work, but writer doesn't ? That's surprising, so say the least, to me.

Comment 2 Caolan McNamara 2010-06-17 08:24:42 UTC
And this is with even a simple newly created writer document with e.g. just "hello world" on it.

Comment 3 Frank 2010-06-17 08:38:24 UTC
Yes - I just tried to make sure:
new document with a few words in writer: no print.
Printing from impress: job submitted to queue and printed

(although I haven't looked at the printout yet because it's a remote printer in a different building, but recent prints with calc and impress worked fine)

Comment 4 Caolan McNamara 2010-06-17 08:54:22 UTC
I'd be interested in finding out what happens if you use print to file in writer, save as some example.ps, and the open that example.ps in evince and try and print from there. Does that work or fail ?

caolanm->twaugh: Do we have a list of easy-to-set-by-user flags to get some useful logging as to how far the output .ps got.

Comment 5 Frank 2010-06-17 09:06:06 UTC
Printing ps from evince works, however, I was asked for authentication. Entering my linux user password (NOT samba password) worked, and the document got printed.

Comment 6 Frank 2010-06-17 09:42:58 UTC
Created attachment 424733 [details]
Cupsd error_log with loglevel debug2

Comment 7 Frank 2010-06-17 09:44:17 UTC
Above attachment is the error_log after setting cupsd loglevel to debug2. Attempt to print from OOWriter starts at 11:30

Comment 8 Frank 2010-06-17 10:36:50 UTC
I realized that the recent prints worked??!! I'm wondering whether this is due to the authentication during the evince print above, or due to the yum upgrade I just did. I'll keep an eye on this, and will close the bug if it doesn't reappear.

Comment 9 Tim Waugh 2010-06-17 11:32:42 UTC
(In reply to comment #4)
> caolanm->twaugh: Do we have a list of easy-to-set-by-user flags to get some
> useful logging as to how far the output .ps got.    

Information about debugging printing issues is here:
  https://fedoraproject.org/wiki/Printing/Debugging

Comment 10 Tim Waugh 2010-06-17 11:34:19 UTC
(In reply to comment #0)
> <Printer ps>
> AuthInfoRequired username,password
...

This part says that at some point in the past, the backend failed and told CUPS that it needed a username and password in order to succeed next time.  Perhaps some configuration changed on the Windows machine.

Comment 11 Frank 2010-06-18 07:48:23 UTC
Works after the update, even after reboot. Still not clear why openoffice writer was the only program affected. 
Thanks for helping.


Note You need to log in before you can comment on or make changes to this bug.