Bug 605 - Can't send to User@host (user@host is OK)
Can't send to User@host (user@host is OK)
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: sendmail (Show other bugs)
5.2
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Florian La Roche
:
: 604 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1998-12-26 10:43 EST by marcelvdh
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-03-22 12:42:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description marcelvdh 1998-12-26 10:43:05 EST
We're unable to send local email in Redhat 5.2 to accounts
that start with a captial letter. Thus email can be sent
locally from root@localhost to user@localhost, but NOT to
User1@localhost. (accounts starting with a capital letter
cannot receive mail).

signed,

Marcel van den Hof (we have tested this with a clean
install with other ppl's computers and they also experience
the problem)
Comment 1 Bill Nottingham 1998-12-28 11:02:59 EST
*** Bug 605 has been marked as a duplicate of this bug. ***

We're unable to send local email in Redhat 5.2 to accounts
that start with a captial letter. Thus email can be sent
locally from root@localhost to user@localhost, but NOT to
User1@localhost. (accounts starting with a capital letter
cannot receive mail).
%
Comment 2 Jeff Johnson 1998-12-31 12:55:59 EST
From rfc 821:

"For some hosts the user name is case sensitive, and SMTP
implementations must
take case to preserve the case of user names as they appear in mailbox
arguments. Host names are not case sensitive."
Comment 3 Preston Brown 1999-03-22 12:42:59 EST
Let me verify something.  You are unable to send mail to users names
starting with capital letters, and those users exist on the system
with usernames physically starting with capital letters? I.e. there is
an entry in /etc/aliases or /etc/passwd for them with the
capitalization you speak of?

If you are simply trying to address normal users (which have all
lowercase login names) with a capital letter, then this will fail, and
the behaviour is expected as referenced from the RFC.  Please re-open
the bug if this is not the case.

Note You need to log in before you can comment on or make changes to this bug.