Bug 60510 - RFE: split php-manual into several packages
Summary: RFE: split php-manual into several packages
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: php   
(Show other bugs)
Version: 7.2
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Phil Copeland
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-02-28 19:53 UTC by Michael Schwendt
Modified: 2007-03-27 03:51 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-18 15:39:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael Schwendt 2002-02-28 19:53:22 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020205

Request for enhancement:

Please split the multi-language php-manual rpm into several packages, so one
doesn't have to install a huge 15 MiB compressed rpm just to get the PHP Manual
in one language. E.g.

  php-manual-cs
  php-manual-de
  php-manual-en
  php-manual-es
  ...

If necessary, add a php-manual-common.

Version-Release number of selected component (if applicable):
4.0.6-12 (errata release)

Comment 1 Phil Copeland 2002-03-04 20:40:00 UTC
*shrugg* I asked around. Not the policy here. The manuals do not really change
from errata to errata release so thers really no reason to pull them down. The
reason it's a singular rpm is because it's languified.

Phil
=--=

Comment 2 Nils Philippsen 2002-03-18 08:02:08 UTC
Maybe it's not such a big deal to download one 15meg package, but having nearly
100 megs wasted on the disk is not the thing to do. Having the package
languified(?) means using "%lang(...)" tags in the %files section, right? If so,
first rpm installed all of them anyway and second I am not able to sensibly select
the languages I want, as I don't only want the language in set in $LANG (I
consider %lang a failed experiment). Whether or not, I just looked and have 10
translations on my disk I really don't want. And I don't want to just remove files
in the rpm database either.

If you can't justify the time spent, tell me a version-release to begin with and
I shall send you a split-up package back.

Comment 3 Nalin Dahyabhai 2002-03-18 15:30:07 UTC
nils, if you're getting all of the translations installed, then you're getting
them because RPM is installing files marked for all languages.  Check the
setting for %_install_langs in /usr/lib/rpm/macros to verify this.

Comment 4 Nils Philippsen 2002-03-18 15:39:34 UTC
And the proposed way to change the set of installed languages for a specific
package is "rpm -ivh <samepackage.rpm> --define '_install_langs <list of langs>'
--replacepkgs"? Yuck.


Note You need to log in before you can comment on or make changes to this bug.