Bug 60511 - Trailing : on LD_LIBRARY_PATH puts . in the path
Summary: Trailing : on LD_LIBRARY_PATH puts . in the path
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-02-28 20:09 UTC by Havoc Pennington
Modified: 2016-11-24 14:53 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-28 20:09:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Havoc Pennington 2002-02-28 20:09:23 UTC
Not sure if this is a bug or intended behavior:

$ mkdir /tmp/testing
$ cd /tmp/testing
$ touch libc.so
$ touch libc.so.6
$ LD_LIBRARY_PATH=. ls
ls: error while loading shared libraries: ./libc.so.6: file too short
$ LD_LIBRARY_PATH=/usr/lib ls
libc.so  libc.so.6
$ LD_LIBRARY_PATH=/usr/lib: ls
ls: error while loading shared libraries: libc.so.6: file too short
$ 

People do "LD_LIBRARY_PATH=/foo:$LD_LIBRARY_PATH" in scripts pretty often.

Comment 1 Jakub Jelinek 2002-03-04 14:17:03 UTC
According to Ulrich, this is mandated by ELF gABI:
http://sources.redhat.com/ml/libc-hacker/2002-02/msg00124.html


Note You need to log in before you can comment on or make changes to this bug.